Bug 53585 - RH7.2 RC2 will show GRUB error upon load on PL8500
RH7.2 RC2 will show GRUB error upon load on PL8500
Status: CLOSED DUPLICATE of bug 50591
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-12 08:47 EDT by Bryan Leopard
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-12 16:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested grub files (634 bytes, text/plain)
2001-10-09 10:54 EDT, chadd hudson
no flags Details

  None (edit)
Description Bryan Leopard 2001-09-12 08:47:45 EDT
System:
PL8500
P42 2-16-01
4096 mb ram
(4) 700mhz proc
SA 5300 (firmware revA v1.28) in slot 7 attached to storage box with 3 
drives configured as 1 logical
NC3134 in slot 2
Embedded array controller (firmware 1.46) with 2 drives configured as 1 
logical drive

Embedded array controller set as boot controller.

drive configuration:
cciss/c0d0p1 - 512mb swap
cciss/c0d0p2 - 16gb /home

ida/c0d0p1 - 30mb /boot (set as active)
ida/c0d0p2 - 8.6gb /

I performed a full install of RH7.2 RC2 with grub selected as the boot 
loader.  I also chose to write the kernel to the /boot partition.  System 
will attempt to boot but will give the error "GRUB hard disk error".  
System will boot correctly with the boot disk made during the install.   

When I use LILO as the boot loader I do not have any problem.
Comment 1 Bill Nottingham 2001-09-26 11:19:43 EDT
Please attach /boot/grub/grub.conf, and /boot/grub/device.map.
Comment 2 chadd hudson 2001-10-09 10:54:31 EDT
Created attachment 33623 [details]
requested grub files
Comment 3 Jeremy Katz 2001-10-12 14:21:18 EDT
What is configured as the boot controller in the BIOS for this system, the cciss
or the ida array?
Comment 4 chadd hudson 2001-10-12 16:04:30 EDT
I had used the Smart Start cd to configure the IDA (embedded array controller) 
as the boot controller.
Comment 5 Jeremy Katz 2001-10-12 16:13:57 EDT
This falls into the "boot drives not in the order anaconda expects" class of bug

*** This bug has been marked as a duplicate of 50591 ***

Note You need to log in before you can comment on or make changes to this bug.