This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 505938 - Need to package MediaAttach.
Need to package MediaAttach.
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
David Nalley
:
Depends On: 512273 516664 516665
Blocks: FE-ZIKULA
  Show dependency treegraph
 
Reported: 2009-06-14 16:22 EDT by eric@christensenplace.us
Modified: 2010-12-15 10:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-15 10:58:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Initial SPEC file. (1.79 KB, text/plain)
2009-06-15 20:48 EDT, eric@christensenplace.us
no flags Details

  None (edit)
Description eric@christensenplace.us 2009-06-14 16:22:16 EDT
Description of problem:  Need to package MediaAttach.

SVN Head: http://code.zikula.org/mediaattach/browser/trunk/MediaAttach
Comment 1 eric@christensenplace.us 2009-06-15 20:48:16 EDT
Created attachment 348035 [details]
Initial SPEC file.
Comment 2 eric@christensenplace.us 2009-06-15 20:51:13 EDT
A download is not available for this package from the Zikula website.
Comment 3 Simon Birtwistle 2009-06-16 08:01:27 EDT
We use the SVN version as prior releases are not compatible with Zikula 1.1.  I can ask the author to make a release, however he may not have the time at the moment as he's busy with a number of other tasks.

It would be quicker to build a package against revision 210 of SVN: http://code.zikula.org/mediaattach/log/trunk/MediaAttach?rev=210
Comment 4 Ian Weller 2009-07-17 15:52:49 EDT
Packaging dependency: PHP getid3 libraries, http://www.getid3.org
Comment 5 Ian Weller 2009-07-17 15:54:55 EDT
Licensing issues:

(from pndocs/credits.txt)
  -- Highslide JS                            http://vikjavev.no/highslide/
        License: Creative Commons Attribution-NonCommercial 2.5 License (http://creativecommons.org/licenses/by-nc/2.5/)
  -- JavaScript Image Cropper UI             http://www.defusion.org.uk/code/javascript-image-cropper-ui-using-prototype-scriptaculous/
        Copyright (c) 2006, David Spurr (www.defusion.org.uk)
        All rights reserved.
  -- JW FLV Player                           http://www.jeroenwijering.com/?item=JW_FLV_Player
        License: Creative Commons Attribution-NonCommercial 2.0 License (http://creativecommons.org/licenses/by-nc-sa/2.0/)
Comment 6 Ian Weller 2009-07-17 15:59:38 EDT
JS-TreeMenu, from their website:

"This software is freeware for non-commercial use."

-- http://www.gerd-tentler.de/tools/treemenu/?page=download
Comment 7 John (J5) Palmieri 2009-08-03 16:42:16 EDT
Highslide JS is just another image gallery lightbox. 

JW FLV Player should be easy to replace with http://metavid.org/w/index.php/Mv_embed and move to using the video tag.  Since we should be uploading ogg this means that we will get native ogg support depending on how the component uses the player.  Which brings me to a question.  Does anyone have these components running somewhere so I can see how they utilize the javascript libraries?

Tree menus should be easy to rewrite but I'm not sure if they are the best UI elements out there.  I would have to see this component in action.
Comment 8 John (J5) Palmieri 2009-08-03 16:52:07 EDT
Javascript side of the cropper should be easy to replace with this mit licensed cropper:

http://marqueetool.net/
Comment 9 John (J5) Palmieri 2009-08-03 17:00:53 EDT
BTW The current cropper is the new/simplified BSD license (GPL Compatible) or at least that is what he links to but the copyright notice seems to add some clauses.  I would run it through legal and contact him.
Comment 10 John (J5) Palmieri 2009-08-03 17:05:26 EDT
Actually, looking at the OSI page for the BSD license http://www.opensource.org/licenses/bsd-license.php "All rights reserved" is clearly the correct verbiage. JavaScript Image Cropper UI has the OSI approved BSD license copied verbatim so no issue there.
Comment 11 eric@christensenplace.us 2009-10-30 13:21:48 EDT
Any update on this?
Comment 12 Paul W. Frields 2009-10-30 14:00:37 EDT
Eric, Mel,

This should go on a list of issues to work with Simon on at the FUDCon Toronto 2009 event.
Comment 13 itbegins 2009-12-07 13:20:46 EST
I'm thinking we just purge the badly licensed stuff from the package and see how far we get.  This module does a lot of different stuff, and we'll only be using a small subset of the features on Fedora sites.  I don't know if there's a better short term solution to these problems.
Comment 14 eric@christensenplace.us 2009-12-07 16:52:03 EST
So it appears that these are the pieces that need to be removed:

*Highslide JS                            http://vikjavev.no/highslide/
        License: Creative Commons Attribution-NonCommercial 2.5 License (http://creativecommons.org/licenses/by-nc/2.5/)

*JavaScript Image Cropper UI             http://www.defusion.org.uk/code/javascript-image-cropper-ui-using-prototype-scriptaculous/
        Copyright (c) 2006, David Spurr (www.defusion.org.uk)
        All rights reserved.


*JW FLV Player                           http://www.jeroenwijering.com/?item=JW_FLV_Player
        License: Creative Commons Attribution-NonCommercial 2.0 License (http://creativecommons.org/licenses/by-nc-sa/2.0/)

So if we can just yank those pieces out then we should be good to go.  Everything else is LGPL or GPL+.
Comment 15 itbegins 2010-01-09 06:49:26 EST
A new version of MediaAttached has been released by the developers.  Version 1.1 solves all the licensing issues referenced in this ticket :)  See http://community.zikula.org for more info.
Comment 16 eric@christensenplace.us 2010-12-15 10:58:52 EST
This request is no longer applicable since Insight has changed platforms.

Note You need to log in before you can comment on or make changes to this bug.