Bug 506013 - liveinst crash - DBusException ... No such property HwAddress
liveinst crash - DBusException ... No such property HwAddress
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
NeedsRetesting
:
: 504935 (view as bug list)
Depends On:
Blocks: F12AnacondaBlocker
  Show dependency treegraph
 
Reported: 2009-06-15 05:15 EDT by Harald Hoyer
Modified: 2009-10-31 01:24 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-12.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 16:58:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2009-06-15 05:15:43 EDT
# liveinst

   File "/usr/lib/anaconda/isys.py", line 583, in getMacAddress
     device_macaddr = device_props_iface.Get(NM_MANAGER_IFACE, "HwAddress")
   File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
   File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
   message, timeout)
 dbus.exceptions.DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property HwAddress
Comment 1 David Cantrell 2009-06-30 17:27:50 EDT
*** Bug 504935 has been marked as a duplicate of this bug. ***
Comment 2 Eric Kerin 2009-07-16 16:19:29 EDT
I'm hitting this bug on a Lenovo T400s - with a WWAN card (/dev/TTYACM0)  I added a print statement to the loop that goes through the network devices, and it fails on the WWAN serial interface.  Checking the attached logs on the bug that is a dupe of this one, that machine also has a WWAN card.

Since it's a serial device, it does not have a hardware address listed in lshal.
Comment 3 ////// 2009-07-19 08:25:41 EDT
I get following error when I try to install fc11.


[liveuser@localhost ~]$ /usr/bin/liveinst
umount: /media/*: not found
12:58:08 Starting graphical installation...
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 876, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 300, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 65, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 343, in __init__
    available_devices = self.available()
  File "/usr/lib/anaconda/network.py", line 391, in available
    hwaddr = isys.getMacAddress(dev)
  File "/usr/lib/anaconda/isys.py", line 583, in getMacAddress
    device_macaddr = device_props_iface.Get(NM_MANAGER_IFACE, "HwAddress")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property HwAddress
[liveuser@localhost ~]$

I have Asus P5Q Deluxe motherboard.
Comment 4 Jan-Frode Myklebust 2009-07-20 19:03:18 EDT
I had the same problem on my t400, and removing the "cdc_acm" kernel module seems like an OK workaround.
Comment 5 Connor 2009-07-27 10:46:02 EDT
Experiencing this problem with Dell Inspiron mini 9, trying to install f11 via live USB stick.  Workaround of the above post does not work for me.

umount: /media/*: not found                                                                
15:41:08 Starting graphical installation...                                                
Traceback (most recent call last):                                                         
  File "/usr/sbin/anaconda", line 876, in <module>                                         
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 300, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 65, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 343, in __init__
    available_devices = self.available()
  File "/usr/lib/anaconda/network.py", line 391, in available
    hwaddr = isys.getMacAddress(dev)
  File "/usr/lib/anaconda/isys.py", line 583, in getMacAddress
    device_macaddr = device_props_iface.Get(NM_MANAGER_IFACE, "HwAddress")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property HwAddress
Comment 6 Sebo 2009-08-06 05:14:14 EDT
I had the same problem. Switching off the HW switch of the WiFi/BT/WWAN allowed me to proceed the install.
Comment 7 Connor 2009-08-07 17:32:12 EDT
(In reply to comment #6)
> I had the same problem. Switching off the HW switch of the WiFi/BT/WWAN allowed
> me to proceed the install.  

So, sorry to ask a stupid question, but did your WiFi work subseequently after the install? In the case of the Dell, obviously I'd need to get some propreitary drivers first.
Comment 8 Eric Kerin 2009-08-07 19:24:31 EDT
Yes, WIFI and WWAN worked on my T400s after the install.
Comment 9 Warren Togami 2009-10-08 18:05:11 EDT
LiveCD rawhide 20091008
Lenovo Thinkpad T61 (extra laptop sitting in a pile near ajax and krh)
anaconda-12.33-1.fc12
kernel-2.6.31.1-56.fc12.x86_64

Summary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property HwAddress

Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 891, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 302, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 64, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 342, in __init__
    available_devices = self.available()
  File "/usr/lib/anaconda/network.py", line 390, in available
    hwaddr = isys.getMacAddress(dev)
  File "/usr/lib/anaconda/isys.py", line 519, in getMacAddress
    device_macaddr = device_props_iface.Get(NM_MANAGER_IFACE, "HwAddress")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property HwAddress

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SystemBus (system) at 0x91cff2c>
args: ('org.freedesktop.NetworkManager', 'HwAddress')
utf8_strings: False
bus_name: :1.8
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: /org/freedesktop/NetworkManager/Devices/2
timeout: -1.0
signature: ss
dbus_interface: org.freedesktop.DBus.Properties
message: <dbus.lowlevel.MethodCallMessage object at 0x914e870>
method: Get
Comment 10 Radek Vykydal 2009-10-09 10:13:20 EDT
I am sending patch for review, you can try updates file for version 12.33 (using anaconda boot option updates) containing the patch:
http://rvykydal.fedorapeople.org/updates.hwaddress.img
Comment 11 Chris Lumens 2009-10-13 17:31:30 EDT
Radek - I've applied your patch via git am and pushed to both head and f12-branch.
Comment 12 Adam Williamson 2009-10-21 11:47:00 EDT
Guys, can you please test the fix for this? It's a blocker bug so we need to know if it's fixed. Chris, did the fix make it into the Beta?

Connor, I'm particularly interested if the fix works for you, as the initial workaround did not and your hardware seems different to the others. If the fix works for the others but not for you, we should get you to file a new bug, because I wouldn't want to lose your problem.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 bugzillas 2009-10-21 12:01:11 EDT
(In reply to comment #12)
> Guys, can you please test the fix for this? It's a blocker bug so we need to
> know if it's fixed. Chris, did the fix make it into the Beta?
> 

The priority and severity seem weird for a blocker bug:
 Priority:  	low   Severity: medium
Comment 14 Adam Williamson 2009-10-21 18:57:02 EDT
severity should be high, but we're not being totally consistent on that yet. however, the fact that it blocks f12blocker is the most important thing, that means we won't release f12 without either confirming the bug is fixed or coming up with a good reason why it doesn't need to be.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Eric Kerin 2009-10-21 19:08:43 EDT
Works on an external USB WWAN card on a Lenovo S10 using Fedora 12 Beta 2 LiveCD.  Tomorrow I'll track down a T400s to confirm on that hardware as well.
Comment 16 Eric Kerin 2009-10-22 12:34:32 EDT
Still does not work on the T400s.

When you start liveinst and the WWAN card is active, it crashes (NetworkManager crashes too)
When you flip the kill switch (which disconnects the device at the USB layer) the graphical install starts fine.


liveinst Backtrace:
16:12:58 Starting graphical installation.
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 878, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 302, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 64, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 276, in __init__
    devhash = isys.getDeviceProperties(dev=None)
  File "/usr/lib/anaconda/isys.py", line 456, in getDeviceProperties
    devlist = nm.get_dbus_method("GetDevices")()
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)


NetworkManager crash: 
Oct 22 16:25:42 localhost NetworkManager: <WARN>  device_creator(): /sys/devices/virtual/net/pan0: couldn't determine device driver; ignoring...
Oct 22 16:25:42 localhost NetworkManager: <info>  (usb0): carrier is OFF
Oct 22 16:25:42 localhost NetworkManager: <WARN>  device_creator(): /sys/devices/virtual/net/pan0: couldn't determine device driver; ignoring...
Oct 22 16:25:42 localhost NetworkManager: <info>  (usb0): carrier is OFF
Oct 22 16:25:43 localhost NetworkManager: <WARN>  nm_signal_handler(): Caught signal 11.  Generating backtrace...
Oct 22 16:25:43 localhost NetworkManager: ******************* START **********************************
Oct 22 16:25:43 localhost NetworkManager: [Thread debugging using libthread_db enabled]
Oct 22 16:25:43 localhost NetworkManager: [New Thread 0xb7f8ab70 (LWP 2491)]
Oct 22 16:25:43 localhost NetworkManager: 0x0087b416 in __kernel_vsyscall ()
Oct 22 16:25:43 localhost NetworkManager: #0  0x0087b416 in __kernel_vsyscall ()
Oct 22 16:25:43 localhost NetworkManager: #1  0x0069903b in waitpid () from /lib/libpthread.so.0
Oct 22 16:25:43 localhost NetworkManager: #2  0x08081899 in nm_logging_backtrace ()
Oct 22 16:25:43 localhost NetworkManager: #3  0x0807b1ad in ?? ()
Oct 22 16:25:43 localhost NetworkManager: #4  <signal handler called>
Oct 22 16:25:43 localhost NetworkManager: #5  0x0805d890 in nm_device_get_path ()
Oct 22 16:25:43 localhost NetworkManager: #6  0x080820eb in ?? ()
Oct 22 16:25:43 localhost NetworkManager: #7  0x0808767f in dbus_glib_marshal_nm_manager_BOOLEAN__POINTER_POINTER ()
Oct 22 16:25:43 localhost NetworkManager: #8  0x001642d1 in invoke_object_method (object=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     object_info=<value optimized out>, method=0x80bb7c0, connection=0x8d1ed20,
Oct 22 16:25:43 localhost NetworkManager:     message=0x8d360b0) at dbus-gobject.c:1446
Oct 22 16:25:43 localhost NetworkManager: #9  0x00164b31 in object_registration_message (connection=0x8d1ed20,
Oct 22 16:25:43 localhost NetworkManager:     message=0x8d360b0, user_data=0x8d16a00) at dbus-gobject.c:1598
Oct 22 16:25:43 localhost NetworkManager: #10 0x00198751 in _dbus_object_tree_dispatch_and_unlock (
Oct 22 16:25:43 localhost NetworkManager:     tree=<value optimized out>, message=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at dbus-object-tree.c:856
Oct 22 16:25:43 localhost NetworkManager: #11 0x0018b15a in dbus_connection_dispatch (connection=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at dbus-connection.c:4485
Oct 22 16:25:43 localhost NetworkManager: #12 0x0016120e in message_queue_dispatch (source=0x8d20688, callback=0,
Oct 22 16:25:43 localhost NetworkManager:     user_data=0x0) at dbus-gmain.c:101
Oct 22 16:25:43 localhost NetworkManager: #13 0x005c9118 in g_main_dispatch (context=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at gmain.c:1960
Oct 22 16:25:43 localhost NetworkManager: #14 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
Oct 22 16:25:43 localhost NetworkManager: #15 0x005cca48 in g_main_context_iterate (context=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     block=<value optimized out>, dispatch=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     self=<value optimized out>) at gmain.c:2591
Oct 22 16:25:43 localhost NetworkManager: #16 0x005ccebf in IA__g_main_loop_run (loop=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at gmain.c:2799
Oct 22 16:25:43 localhost NetworkManager: #17 0x0807bcab in main ()
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: Thread 2 (Thread 0xb7f8ab70 (LWP 2491)):
Oct 22 16:25:43 localhost NetworkManager: #0  0x0087b416 in __kernel_vsyscall ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #1  0x0069818b in read () from /lib/libpthread.so.0
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #2  0x005ca0da in read (__nbytes=20, __buf=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     __fd=<value optimized out>) at /usr/include/bits/unistd.h:45
Oct 22 16:25:43 localhost NetworkManager: No locals.
Oct 22 16:25:43 localhost NetworkManager: #3  child_watch_helper_thread (__nbytes=20, __buf=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     __fd=<value optimized out>) at gmain.c:3822
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         list = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: #4  0x005f3a30 in g_thread_create_proxy (data=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at gthread.c:635
Oct 22 16:25:43 localhost NetworkManager:         thread = 0x8d1e600
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: #5  0x006909d5 in start_thread () from /lib/libpthread.so.0
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #6  0x0108769e in clone () from /lib/libc.so.6
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: Thread 1 (Thread 0xb7f8b780 (LWP 2488)):
Oct 22 16:25:43 localhost NetworkManager: #0  0x0087b416 in __kernel_vsyscall ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #1  0x0069903b in waitpid () from /lib/libpthread.so.0
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #2  0x08081899 in nm_logging_backtrace ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #3  0x0807b1ad in ?? ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #4  <signal handler called>
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #5  0x0805d890 in nm_device_get_path ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #6  0x080820eb in ?? ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #7  0x0808767f in dbus_glib_marshal_nm_manager_BOOLEAN__POINTER_POINTER ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: #8  0x001642d1 in invoke_object_method (object=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     object_info=<value optimized out>, method=0x80bb7c0, connection=0x8d1ed20,
Oct 22 16:25:43 localhost NetworkManager:     message=0x8d360b0) at dbus-gobject.c:1446
Oct 22 16:25:43 localhost NetworkManager:         had_error = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         gerror = 0x0
Oct 22 16:25:43 localhost NetworkManager:         value_array = 0x8d441a0
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: v_float = 0,
Oct 22 16:25:43 localhost NetworkManager: v_uint = 0,
Oct 22 16:25:43 localhost NetworkManager: v_float = 0,
Oct 22 16:25:43 localhost NetworkManager: v_pointer = 0x0}}}
Oct 22 16:25:43 localhost NetworkManager: n_guards = 0,
Oct 22 16:25:43 localhost NetworkManager: floating = 0,
Oct 22 16:25:43 localhost NetworkManager: is_invalid = 0, marshal = 0,
Oct 22 16:25:43 localhost NetworkManager: notifiers = 0x0}
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         out_param_values = 0x8d38568
Oct 22 16:25:43 localhost NetworkManager:         out_param_gvalues = 0x8d389b0
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         result = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         reply = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         arg_metadata = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: #9  0x00164b31 in object_registration_message (connection=0x8d1ed20,
Oct 22 16:25:43 localhost NetworkManager:     message=0x8d360b0, user_data=0x8d16a00) at dbus-gobject.c:1598
Oct 22 16:25:43 localhost NetworkManager:         pspec = 0x0
Oct 22 16:25:43 localhost NetworkManager:         object = 0x8d23000
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         getter = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         s = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         wincaps_propname = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         wincaps_propiface = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: dummy3 = 3217912392,
Oct 22 16:25:43 localhost NetworkManager: dummy6 = 147974872,
Oct 22 16:25:43 localhost NetworkManager: dummy9 = 147975072,
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: pad3 = 0x1c0ff4}
Oct 22 16:25:43 localhost NetworkManager:         method = 0x80bb7c0
Oct 22 16:25:43 localhost NetworkManager:         object_info = 0x80bb190
Oct 22 16:25:43 localhost NetworkManager:         ret = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: #10 0x00198751 in _dbus_object_tree_dispatch_and_unlock (
Oct 22 16:25:43 localhost NetworkManager:     tree=<value optimized out>, message=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager: e.c:856
Oct 22 16:25:43 localhost NetworkManager:         message_function = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         user_data = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         next = 0x0
Oct 22 16:25:43 localhost NetworkManager:         path = 0x8d28a80
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         list = 0x8d3021c
Oct 22 16:25:43 localhost NetworkManager:         link = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         result = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         subtree = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: #11 0x0018b15a in dbus_connection_dispatch (connection=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at dbus-connection.c:4485
Oct 22 16:25:43 localhost NetworkManager:         message = 0x8d360b0
Oct 22 16:25:43 localhost NetworkManager:         link = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         filter_list_copy = 0x0
Oct 22 16:25:43 localhost NetworkManager:         message_link = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         result = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         pending = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: ized out>
Oct 22 16:25:43 localhost NetworkManager:         status = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: #12 0x0016120e in message_queue_dispatch (source=0x8d20688, callback=0,
Oct 22 16:25:43 localhost NetworkManager:     user_data=0x0) at dbus-gmain.c:101
Oct 22 16:25:43 localhost NetworkManager:         connection = 0x8d1ed20
Oct 22 16:25:43 localhost NetworkManager: #13 0x005c9118 in g_main_dispatch (context=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at gmain.c:1960
Oct 22 16:25:43 localhost NetworkManager:         dispatch = 0x1611e0 <message_queue_dispatch>
Oct 22 16:25:43 localhost NetworkManager:         user_data = 0x0
Oct 22 16:25:43 localhost NetworkManager:         callback = 0
Oct 22 16:25:43 localhost NetworkManager:         cb_funcs = 0x0
Oct 22 16:25:43 localhost NetworkManager:         cb_data = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: next = 0x0}
Oct 22 16:25:43 localhost NetworkManager:         source = 0x8d20688
Oct 22 16:25:43 localhost NetworkManager:         current = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         i = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager: #14 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
Oct 22 16:25:43 localhost NetworkManager: No locals.
Oct 22 16:25:43 localhost NetworkManager: #15 0x005cca48 in g_main_context_iterate (context=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     block=<value optimized out>, dispatch=<value optimized out>,
Oct 22 16:25:43 localhost NetworkManager:     self=<value optimized out>) at gmain.c:2591
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager:         nfds = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         allocated_nfds = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:         fds = <value optimized out>
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: #16 0x005ccebf in IA__g_main_loop_run (loop=<value optimized out>)
Oct 22 16:25:43 localhost NetworkManager:     at gmain.c:2799
Oct 22 16:25:43 localhost NetworkManager:         self = 0x8d15180
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: #17 0x0807bcab in main ()
Oct 22 16:25:43 localhost NetworkManager: No symbol table info available.
Oct 22 16:25:43 localhost NetworkManager: A debugging session is active.
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: #011Inferior 1 [process 2488] will be detached.
Oct 22 16:25:43 localhost NetworkManager:
Oct 22 16:25:43 localhost NetworkManager: Quit anyway? (y or n) [answered Y; input not from terminal]
Oct 22 16:25:43 localhost NetworkManager: ******************* END **********************************
Comment 17 Adam Williamson 2009-10-22 17:58:48 EDT
thanks for testing, setting back to ASSIGNED...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Connor 2009-10-22 18:13:54 EDT
(In reply to comment #12)
> Guys, can you please test the fix for this? It's a blocker bug so we need to
> know if it's fixed. Chris, did the fix make it into the Beta?
> 
> Connor, I'm particularly interested if the fix works for you, as the initial
> workaround did not and your hardware seems different to the others. If the fix
> works for the others but not for you, we should get you to file a new bug,
> because I wouldn't want to lose your problem.
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers  

Hi,

I was actually installing or attempting to for someone else. I've only been using linux and fedora for a year, so my abilities can't really stretch beyond copy and paste for this problem. I'll be able to have another try on Wednesday, and can post an update then as to what happens. If I just check that the F12 beta graphical installer boots up fine, will that be enough? It's a friend who uses Fedora on their desktop and wanted it on their netbook but encountered this problem, pretty much...
Comment 19 Adam Williamson 2009-10-22 18:32:04 EDT
Yup, that's really all you need to do. If you still have the problem, just file a new bug with the error message included.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Adam Williamson 2009-10-22 18:32:53 EDT
er, actually, since the initial fix doesn't seem to be complete yet, don't file a new bug even if you hit the problem :) but a note of whether you have the problem still or not will be useful.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Radek Vykydal 2009-10-23 05:13:59 EDT
The crash in comment #16 occurs before the patched code is executed, so it seems like different (NM?) bug to me.

The patch is in version 12.38, which is post-beta, beta has 12.37.
Comment 22 Eric Kerin 2009-10-23 07:46:11 EDT
This happens doing a LiveCD based install.  I just confirmed, the LiveCD image for Beta2 has anaconda-12.38-1.fc12.
Comment 23 Radek Vykydal 2009-10-23 08:12:55 EDT
(In reply to comment #22)
> This happens doing a LiveCD based install.  I just confirmed, the LiveCD image
> for Beta2 has anaconda-12.38-1.fc12.  

Aha, OK, thanks. Anyway, as I said, your last traceback seems to point to another issue than this bug - I've prepared updates image with the patch removed. Retest using it (by adding updates=<updates_image_url> to anaconda boot options) could confirm it, although I am pretty sure about it.

http://rvykydal.fedorapeople.org/updates.nohwaddress.img
Comment 24 Eric Kerin 2009-10-23 10:34:45 EDT
I just tried this (I backed out the patch by hand, removing the pyc and pyo files) and it still crashed NetworkManager.  So a new bug was definitely introduced since this was found.  I'll try using older versions of NetworkManager from koji and see if I can track down where this was introduced.
Comment 25 Eric Kerin 2009-10-23 11:27:52 EDT
Good News!  NetworkManager-0.7.996-5.git20091021.fc12 fixes the crash.  Combined with the Anaconda patch, the installer starts correctly.  I tried it with the anaconda patch rolled back, and it went back to the "No Such Property HwAddress" behavior.

There aren't any nightly composes with the updated network manager yet, but I'll double check after they get built.
Comment 26 Radek Vykydal 2009-10-23 11:31:38 EDT
That's great! Thanks a lot for your testing Eric.
Comment 27 Adam Williamson 2009-10-23 11:48:05 EDT
Discussed at blocker meeting today. Looks like it's fixed, we need anaconda team to request a tag for 12.39 so it gets into Rawhide and a newer nightly build can be tested.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Connor 2009-10-25 16:46:08 EDT
Hi,
It's actually going to have to be Friday for my testing out. I very strongly suspect its going to work anyway, but I'll let you know.
Comment 29 Eric Kerin 2009-10-26 12:49:12 EDT
Just tested, it's working perfect in the desktop-i386-20091024.19.iso nightly livecd on my T400s.
Comment 30 Adam Williamson 2009-10-28 16:58:49 EDT
I think we can close this based on feedback so far, 12.39 has been tagged. I think if anyone sees a similar issue with anaconda 12.39+ it'd be best to open a new bug. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 31 Connor 2009-10-30 19:21:56 EDT
Hi,

Just to let you know the patch works fine on the Dell netbook.

Connor
Comment 32 Adam Williamson 2009-10-31 01:24:51 EDT
excellent, that's useful - thanks for following up.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.