Bug 504935 - Live install backtrace when there's a wireless card without firmware
Live install backtrace when there's a wireless card without firmware
Status: CLOSED DUPLICATE of bug 506013
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 505454 507081 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 00:19 EDT by Sijis Aviles
Modified: 2009-06-30 17:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 17:27:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cli output liveinst and anaconda (4.22 KB, text/plain)
2009-06-10 00:19 EDT, Sijis Aviles
no flags Details
Sosreport of system. (426.87 KB, application/x-bzip)
2009-06-10 13:09 EDT, Sijis Aviles
no flags Details

  None (edit)
Description Sijis Aviles 2009-06-10 00:19:17 EDT
Created attachment 347148 [details]
cli output liveinst and anaconda

Description of problem:
I'm unable to launch the "Install to Hard Drive" on the liveCD feature to install Fedora 11 (F11).

Version-Release number of selected component (if applicable):
[liveuser@localhost Desktop]$ rpm -qa | grep anaconda
busybox-anaconda-1.13.2-2.fc11.i386
anaconda-yum-plugins-1.0-4.fc11.noarch
anaconda-11.5.0.59-1.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. Boot computer using i686 LiveCD
2. Double-click on "Install to Hard Drive" 
  
Actual results:
No output to screen. No error/warning.

Expected results:
Begin install wizard

Additional info:
The only way I was able to notice that there was an issue was running the installer through the cli as root. Regardless if I ran "/usr/bin/liveinst" or "anaconda" the error was the same.
Comment 1 Sijis Aviles 2009-06-10 00:28:52 EDT
As an added note, I'm using a Dell Latitude D620 with a Core Duo and 2GB RAM.
Comment 2 Jeremy Katz 2009-06-10 11:09:11 EDT
Was NetworkManager running?
Comment 3 Sijis Aviles 2009-06-10 13:09:18 EDT
Created attachment 347258 [details]
Sosreport of system.
Comment 4 Sijis Aviles 2009-06-10 13:09:57 EDT
Yes, it was running last night.
Its running now too.

[root@localhost liveuser]# service NetworkManager status
NetworkManager (pid  2463) is running...
[root@localhost liveuser]# service network status
Configured devices:
lo
Currently active devices:
lo eth0
[root@localhost liveuser]# chkconfig --list | grep -i "network"
NetworkManager 	0:off	1:off	2:on	3:on	4:on	5:on	6:off
network        	0:off	1:off	2:off	3:off	4:off	5:off	6:off
[root@localhost liveuser]# 

The only network related oddity is that it appears that my wireless network card is detected but not loaded and it isn't able to 'see' any wireless networks (for obvious reasons). Although currently I'm plugged in and using it to update this bug.

Yesterday I was trying to install using the wireless. I'm trying again right now and i'm getting the same error as last night. I also stopped NetworkManager and started network service but i wasn't able to get a networking connection.
I'll upload the sosreport from last night if that's of any use.
Comment 5 Jeremy Katz 2009-06-10 14:33:51 EDT
Ah, b43 wireless which we can't ship the firmware for.  I suspect NetworkManager is sort of seeing the device but not entirely (since there's no firmware) and we're not catching an exception we should.
Comment 6 Sijis Aviles 2009-06-10 14:53:07 EDT
When i was trying earlier today i was plugged in. I just wanted to make that clear.

What other information do you need from me?
Comment 7 Jeremy Katz 2009-06-16 11:00:54 EDT
*** Bug 505454 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2009-06-22 16:34:42 EDT
*** Bug 507081 has been marked as a duplicate of this bug. ***
Comment 9 David Cantrell 2009-06-30 17:27:50 EDT
Based on the traceback in the opening comment, this is a dupe of 506013.

*** This bug has been marked as a duplicate of bug 506013 ***

Note You need to log in before you can comment on or make changes to this bug.