Bug 506195 - nash network fails to configure default gateway
nash network fails to configure default gateway
Status: CLOSED DUPLICATE of bug 501033
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 20:01 EDT by Ed Swierk
Modified: 2009-06-16 04:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 04:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix nash network command to set the default gateway properly (423 bytes, patch)
2009-06-15 20:01 EDT, Ed Swierk
no flags Details | Diff

  None (edit)
Description Ed Swierk 2009-06-15 20:01:59 EDT
Created attachment 348033 [details]
Fix nash network command to set the default gateway properly

The nash network command in mkinitrd-6.0.86-2.fc11 fails to configure the default gateway when booting from an NFS server.

nashSetupInterface() calls rtnl_route_add(), which returns -3 (ESRCH), leaving the routing table without an entry for the default gateway.

The attached patch fixes the problem by setting the scope of the default route to RT_SCOPE_UNIVERSE.
Comment 1 Hans de Goede 2009-06-16 04:10:29 EDT
Hi we already have a bug tracking this, thanks for the patch!

*** This bug has been marked as a duplicate of bug 501033 ***

Note You need to log in before you can comment on or make changes to this bug.