Bug 501033 - nash does not set default gw when configuring network interfaces
nash does not set default gw when configuring network interfaces
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 503109 506195 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-15 11:18 EDT by Hans de Goede
Modified: 2009-07-11 13:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: 6.0.87-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 13:20:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2009-05-15 11:18:43 EDT
Since the rewrite of the nash network code to no longer use libdhcp, nash
no longer sets the default gw when configuring the network (happens with
both static as well as dhcp configurations).

dcantrell, as you did the rework of the network code to no longer use libdhcp, I'm assigning this to you.
Comment 1 Hans de Goede 2009-06-01 08:43:14 EDT
*** Bug 503109 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2009-06-09 11:53:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Hans de Goede 2009-06-16 04:10:29 EDT
*** Bug 506195 has been marked as a duplicate of this bug. ***
Comment 4 Hans de Goede 2009-06-16 04:11:04 EDT
David note: bug 506195 has a patch for this!
Comment 5 Hans de Goede 2009-06-16 08:31:38 EDT
I've reviewed the patch from bug 506195 and it looks ok, since I needed to do
a new mkinitrd build anyways I've applied the patch. I'll push an update to updates-testing which should fix this, please let me know if this fixes things or not.
Comment 6 Fedora Update System 2009-06-16 08:33:07 EDT
mkinitrd-6.0.87-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mkinitrd-6.0.87-1.fc11
Comment 7 Fedora Update System 2009-06-18 07:55:22 EDT
mkinitrd-6.0.87-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mkinitrd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6652
Comment 8 Andy Lindeberg 2009-07-07 10:57:43 EDT
*** Bug 510039 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2009-07-11 13:20:32 EDT
mkinitrd-6.0.87-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.