This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506196 - Missing dependency -- freshclam (clamav-update)
Missing dependency -- freshclam (clamav-update)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: clamtk (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Jerome Soyer
Fedora Extras Quality Assurance
:
: 517842 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 20:30 EDT by Denny Crane
Modified: 2010-01-31 20:12 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.23-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-31 20:04:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denny Crane 2009-06-15 20:30:43 EDT
Description of problem:
If the user selects clamtk through the package installer, not all of the dependencies are installed. Specifically, the freshclam program is needed or the GUI will not start at all (fails silently). If run from the command line, this becomes obvious. Solution is to install clamav-update.


Version-Release number of selected component (if applicable):
4.10-1


How reproducible:


Steps to Reproduce:
1.Install clamtk by itself.
2.Attempt to run clamtk GUI
3.Attempt to run from command line.
  
Actual results:
Attempt to run through GUI: silently fails.
Attempt to run from command line: error states that freshclam is needed.


Expected results:
GUI works/no error.


Additional info:
Comment 1 Denny Crane 2009-08-23 22:27:26 EDT
Hello? This seems like an easy fix, yet it has been ignored despite the fact that the package is 100% useless to most of the target audience who wouldn't be running things from a command line to see how to fix the problem.
Comment 2 Dave M 2009-10-04 12:27:07 EDT
For some reason, that dependency was removed from the upstream rpm spec.

Current: http://cvs.fedoraproject.org/viewvc/rpms/clamtk/F-11/clamtk.spec?revision=1.4&view=markup

Upstream: http://clamtk.sf.net/clamtk.spec

I'll see if I can contact the packager.
Comment 3 Till Maas 2009-11-07 15:33:17 EST
*** Bug 517842 has been marked as a duplicate of this bug. ***
Comment 4 Jerry Amundson 2009-12-11 00:13:44 EST
(In reply to comment #2)
> For some reason, that dependency was removed from the upstream rpm spec.

So? Please fix it here, where it matters.
Comment 5 Dave M 2009-12-11 07:45:37 EST
I didn't break it, so I can't fix it. Yet.

https://bugzilla.redhat.com/show_bug.cgi?id=530709

https://bugzilla.redhat.com/show_bug.cgi?id=536694

Once approved, I'll (at least temporarily) take over maintaining it here until someone else wants to. Frankly I'd rather just work on it upstream, but if I have to maintain it here too to make sure there is one less broken package in Fedora, so be it.
Comment 6 Jerry Amundson 2009-12-16 11:29:20 EST
(In reply to comment #5)
> I didn't break it, so I can't fix it. Yet.

OK, that makes sense. Thanks for the update.
Comment 7 Fedora Update System 2010-01-27 22:05:23 EST
clamtk-4.23-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/clamtk-4.23-1.fc12
Comment 8 Fedora Update System 2010-01-27 22:05:28 EST
clamtk-4.23-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/clamtk-4.23-1.fc11
Comment 9 Fedora Update System 2010-01-28 22:30:23 EST
clamtk-4.23-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-1210
Comment 10 Fedora Update System 2010-01-28 22:33:53 EST
clamtk-4.23-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamtk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1220
Comment 11 Fedora Update System 2010-01-31 20:04:26 EST
clamtk-4.23-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-01-31 20:12:21 EST
clamtk-4.23-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.