Bug 506264 - Channel Product Name Data Seems to be Missing For Inter Satellite Sync
Channel Product Name Data Seems to be Missing For Inter Satellite Sync
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Shannon Hughes
:
: 508939 509362 (view as bug list)
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-06-16 09:48 EDT by Devan Goodwin
Modified: 2010-06-16 05:30 EDT (History)
6 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:04:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-06-16 09:48:33 EDT
Description of problem:

After satellite-sync'ing RHEL 5 Server using ISS from an existing Satellite, the PRODUCT_NAME_ID column in rhnChannel on the slave is set to NULL.

Version-Release number of selected component (if applicable):

Somewhat older 530 build for the master Satellite: Satellite-5.3.0-RHEL5-re20090414.0-i386-embedded-oracle.iso

How reproducible:

Unknown.

Steps to Reproduce:
1. Configure Inter-Satellite Sync on a Satellite with rhel-i386-server-5 synced.
2. Sync rhel-i386-server-5 to a slave Satellite.
3. Check PRODUCT_NAME_ID column in rhnChannel.
  
Actual results:

NULL

Expected results:

Product name eventually pointing to "Enterprise Linux".

Additional info:

Noticed this as all other channels on my Satellite (which were obtained from webqa) got product name populated as expected. 

Checked in /var/cache/rhn/xml-channels/rhn-channel-ID.xml on the master, can't find any reference to "product" at all.

This is a 2 month old Satellite build, so apologies if this has already been fixed.

Will cause problems for EUS at least.
Comment 3 Shannon Hughes 2009-06-30 12:36:08 EDT
not working. we need to update a query in importLib to update the product_name_id if its not equal to the incoming value OR its null.
Comment 5 Miroslav Suchý 2009-07-01 09:15:19 EDT
*** Bug 508939 has been marked as a duplicate of this bug. ***
Comment 6 Miroslav Suchý 2009-07-02 11:06:44 EDT
*** Bug 509362 has been marked as a duplicate of this bug. ***
Comment 7 Shannon Hughes 2009-07-10 16:08:21 EDT
looks good now, no null values for PRODUCT_NAME_ID on the rhnChannel table after a slave sync to master
Comment 8 Steve Salevan 2009-08-13 15:18:07 EDT
RELEASE_PENDING from latest Stage build.
Comment 9 Brandon Perkins 2009-09-10 16:04:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.