Bug 506359 - pidgin segfault on startup, gstreamer-0.10/libgstwavpack.so
pidgin segfault on startup, gstreamer-0.10/libgstwavpack.so
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 16:51 EDT by Leif Gruenwoldt
Modified: 2010-02-15 05:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-07 07:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leif Gruenwoldt 2009-06-16 16:51:05 EDT
Description of problem:

On a fresh install of fedora 11, pidgin crashes on startup.


Version-Release number of selected component (if applicable):

$ rpm -q pidgin
pidgin-2.5.6-1.fc11.i586


How reproducible:

Everytime.


Steps to Reproduce:
1. $ pidgin
  
Actual results:

$ pidgin

(pidgin:13555): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstwavpack.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.


Expected results:

pidgin should start.

Additional info:

$ pidgin -d
(16:43:48) prefs: Reading /home/leif/.purple/prefs.xml
(16:43:48) prefs: Reading /etc/purple/prefs.xml
(16:43:48) prefs: Finished reading /etc/purple/prefs.xml
(16:43:48) dbus: okkk
(16:43:48) plugins: probing /usr/lib/pidgin/convcolors.so
(16:43:48) plugins: probing /usr/lib/pidgin/history.so
(16:43:48) plugins: probing /usr/lib/pidgin/pidginrc.so
(16:43:48) plugins: probing /usr/lib/pidgin/markerline.so
(16:43:48) plugins: probing /usr/lib/pidgin/spellchk.so
(16:43:48) plugins: probing /usr/lib/pidgin/musicmessaging.so
(16:43:48) plugins: probing /usr/lib/pidgin/sendbutton.so
(16:43:48) plugins: probing /usr/lib/pidgin/ticker.so
(16:43:48) plugins: probing /usr/lib/pidgin/iconaway.so
(16:43:48) plugins: probing /usr/lib/pidgin/notify.so
(16:43:48) plugins: probing /usr/lib/pidgin/gestures.so
(16:43:48) plugins: probing /usr/lib/pidgin/timestamp.so
(16:43:48) plugins: probing /usr/lib/pidgin/gevolution.so
(16:43:48) plugins: probing /usr/lib/pidgin/extplacement.so
(16:43:48) plugins: probing /usr/lib/pidgin/timestamp_format.so
(16:43:48) plugins: probing /usr/lib/pidgin/xmppconsole.so
(16:43:48) plugins: probing /usr/lib/pidgin/gtkbuddynote.so
(16:43:48) plugins: probing /usr/lib/purple-2/libmyspace.so
(16:43:48) plugins: probing /usr/lib/purple-2/libaim.so
(16:43:48) plugins: probing /usr/lib/purple-2/dbus-example.so
(16:43:48) plugins: probing /usr/lib/purple-2/offlinemsg.so
(16:43:48) plugins: probing /usr/lib/purple-2/libnovell.so
(16:43:48) plugins: probing /usr/lib/purple-2/idle.so
(16:43:48) plugins: probing /usr/lib/purple-2/liboscar.so
(16:43:48) plugins: /usr/lib/purple-2/liboscar.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:43:48) plugins: probing /usr/lib/purple-2/libicq.so
(16:43:48) plugins: probing /usr/lib/purple-2/libgg.so
(16:43:48) plugins: probing /usr/lib/purple-2/log_reader.so
(16:43:48) plugins: probing /usr/lib/purple-2/joinpart.so
(16:43:48) plugins: probing /usr/lib/purple-2/ssl-nss.so
(16:43:48) plugins: probing /usr/lib/purple-2/libxmpp.so
(16:43:48) util: Reading file xmpp-caps.xml from directory /home/leif/.purple
(16:43:48) util: File /home/leif/.purple/xmpp-caps.xml does not exist (this is not necessarily an error)
(16:43:48) jabber: creating hash tables for data objects
(16:43:48) plugins: probing /usr/lib/purple-2/libsametime.so
(16:43:48) plugins: /usr/lib/purple-2/libsametime.so has a prefs_info, but is a prpl. This is no longer supported.
(16:43:48) plugins: probing /usr/lib/purple-2/libjabber.so
(16:43:48) plugins: /usr/lib/purple-2/libjabber.so is not usable because the 'purple_init_plugin' symbol could not be found.  Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:43:48) plugins: probing /usr/lib/purple-2/buddynote.so
(16:43:48) plugins: probing /usr/lib/purple-2/libsilcpurple.so
(16:43:48) plugins: probing /usr/lib/purple-2/libbonjour.so
(16:43:48) plugins: probing /usr/lib/purple-2/libirc.so
(16:43:48) plugins: probing /usr/lib/purple-2/libyahoo.so
(16:43:48) plugins: probing /usr/lib/purple-2/libqq.so
(16:43:48) plugins: probing /usr/lib/purple-2/libzephyr.so
(16:43:48) plugins: probing /usr/lib/purple-2/ssl.so
(16:43:48) plugins: probing /usr/lib/purple-2/libsimple.so
(16:43:48) plugins: probing /usr/lib/purple-2/statenotify.so
(16:43:48) plugins: probing /usr/lib/purple-2/psychic.so
(16:43:48) plugins: probing /usr/lib/purple-2/newline.so
(16:43:48) plugins: probing /usr/lib/purple-2/autoaccept.so
(16:43:48) plugins: probing /usr/lib/purple-2/libmsn.so
(16:43:48) plugins: probing /usr/lib/purple-2/one_time_password.so
(16:43:48) prefs: /purple/status/scores/offline changed, scheduling save.
(16:43:48) prefs: /purple/status/scores/available changed, scheduling save.
(16:43:48) prefs: /purple/status/scores/invisible changed, scheduling save.
(16:43:48) prefs: /purple/status/scores/away changed, scheduling save.
(16:43:48) prefs: /purple/status/scores/extended_away changed, scheduling save.
(16:43:48) prefs: /purple/status/scores/idle changed, scheduling save.
(16:43:48) prefs: /purple/status/scores/offline_msg changed, scheduling save.
(16:43:48) util: Reading file accounts.xml from directory /home/leif/.purple
(16:43:48) util: File /home/leif/.purple/accounts.xml does not exist (this is not necessarily an error)
(16:43:48) util: Reading file status.xml from directory /home/leif/.purple
(16:43:48) util: File /home/leif/.purple/status.xml does not exist (this is not necessarily an error)
(16:43:48) certificate: CertificateVerifier x509, singleuse requested but not found.
(16:43:48) certificate: CertificateVerifier singleuse registered
(16:43:48) certificate: CertificatePool x509, ca requested but not found.
(16:43:48) certificate: CertificateScheme x509 requested but not found.
(16:43:48) certificate/x509/ca: Lazy init failed because an X.509 Scheme is not yet registered. Maybe it will be better later.
(16:43:48) certificate/x509/ca: Init failed, probably because a dependency is not yet registered. It has been deferred to later.
(16:43:48) certificate: CertificatePool ca registered
(16:43:48) certificate: CertificatePool x509, tls_peers requested but not found.
(16:43:48) certificate: CertificatePool tls_peers registered
(16:43:48) certificate: CertificateVerifier x509, tls_cached requested but not found.
(16:43:48) certificate: CertificateVerifier tls_cached registered
(16:43:48) prefs: /purple/logging/format changed, scheduling save.
(16:43:48) prefs: /purple/logging/format changed, scheduling save.
(16:43:48) prefs: /purple/proxy/type changed, scheduling save.
(16:43:48) prefs: /purple/proxy/host changed, scheduling save.
(16:43:48) prefs: /purple/proxy/port changed, scheduling save.
(16:43:48) prefs: /purple/proxy/username changed, scheduling save.
(16:43:48) prefs: /purple/proxy/password changed, scheduling save.
(16:43:48) certificate: CertificateScheme x509 requested but not found.
(16:43:48) certificate: CertificateScheme x509 registered
(16:43:48) util: Reading file smileys.xml from directory /home/leif/.purple
(16:43:48) util: File /home/leif/.purple/smileys.xml does not exist (this is not necessarily an error)
(16:43:48) stun: using server 
(16:43:48) sound: Initializing sound output drivers.
(16:43:48) GLib-GObject: cannot register existing type `GstRTPSirenPay'
(16:43:48) GLib: g_once_init_leave: assertion `initialization_value != 0' failed

(pidgin:13520): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstwavpack.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
Comment 1 Leif Gruenwoldt 2009-06-16 16:58:09 EDT
This is beginning to look like a gstreamer bug. Rhythmbox is crashing with similar error:

$ rhythmbox

(rhythmbox:13583): GLib-GObject-WARNING **: cannot register existing type `GstRTPSirenPay'

(rhythmbox:13583): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(rhythmbox:13583): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstwavpack.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
Error re-scanning registry , child terminated by signal
Run 'rhythmbox --help' to see a full list of available command line options.
Comment 2 Leif Gruenwoldt 2009-06-17 09:10:35 EDT
Just noticed my /var/log/messages is filled with these:

Jun 16 17:00:46 jug pulseaudio[2775]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio0': Input/output error
Comment 3 Leif Gruenwoldt 2009-06-17 10:24:32 EDT
Good news and bad news. 

The good news is pidgin, rhytmbox, empathy and any other gstreamer apps are now working. 

The bad news is I'm not sure why exactly. I was taking a break from debugging the problem and decided to follow a F11 install guide to setup the rest of my system (http://www.mjmwired.net/resources/mjm-fedora-f11.html). One (or more) of the packages that got installed seem to have fixed the problem. Here's my yum activity for the day:


$ sudo yum install yum-presto
$ sudo yum install yum-plugin-fastestmirror
$ sudo yum install rhythmbox gstreamer-plugins-ugly gstreamer-plugins-bad gstreamer-ffmpeg
$ sudo yum install mplayer mencoder -y
$ sudo yum install libdvdcss
$ sudo yum install flash-plugin


$ grep "Jun 17" /var/log/yum.log
Jun 17 09:38:44 Installed: yum-presto-0.4.5-4.fc11.noarch
Jun 17 09:39:06 Installed: yum-plugin-fastestmirror-1.1.22-1.fc11.noarch
Jun 17 09:48:31 Installed: libdvdread-4.1.3-2.fc11.i586
Jun 17 09:48:32 Installed: x264-libs-0.0.0-0.24.20090319gitc109c8.fc11.i586
Jun 17 09:48:33 Installed: 1:faad2-libs-2.7-1.fc11.i586
Jun 17 09:48:33 Installed: lame-libs-3.98.2-3.fc11.i586
Jun 17 09:48:34 Installed: xvidcore-1.2.1-2.fc11.i586
Jun 17 09:48:35 Installed: libdc1394-2.1.0-1.fc11.i586
Jun 17 09:48:35 Installed: libdvdnav-4.1.3-2.fc11.i586
Jun 17 09:48:36 Installed: libsysfs-2.1.0-5.fc11.i586
Jun 17 09:48:37 Installed: libmpeg2-0.5.1-7.fc11.1.i586
Jun 17 09:48:37 Installed: schroedinger-1.0.6-1.fc11.i586
Jun 17 09:48:38 Installed: libmad-0.15.1b-11.fc11.i586
Jun 17 09:48:38 Installed: lzo-minilzo-2.03-2.fc11.i586
Jun 17 09:48:39 Installed: libvncserver-0.9.1-4.fc11.i586
Jun 17 09:48:41 Installed: directfb-1.2.7-4.fc11.i586
Jun 17 09:48:43 Installed: fftw-3.2.1-2.fc11.i586
Jun 17 09:48:43 Installed: libofa-0.9.3-15.fc11.i586
Jun 17 09:48:44 Installed: libmp4v2-1.5.0.1-8.fc11.i586
Jun 17 09:48:45 Installed: faac-1.28-1.fc11.1.i586
Jun 17 09:48:46 Installed: libmms-0.4-4.fc11.i586
Jun 17 09:48:47 Installed: dirac-libs-1.0.2-2.fc11.i586
Jun 17 09:48:47 Installed: libcdaudio-0.99.12p2-12.fc11.i586
Jun 17 09:48:48 Installed: twolame-libs-0.3.12-4.fc11.i586
Jun 17 09:48:48 Installed: libid3tag-0.15.1b-8.fc11.i586
Jun 17 09:48:49 Installed: libsidplay-1.36.57-19.i586
Jun 17 09:48:49 Installed: celt-0.5.2-2.fc11.i586
Jun 17 09:48:50 Installed: a52dec-0.7.4-15.fc11.i586
Jun 17 09:48:51 Installed: enca-1.9-5.fc11.i586
Jun 17 09:48:52 Installed: libass-0.9.6-2.fc11.i586
Jun 17 09:48:53 Installed: imlib2-1.4.2-4.fc11.i586
Jun 17 09:48:53 Installed: openjpeg-libs-1.3-4.fc11.i586
Jun 17 09:48:55 Installed: ffmpeg-libs-0.5-2.fc11.i586
Jun 17 09:48:56 Installed: libquicktime-1.1.1-2.fc11.i586
Jun 17 09:48:57 Installed: mjpegtools-libs-1.9.0-1.fc11.i586
Jun 17 09:48:58 Installed: libdca-0.0.5-4.fc11.i586
Jun 17 09:48:58 Installed: gstreamer-ffmpeg-0.10.7-1.fc11.i586
Jun 17 09:49:02 Installed: gstreamer-plugins-bad-0.10.12-1.fc11.1.i586
Jun 17 09:49:03 Installed: gstreamer-plugins-ugly-0.10.11-1.fc11.i586
Jun 17 09:49:50 Installed: lirc-libs-0.8.5-2.fc11.i586
Jun 17 09:49:50 Installed: fribidi-0.19.2-1.fc11.i586
Jun 17 09:49:51 Installed: live555-0-0.23.2009.04.07.fc11.i586
Jun 17 09:49:52 Installed: libcaca-0.99-0.7.beta16.fc11.i586
Jun 17 09:49:53 Installed: mplayer-1.0-0.109.20090329svn.fc11.i586
Jun 17 09:49:54 Installed: mencoder-1.0-0.109.20090329svn.fc11.i586
Jun 17 09:50:29 Installed: libdvdcss-1.2.10-1.i386
Jun 17 09:54:29 Installed: flash-plugin-10.0.22.87-release.i386
Jun 17 09:55:55 Updated: rpmfusion-free-release-11-1.noarch
Jun 17 09:55:56 Updated: rpmfusion-nonfree-release-11-1.noarch


One of my coworkers is going to be doing a F11 install soon on the same hardware so I'll try be vigilante about tracking down what yum command fixed it.
Comment 4 Leif Gruenwoldt 2009-06-18 10:00:53 EDT
I tried reproducing this on another fresh install of F11 and could not. The difference between the two installs is that with my original install I had taken time to customize the packages I wanted during the install process. During the second install just office productivity + software devel were selected. So chalk this up to being not very reproducable sadly.
Comment 5 Mike McCune 2009-07-01 19:06:10 EDT
I'm getting:

$ pidgin

(pidgin:26695): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib64/gstreamer-0.10/libgstspeex.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.
Comment 6 Doug Doan 2009-07-02 14:21:04 EDT
I'm getting the same experience as Comment #4. It only happens on a customized install, and not with office/productivity + software dev install.

Checking those two groups/packages after Fedora has been installed does not fix the problem, but installing other gstreamer-* packages (as in Comment #3) changed my error message from

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib64/gstreamer-0.10/libgstspeex.so

to

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib64/gstreamer-0.10/libgstx264.so
Comment 7 Doug Doan 2009-07-10 17:36:37 EDT
Installing gstreamer-plugins-good-0.10.15-3.fc11 from the testing repo fixed this problem. See Bug 507009.
Comment 8 Bastien Nocera 2009-10-07 07:04:00 EDT
Closing as per last comment.
Comment 9 Rubin Simons 2010-02-15 03:48:07 EST
Fwiw,

I ran into exactly this issue with gstreamer-0.10.25.1-3.fc12.x86_64 Afaik, this is the latest updated version in F12. What happened (I think) is this:

1: Install F12 from dvd

2: Start using F12 which has gstreamer-0.10.25-1 which will eventually 
lead to gstreamer initializing ~/.gstreamer-0.10/registry.x86_64.bin

3: After some time gestreamer is updated to a newer version

4: Existing users won't notice the bug because 
~/.gstreamer-0.10/registry.x86_64.bin already exists

5: New users will encounter:

[root@inden ~]# gst-inspect
(plugin-scanner:2782): GLib-GObject-WARNING **: cannot register existing type `GstBaseVideoCodec'
(plugin-scanner:2782): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
(plugin-scanner:2782): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed
(plugin-scanner:2782): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
(plugin-scanner:2782): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed
(plugin-scanner:2782): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
(plugin-scanner:2782): GStreamer-CRITICAL **: gst_element_register: assertion `g_type_is_a (type, GST_TYPE_ELEMENT)' failed
*HANGs here*

6: actually copying a pre-existing ~/.gstreamer-0.10/registry.x86_64.bin
from another user account works around the problem.

Note that we've tried rpm -e --nodep all gstreamer packages and then re-installing them all. This did not help. Only copying the 
registry.x86_64.bin file to a new user's account seemed to alleviate
the problem.
Comment 10 Bastien Nocera 2010-02-15 05:48:13 EST
(In reply to comment #9)
> Fwiw,
> 
> I ran into exactly this issue with gstreamer-0.10.25.1-3.fc12.x86_64 Afaik,
> this is the latest updated version in F12. What happened (I think) is this:

It's not the latest version (0.10.26 should have been pushed to testing this week-end), and the problem is actually caused by third-party plugins.

Note You need to log in before you can comment on or make changes to this bug.