Bug 507009 - farsight2 is missing the gst-plugins-bad dep
farsight2 is missing the gst-plugins-bad dep
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: farsight2 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 507109 507281 507924 508600 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 16:00 EDT by Olivier Crête
Modified: 2009-07-27 17:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.10.15-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 13:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 586497 None None None Never

  None (edit)
Description Olivier Crête 2009-06-19 16:00:10 EDT
Farsight2 0.0.12 no longer depends on gst-plugins-farsight (which you can prune from you distro along with farsight1).

But it needs gst-plugins-bad 0.0.12

The same applies to 0.0.9 in Fedora 11 (so please push out an update there, otherwise Empathy calling is just broken).
Comment 1 Olivier Crête 2009-06-19 16:13:57 EDT
Also, did I mention that the rpmfusion gst-p-bad package doesn't work because the farsight plugins are disabled (becaues they conflict with the outdated version of gst-p-farsight in F11)
Comment 2 Brian Pepple 2009-06-19 19:18:47 EDT
(In reply to comment #0)
> Farsight2 0.0.12 no longer depends on gst-plugins-farsight (which you can prune
> from you distro along with farsight1).
> 
> But it needs gst-plugins-bad 0.0.12

If that is a hard dependency on gst-plugins-bad, that means farsight 2 will need to be removed from Fedora and moved to rpmfusion.

It would probably be helpful if the configure.ac was updated to check for the necessary plugins are available for farsight2 to work correctly.

> The same applies to 0.0.9 in Fedora 11 (so please push out an update there,
> otherwise Empathy calling is just broken).

Ditto here if the gst-plugins-bad is a hard dependency, it will need to be removed from F11.
Comment 3 Brian Pepple 2009-06-19 19:26:07 EDT
(In reply to comment #2)
> (In reply to comment #0)
> > Farsight2 0.0.12 no longer depends on gst-plugins-farsight (which you can prune
> > from you distro along with farsight1).
> > 
> > But it needs gst-plugins-bad 0.0.12
> 
> If that is a hard dependency on gst-plugins-bad, that means farsight 2 will
> need to be removed from Fedora and moved to rpmfusion.
> 
> It would probably be helpful if the configure.ac was updated to check for the
> necessary plugins are available for farsight2 to work correctly.

And going a little further, if this is a hard dep on gst-plugins-bad empathy will also be removed since it depends tp-farsight (which in turn depends on farsight2).  Not good.
Comment 4 Bastien Nocera 2009-06-19 19:40:13 EDT
What plugins are needed specifically?
Comment 5 Olivier Crête 2009-06-19 19:58:41 EDT
You need rtpmanager, valve, rtpmux, autoconvert, liveadder, dtmf.

For the upcoming msnwebcam, you also need mimic.. but that one probably needs to go on rpmfusion.
Comment 6 Olivier Crête 2009-06-20 18:44:49 EDT
Btw, this will show up as a crash in empathy because of a bug in the libtelepathy-farsight 0.0.6 GError handling code. So I'm adding the gnome bug as a dep.
Comment 7 Bastien Nocera 2009-06-20 19:25:12 EDT
Other question, does Empathy support the missing-plugins GStreamer framework to install missing plugins, should they be needed?
Comment 8 Olivier Crête 2009-06-20 19:45:50 EDT
No it doesn't. I plan to support it in farsight2 at some point for the codecs (lets say to install h.263 or h.264 codecs). But it's not going to happen for the basic elements. I doubt totem uses missing plugins if playbin is not installed.
Comment 9 Bastien Nocera 2009-06-20 21:09:25 EDT
(In reply to comment #8)
> No it doesn't. I plan to support it in farsight2 at some point for the codecs
> (lets say to install h.263 or h.264 codecs). But it's not going to happen for
> the basic elements. I doubt totem uses missing plugins if playbin is not
> installed.  

Except that Totem doesn't rely on plugins in gst-plugins-bad, except for some things like DVD and DVB playback, and it should be able to ask for those plugins.

I'd expect the same from Empathy, where certainly, the basic functionality would be there whether or not you had those plugins available.
Comment 10 Olivier Crête 2009-06-20 21:15:12 EDT
Except that in the case of farsight2, the main functionality is in rtpmanager which is still in -bad.
Comment 11 Christoph Maser 2009-06-21 03:14:36 EDT
*** Bug 507109 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2009-06-22 12:09:16 EDT
gstreamer-plugins-good-0.10.15-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gstreamer-plugins-good-0.10.15-2.fc11
Comment 13 Fedora Update System 2009-06-22 13:27:43 EDT
farsight2-0.0.12-1.fc11,gstreamer-plugins-good-0.10.15-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/farsight2-0.0.12-1.fc11,gstreamer-plugins-good-0.10.15-3.fc11
Comment 14 Brian Pepple 2009-06-24 14:18:33 EDT
*** Bug 507924 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2009-06-24 15:17:43 EDT
gstreamer-plugins-good-0.10.15-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6897
Comment 16 Fedora Update System 2009-06-24 15:26:39 EDT
farsight2-0.0.12-1.fc11, gstreamer-plugins-good-0.10.15-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update farsight2 gstreamer-plugins-good'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6921
Comment 17 Brian Pepple 2009-06-29 18:16:42 EDT
*** Bug 508600 has been marked as a duplicate of this bug. ***
Comment 18 Brian Pepple 2009-06-30 09:25:50 EDT
*** Bug 507281 has been marked as a duplicate of this bug. ***
Comment 19 Fedora Update System 2009-07-11 13:37:33 EDT
farsight2-0.0.12-1.fc11, gstreamer-plugins-good-0.10.15-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Johannes Goller 2009-07-14 12:48:21 EDT
I have a question about this bug report. I have installed empathy-2.26.2-1.fc11, as well as the package versions mentioned above, i.e.

farsight2-0.0.12-1.fc11
gstreamer-plugins-good-0.10.15-3.fc11

but I have no package called gstreamer-plugins-bad, neither from the yum repositories (it does not seem to exist there) nor from rpmfusion or any other source.

Here are my questions:
1) Do they messages above imply that Empathy should work with the package versions I have?

2) When I try to make a voice call to somebody running the Google Talk client on Windows, the connection is made, but there is no sound on either end. After a few seconds, Empathy freezes and needs to be killed by force. Could this symptom be explained based on the missing/wrong package discussion above? Should I file a separate bug report for this?
[Note: Empathy works very well if the other person calls me.]

3) This page
http://live.gnome.org/Empathy/FAQ#head-0cf7b08b5a6dd38484cb692f72da4475997aa008
says that the gstreamer-plugins-bad package is required on Fedora 11 and I must install it by hand. Is this still true?

4) The same page also says I need gstreamer-ffmpeg package. Is that true? Is that only for Video, or do I need it anyway? What is the recommended way of getting it?

Thank you very much in advance for any information you may have for me.
Comment 21 Olivier Crête 2009-07-14 13:04:07 EDT
(In reply to comment #20)
> 1) Do they messages above imply that Empathy should work with the package
> versions I have?

Yes
 
> 2) When I try to make a voice call to somebody running the Google Talk client
> on Windows, the connection is made, but there is no sound on either end. After
> a few seconds, Empathy freezes and needs to be killed by force. Could this
> symptom be explained based on the missing/wrong package discussion above?
> Should I file a separate bug report for this?
> [Note: Empathy works very well if the other person calls me.]

Yes, can you attach gdb to empathy when its frozen and do "thread apply all bt" and paste the result in that new bug.. Also please CC me on that bug.
 
> 3) This page
> http://live.gnome.org/Empathy/FAQ#head-0cf7b08b5a6dd38484cb692f72da4475997aa008
> says that the gstreamer-plugins-bad package is required on Fedora 11 and I must
> install it by hand. Is this still true?

No, page updated.

> 4) The same page also says I need gstreamer-ffmpeg package. Is that true? Is
> that only for Video, or do I need it anyway? What is the recommended way of
> getting it?

You only need gst-ffmpeg if you want to make video calls with clients using non-free codecs, like the Nokia N8x0 tablets.
Comment 22 Johannes Goller 2009-07-15 08:15:19 EDT
Thank you for all the information, this is very helpful. I have filed bug #511854 for the freeze problem and copied you.
Comment 23 Fedora Update System 2009-07-21 17:55:24 EDT
gstreamer-plugins-good-0.10.15-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gstreamer-plugins-good-0.10.15-4.fc11
Comment 24 Fedora Update System 2009-07-27 17:36:14 EDT
gstreamer-plugins-good-0.10.15-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.