Bug 506362 - control- and shift-click do not work connecting to F11 Vino
control- and shift-click do not work connecting to F11 Vino
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 17:18 EDT by Erik M Jacobs
Modified: 2013-04-30 19:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:04:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erik M Jacobs 2009-06-16 17:18:05 EDT
Description of problem:
When connecting with tigervnc to a vino remote desktop, control-click and shift-click do not appear to function.  Example: selecting multiple emails in thunderbird

Version-Release number of selected component (if applicable):
tigervnc.i586 0.0.90-0.10.fc11
vino.i586 2.26.1-2.fc11

How reproducible:
Always

Steps to Reproduce:
1. Connect tigervnc to a remote vino-powered gnome desktop session
2. Fire up a program where you can control- or shift-click multiple items ex: thunderbird, nautilus file manager, etc
3. try to control- or shift-click multiple items
  
Actual results:
the shift- and control- part of the click are ignored, the mouse click is the only thing that goes through

Expected results:
shift- or control- click would be honored.

Additional info:
Have not tried other VNC servers aside from vino as the remote desktop server in gnome with F11, and have not tried other clients aside from tigervnc. this could potentially be a server issue (vino) and not a client issue (tigervnc).
Comment 1 Adam Tkac 2009-06-19 11:22:24 EDT
After inspection it seems this is actually a bug in the Xorg - bug #506963
Comment 2 Chris Tyler 2009-11-23 08:25:48 EST
Using the Gnome desktop on F10-F12, ctrl-click works fine without desktop effects enabled but fails when they are enabled. Is This an Xorg or Compiz/Metacity or TigerVNC issue?
Comment 3 Bug Zapper 2010-04-27 10:59:52 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-06-28 09:04:25 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.