Bug 506435 - kvm: -kernel option seems broken
kvm: -kernel option seems broken
Status: CLOSED DUPLICATE of bug 506443
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 05:58 EDT by Stefan Assmann
Modified: 2009-06-17 09:17 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 08:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2009-06-17 05:58:49 EDT
Description of problem:
I tried to run the stock F11 kernel in kvm with
qemu-kvm -kernel /boot/vmlinuz-2.6.29.4-167.fc11.x86_64
but it didn't boot the kernel and only displayed:
FATAL: no bootable device.

Version-Release number of selected component (if applicable):
qemu-kvm-0.10.5-2.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. qemu-kvm -kernel /boot/vmlinuz-2.6.29.4-167.fc11.x86_64
  
Actual results:
FATAL: no bootable device.

Expected results:
boot of kernel vmlinuz-2.6.29.4-167.fc11.x86_64
Comment 1 Mark McLoughlin 2009-06-17 06:46:55 EDT
Thanks, I can reproduced. It works with latest qemu-kvm.git/master
Comment 2 Daniel Berrange 2009-06-17 07:12:04 EDT
Historically when using  -kernel, it has been compulsory to add a IDE hard disk. This is because -kernel is implemented as a sick, disgusting, evil hack where we copy a fake boot sector into the first IDE hard drive, to make the BIOS boot the kernel specified. I think latest upstream has finally switched to using a proper option ROM to avoid this gross hack.
Comment 3 Stefan Assmann 2009-06-17 07:47:00 EDT
Hi Daniel,

my original idea was to do the following:

qemu-kvm -kernel /boot/vmlinuz-2.6.29.4-167.fc11.x86_64 -initrd /boot/initrd-2.6.29.4-167.fc11.x86_64.img F11.img

and later on replace kernel and initrd with my custom builds for testing but that didn't work so I simplified it to realize that

qemu-kvm -kernel /boot/vmlinuz-2.6.29.4-167.fc11.x86_64

didn't work either.

If there is some other boot option to try just let me know.
Comment 4 Mark McLoughlin 2009-06-17 08:06:00 EDT

*** This bug has been marked as a duplicate of bug 506443 ***

Note You need to log in before you can comment on or make changes to this bug.