Bug 506443 - qemu -kernel -initrd not working anymore
qemu -kernel -initrd not working anymore
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
: 506435 506798 (view as bug list)
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-17 07:14 EDT by Harald Hoyer
Modified: 2009-06-19 09:43 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.10.5-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 09:43:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix for load_linux() (657 bytes, patch)
2009-06-17 07:14 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Harald Hoyer 2009-06-17 07:14:22 EDT
Created attachment 348240 [details]
fix for load_linux()

attached patch fixes the problem
Comment 1 Mark McLoughlin 2009-06-17 08:05:01 EDT
Thanks much Harald, I'm building the fix now

* Wed Jun 17 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.5-3
- ppc-on-ppc fix (#504273)
- Fix -kernel regression (#506443)
Comment 2 Mark McLoughlin 2009-06-17 08:06:00 EDT
*** Bug 506435 has been marked as a duplicate of this bug. ***
Comment 3 Mark McLoughlin 2009-06-17 08:59:58 EDT
The re-base of qemu-roms-more-room.patch to 0.10.5 is what broke this, FWIW:

-             load_linux(option_rom_offset,
-                        kernel_filename, initrd_filename, kernel_cmdline);
 -            cpu_register_physical_memory(0xd0000, TARGET_PAGE_SIZE,
 +            cpu_register_physical_memory(option_rom_start, TARGET_PAGE_SIZE,
                                           option_rom_offset);
+             load_linux(0xd0000,
+                        kernel_filename, initrd_filename, kernel_cmdline, below_4g_mem_size);
Comment 4 Fedora Update System 2009-06-17 09:34:48 EDT
qemu-0.10.5-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.5-3.fc11
Comment 5 Mark McLoughlin 2009-06-18 13:24:13 EDT
*** Bug 506798 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2009-06-19 09:43:14 EDT
qemu-0.10.5-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.