Bug 506450 - Package Review: twitter-glib - A library wrapping the Twitter RESTful API
Package Review: twitter-glib - A library wrapping the Twitter RESTful API
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Yanko Kaneti
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FedoraMoblin20 506476
  Show dependency treegraph
 
Reported: 2009-06-17 07:59 EDT by Peter Robinson
Modified: 2009-06-24 16:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 16:34:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
yaneti: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-06-17 07:59:58 EDT
SPEC: http://pbrobinson.fedorapeople.org/twitter-glib.spec
SRPM: http://pbrobinson.fedorapeople.org/twitter-glib-0.9.8-1.fc11.src.rpm

Twitter-GLib is a GObject-based library providing a wrapper around
the RESTful API of Twitter.
Comment 1 Yanko Kaneti 2009-06-17 12:45:24 EDT
MUST:
twitter-glib.src: W: invalid-license LGPLv2.1+
Should be License: LGPLv2


Cosmetic:

URL: http://live.gnome.org/TwitterGlib    
makes more sense I think.

BuildRequires: gtk-doc
is not really necessary , the tarball has that already built.

The package has a testsuite that doesn't seem to do anything network related.
You could add
%check
make check

With the license change this package is APPROVED.

I am not sure why this is a blocker for the rest review...
Comment 2 Peter Robinson 2009-06-18 07:00:47 EDT
(In reply to comment #1)
> MUST:
> twitter-glib.src: W: invalid-license LGPLv2.1+
> Should be License: LGPLv2

I put that because from the README file:
Twitter-GLib is released under the terms of the GNU Lesser General
Public License version 2.1 or, at your option, any later version.

> Cosmetic:
> 
> URL: http://live.gnome.org/TwitterGlib    
> makes more sense I think.

Will do, I never found that one previously :)
 
> BuildRequires: gtk-doc
> is not really necessary , the tarball has that already built.
> 
> The package has a testsuite that doesn't seem to do anything network related.
> You could add
> %check
> make check
> 
> With the license change this package is APPROVED.
> 
> I am not sure why this is a blocker for the rest review...  

It shouldn't have been, but I was looking at hundreds of deps/bz bugs etc yesterday so it was probably a brain fart.
Comment 3 Yanko Kaneti 2009-06-18 08:03:10 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > MUST:
> > twitter-glib.src: W: invalid-license LGPLv2.1+
> > Should be License: LGPLv2
> 
> I put that because from the README file:
> Twitter-GLib is released under the terms of the GNU Lesser General
> Public License version 2.1 or, at your option, any later version.

Oh, very sorry, I've missed the any later part. :/
According to the guidelines the short form of this to be used in spec files is:
LGPLv2+
Comment 4 Peter Robinson 2009-06-18 08:17:21 EDT
Thanks for the update. I've fixed it on my local copy ready for commit. Thanks for the review.
Comment 5 Peter Robinson 2009-06-18 08:18:43 EDT
New Package CVS Request
=======================
Package Name: twitter-glib
Short Description: A library wrapping the Twitter RESTful API
Owners: pbrobinson
Branches: F-11 F-10
InitialCC:
Comment 6 Jason Tibbitts 2009-06-18 16:18:03 EDT
CVS done.
Comment 7 Peter Robinson 2009-06-18 18:20:32 EDT
Build in rawhide
Comment 8 Peter Robinson 2009-06-24 16:34:11 EDT
Done. Thanks for the review!

Note You need to log in before you can comment on or make changes to this bug.