Bug 506486 - Package Review: mojito - A social network data aggregator
Package Review: mojito - A social network data aggregator
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
:
Depends On: 506476
Blocks: FedoraMoblin20 506833 513452
  Show dependency treegraph
 
Reported: 2009-06-17 10:07 EDT by Peter Robinson
Modified: 2009-07-23 13:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 11:56:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-06-17 10:07:03 EDT
SPEC: http://pbrobinson.fedorapeople.org/mojito.spec
SRPM: http://pbrobinson.fedorapeople.org/mojito-0.10.3-1.fc11.src.rpm

Mojito is a social data server which will fetch data from the "social web", 
such as your friend's blog posts and photos, upcoming events, recently played 
tracks, and pending eBay* auctions. It also provides a service to update 
your status on web services which support it, such as MySpace* and Twitter*.
Comment 1 Nikolay Vladimirov 2009-06-20 11:55:55 EDT
Mock build failed:

checking for GCONF... configure: error: Package requirements (gconf-2.0) were not met:
No package 'gconf-2.0' found

Please fix this and update the srpm and spec.
Comment 2 Peter Robinson 2009-06-21 10:06:00 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=1427658

SPEC: same link as before
SRPM: http://pbrobinson.fedorapeople.org/mojito-0.10.3-2.fc11.src.rpm

Updated. Added NetworkManager as well.
Comment 3 Peter Robinson 2009-07-01 19:18:49 EDT
Any update?
Comment 4 Christopher X.S. Zee 2009-07-01 21:52:35 EDT
$ rpm -i mojito-0.10.3-2.fc11.src.rpm 
warning: user perobinson does not exist - using root
warning: group perobinson does not exist - using root
warning: user perobinson does not exist - using root
warning: group perobinson does not exist - using root

Did you build it as root?
Comment 5 Peter Robinson 2009-07-02 02:39:29 EDT
> Did you build it as root?  

No, there's no need to build it as root, I don't do anything as root. That's a standard warning of no consequence.
Comment 6 Nikolay Vladimirov 2009-07-02 08:22:22 EDT
I'm releasing the review. I'm in the eye of some s**t storm at work.
Comment 7 Parag AN(पराग) 2009-07-03 02:21:32 EDT
Review:
+ package builds in mock (rawhide i586).
koji Build =>http://koji.fedoraproject.org/koji/taskinfo?taskID=1452075
- rpmlint is NOT silent for SRPM and for RPM.
mojito.src: W: invalid-license LGPLv2.1
mojito.i586: W: invalid-license LGPLv2.1
mojito-devel.i586: W: invalid-license LGPLv2.1
== Fix it to LGPLv2
+ source files match upstream url
6fcc6b5b439bd95d18901aa2ee7f2241e381a02a  mojito-0.10.3.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ mojito-client.pc and mojito-module.pc files present.
+ -devel subpackage present.
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ ldconfig scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Package mojito-0.10.3-2.fc12.i586  =>
Provides: libmojito-client.so.1 libmojito-service-dummy.so libmojito.so.0 libtwitter.so
Requires(interp): /sbin/ldconfig /sbin/ldconfig
Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3) libdbus-1.so.3 libdbus-glib-1.so.2 libgconf-2.so.4 libgdk_pixbuf-2.0.so.0 libgio-2.0.so.0 libglib-2.0.so.0 libgmodule-2.0.so.0 libgobject-2.0.so.0 libgthread-2.0.so.0 libjson-glib-1.0.so.0 libmojito-client.so.1 libmojito.so.0 libpthread.so.0 librt.so.1 libsoup-2.4.so.1 libsoup-gnome-2.4.so.1 libtwitter-glib-1.0.so.0 rtld(GNU_HASH)
+ Package mojito-devel-0.10.3-2.fc12.i586 =>
Provides: pkgconfig(mojito-client) = 0.10.3 pkgconfig(mojito-module) = 0.10.3
Requires: /usr/bin/pkg-config libmojito-client.so.1 libmojito.so.0 pkgconfig(dbus-glib-1) pkgconfig(glib-2.0) pkgconfig(libsoup-2.4)
+ Not a GUI application

Should:
1) Fix rpmlint warnings.
2) you can also add examples and tests sample code to %doc of -devel package as

%doc tests/*.c examples/*c examples/*.py

APPROVED.
Comment 8 Parag AN(पराग) 2009-07-03 03:27:31 EDT
3) and also remove following from SPEC
BuildRequires: gnome-keyring-devel
BuildRequires: libsoup-devel

because glib2-devel will pull those in buildroot. See successful build after removing those BRs
http://koji.fedoraproject.org/koji/taskinfo?taskID=1452185

4)forgot to tell that you will also need to 
chmod 644 examples/*.py 
in %prep section to make rpmlint silent.
Comment 9 Peter Robinson 2009-07-03 04:57:38 EDT
Brilliant. I'll update the spec before I push it to cvs. Thanks!
Comment 10 Peter Robinson 2009-07-03 04:58:56 EDT
New Package CVS Request
=======================
Package Name: mojito
Short Description: A social network data aggregator
Owners: pbrobinson
Branches: F-11 F-10
InitialCC:
Comment 11 Kevin Fenzi 2009-07-06 00:18:32 EDT
cvs done.
Comment 12 Peter Robinson 2009-07-06 05:24:30 EDT
Imported, built in rawhide. Updated to the latest release and added in support for languages and the new backends. Thanks for the review.
Comment 13 Peter Robinson 2009-07-06 05:54:45 EDT
(In reply to comment #8)
> 3) and also remove following from SPEC
> BuildRequires: gnome-keyring-devel
> BuildRequires: libsoup-devel
> 
> because glib2-devel will pull those in buildroot. See successful build after
> removing those BRs
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1452185

Actually that should be the other way around. glib2-devel would be pulled in by gnome-keyring-devel. See failed build here 

http://koji.fedoraproject.org/koji/getfile?taskID=1456399&name=build.log
Comment 14 Parag AN(पराग) 2009-07-06 07:12:52 EDT
I got successful build http://koji.fedoraproject.org/koji/taskinfo?taskID=1456571,

with following in SPEC
BuildRequires: dbus-glib-devel
BuildRequires: glib2-devel
BuildRequires: GConf2-devel
BuildRequires: NetworkManager-devel
BuildRequires: pkgconfig
BuildRequires: rest-devel
BuildRequires: twitter-glib-devel
BuildRequires: intltool
BuildRequires: gtk-doc
Comment 15 Peter Robinson 2009-07-06 07:47:02 EDT
(In reply to comment #14)
> I got successful build
> http://koji.fedoraproject.org/koji/taskinfo?taskID=1456571,
> 
> with following in SPEC
> BuildRequires: dbus-glib-devel
> BuildRequires: glib2-devel
> BuildRequires: GConf2-devel
> BuildRequires: NetworkManager-devel
> BuildRequires: pkgconfig
> BuildRequires: rest-devel
> BuildRequires: twitter-glib-devel
> BuildRequires: intltool
> BuildRequires: gtk-doc  

I don't think the 0.10 version explicitly depended on them and hence still built fine without the feature but the later version does add an explicit dependency on a couple of packages. NetworkManager-glib-devel was another one of those.
Comment 16 Peter Robinson 2009-07-07 11:56:35 EDT
Built and pushed to rawhide.

Note You need to log in before you can comment on or make changes to this bug.