This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506536 - Add a MIME type definition so we can associate congruity with the appropriate files
Add a MIME type definition so we can associate congruity with the appropriate...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libconcord (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
: Patch, Upstream
Depends On: 514983
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 12:54 EDT by Adam Williamson
Modified: 2009-08-28 18:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.21-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 17:58:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MIME type definition for libconcord (360 bytes, text/plain)
2009-06-17 12:55 EDT, Adam Williamson
no flags Details
MIME type definition for libconcord (411 bytes, text/plain)
2009-06-17 12:56 EDT, Adam Williamson
no flags Details
Patch for upstream libconcord to install a MIME type definition file (2.41 KB, patch)
2009-06-17 13:46 EDT, Adam Williamson
no flags Details | Diff
Patch for libconcord.spec to apply the MIME patch to the upstream code (1.40 KB, patch)
2009-06-17 13:48 EDT, Adam Williamson
no flags Details | Diff

  None (edit)
Description Adam Williamson 2009-06-17 12:54:55 EDT
libconcord should ship a MIME type definition file so that we can associate congruity with the files the web interface ships, and then everything will just work out of the box (I always like it when that happens). :)

I'll attach the file. It should be added to the package as a source and installed as %{_datadir}/mime/packages/congruity.xml , and these snippets should be added:

%post
update-mime-database %{_datadir}/mime &> /dev/null || :

%postun
update-mime-database %{_datadir}/mime &> /dev/null || :

that should handle it. Thanks!

I'll also submit this to upstream.
Comment 1 Adam Williamson 2009-06-17 12:55:35 EDT
Created attachment 348295 [details]
MIME type definition for libconcord
Comment 2 Adam Williamson 2009-06-17 12:56:41 EDT
Created attachment 348296 [details]
MIME type definition for libconcord
Comment 3 Adam Williamson 2009-06-17 12:59:19 EDT
actually, it should be called %{_datadir}/mime/packages/libconcord.xml , sorry. not congruity.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-06-17 13:46:10 EDT
Here's a better way...I patched it into the upstream source.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2009-06-17 13:46:49 EDT
Created attachment 348306 [details]
Patch for upstream libconcord to install a MIME type definition file
Comment 6 Adam Williamson 2009-06-17 13:48:21 EDT
Created attachment 348307 [details]
Patch for libconcord.spec to apply the MIME patch to the upstream code
Comment 7 Adam Williamson 2009-06-17 13:49:52 EDT
Reported upstream: http://sourceforge.net/tracker/?func=detail&aid=2807865&group_id=201579&atid=978130
Comment 8 Douglas E. Warner 2009-06-17 15:10:39 EDT
Thanks for the patches; I'll get them integrated into our builds for all releases shortly; a rawhide package should be coming through soon.
Comment 9 Douglas E. Warner 2009-06-17 16:33:31 EDT
The build is trying to run autoreconf, so I have to get that fixed up before it's ready to go.  Current patch is in CVS.
Comment 10 Adam Williamson 2009-06-17 17:13:16 EDT
I prefer to do things that way (just patch the source files and re-run autoreconf, rather than patching the generated files); which is the 'best' way appears to be something of a bone of contention, going on past f-d-l threads :) but it's your package, I don't mind which way you go, and it'll get upstreamed anyway I expect, since upstream is active. thanks again.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Douglas E. Warner 2009-06-17 21:07:32 EDT
Right; your patch will probably be the one I send upstream.  I'm just trying to get it updated for CVS so I don't need to run autoreconf inside the build of the package.
Comment 12 Anssi Hannula 2009-07-09 18:21:42 EDT
The Logitech server already sends mimetypes for the files:
application/x-easyzapper-hex
application/x-easyzapper-upgrade
application/x-easyzapper-tutor

Mandriva's .desktop file for congruity has those types associated with it, so it works out-of-the-box (with firefox at least; apparently kde4 konqueror has some problems with it) without any new mime type definitions.

Adding the mimetype files anyway is probably not a bad idea, but maybe we should use the same mimetype definitions the server reports? It is possible some browsers trust server for mimetype info, thus not associating the files with congruity.
Comment 13 Adam Williamson 2009-07-15 17:10:22 EDT
Nicely spotted, Anssi - I hadn't noticed that. I'd support your suggestion; Douglas, can you revise my patch a bit to use the upstream MIME types, as Anssi suggests? Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Anssi Hannula 2009-07-15 17:16:45 EDT
I put my modified patch in the upstream bugreport.
I dropped the <magic> entry from it, though, as I didn't see what it was for, and asked you for comment :)
Comment 15 Adam Williamson 2009-07-30 12:40:49 EDT
is this going to go through? I already sent congruity out into the distro, it'd be nice to have this fix in libconcord so it works 'out of the box'. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Douglas E. Warner 2009-07-30 13:15:51 EDT
Yeah, I'm actually looking at it right now due to the f12 failed rebuild.
Comment 17 Adam Williamson 2009-07-30 13:28:53 EDT
great, thanks. please use anssi's better version of the patch, rather than mine :)

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Fedora Update System 2009-07-30 14:56:15 EDT
libconcord-0.21-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libconcord-0.21-3.fc10
Comment 19 Fedora Update System 2009-07-30 14:56:21 EDT
libconcord-0.21-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libconcord-0.21-3.fc11
Comment 20 Adam Williamson 2009-07-30 19:59:02 EDT
That's still using my patch. As I said, Anssi's is better than mine, as it drops the spurious <magic> section, and uses the same MIME type the Logitech server sends out. Could you switch to that patch? Thanks!

http://stuff.onse.fi/concordance-mime2.patch

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Douglas E. Warner 2009-07-30 21:23:44 EDT
Sure; thanks for the link.  I just picked the one that was attached to the upstream bug and didn't realize it was still yours.  I'll try to put that together tomorrow.
Comment 22 Adam Williamson 2009-07-30 21:44:38 EDT
thanks, sorry for the trouble. I think Anssi missed the way to attach things to reports in the sourceforge tracker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Fedora Update System 2009-07-31 14:05:54 EDT
libconcord-0.21-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libconcord'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8167
Comment 24 Douglas E. Warner 2009-07-31 18:12:11 EDT
CVS has been updated with a new patch and has been tagged, but I can't build right now due to a broken swig package [1].  I'll be leaving on vacation this week but will try to monitor the situation.  If anyone sees its fixed and wants to build it before I do, feel free -- I'll try to push it to updates as soon as I see it's built.

[1] https://www.redhat.com/archives/fedora-devel-list/2009-July/msg02068.html
Comment 25 Douglas E. Warner 2009-07-31 18:15:37 EDT
Actually, it looks like the F11 package built fine so you could test from koji if you liked.
Comment 26 Adam Williamson 2009-08-04 17:37:11 EDT
Thanks for the change. I've submitted a patch to congruity to change to the new MIME types, I'll bring that downstream into the Fedora package once it's accepted.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 27 Adam Williamson 2009-08-07 18:36:36 EDT
can you poke me when this hits updates for f10 and f11? i've pushed the new congruity release to rawhide, but I don't want to push it to f10 and f11 till the libconcord switch is done.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Fedora Update System 2009-08-10 09:39:19 EDT
libconcord-0.21-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libconcord-0.21-4.fc11
Comment 29 Fedora Update System 2009-08-10 09:39:25 EDT
libconcord-0.21-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libconcord-0.21-4.fc10
Comment 30 Fedora Update System 2009-08-11 18:31:30 EDT
libconcord-0.21-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libconcord'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8463
Comment 31 Fedora Update System 2009-08-11 18:37:01 EDT
libconcord-0.21-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libconcord'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8489
Comment 32 Fedora Update System 2009-08-28 17:58:15 EDT
libconcord-0.21-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2009-08-28 18:01:50 EDT
libconcord-0.21-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.