Bug 514983 - Incorrect requires pulled from Perl5.html file
Summary: Incorrect requires pulled from Perl5.html file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: swig
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 515108 515175 515577 (view as bug list)
Depends On:
Blocks: 506536
TreeView+ depends on / blocked
 
Reported: 2009-07-31 18:41 UTC by Jesse Keating
Modified: 2013-04-30 23:44 UTC (History)
18 users (show)

Fixed In Version: 1.3.39-3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-05 00:34:19 UTC
Type: ---


Attachments (Terms of Use)

Description Jesse Keating 2009-07-31 18:41:19 UTC
On Fri, 2009-07-31 at 13:35 -0400, Seth Vidal wrote:
> I think swig has a bug in its packaging.
> 
> specifically
> 
> perl(ExtUtils::MakeMaker)
> perl(argv)
> perl(example)
> perl(it)
> perl(the)
> 
> I think those last 4 are an error.
> 
> at least I hope so.
> 

They are.  They come from the file Doc/Manual/Perl5.html, that has the
following lines:

use ExtUtils::MakeMaker;
<snip>
use it without success, you can build a new version of the Perl
<snip>
use example; 
(multiple itmes)
<snip>
use the use command as normal. For example :
<snip>
(more use example)
<snip>
use argv;
<snip>
use of Perl code might be to supply a high-level interface to certain
functions.
<snip>

Each of those are going to trigger the perl require checker to think
those are perl modules if it is ran on this html file.

The spec has:

cat << \EOF > %{name}-req
#!/bin/sh
%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S
+||'`
EOF

%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
chmod +x %{__perl_requires}


which is going to go through the doc dir, where this html file is found,
and scour it for requires.  Does the same for provides which may also
screw things up.

So where is the bug?  That the provider/require script is being ran on
html files, that the script is reading html files and treating them like
perl files?

We'll need to get a new version of swig built to fix this, however it
needs to be fixed.

Comment 1 Jesse Keating 2009-07-31 18:45:11 UTC
Ahem.  This is actually an issue with the F-10 build, which /doesn't/ properly filter out the docs files.  Moving to that version.

Comment 2 Douglas E. Warner 2009-07-31 22:14:54 UTC
Sorry for the initial confusion; I thought it failed build on F11 as well, but Jesse is right that it's just F10.

Comment 3 John Griffiths 2009-08-02 10:17:38 UTC
Finger pointing doesn't fix the fact that the rpm is broken and will not install.

Comment 4 Adam Tkac 2009-08-03 07:42:32 UTC
*** Bug 515175 has been marked as a duplicate of this bug. ***

Comment 5 Adam Tkac 2009-08-03 07:42:47 UTC
*** Bug 515108 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2009-08-03 14:05:01 UTC
swig-1.3.39-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/swig-1.3.39-3.fc10

Comment 7 Adam Tkac 2009-08-03 14:05:49 UTC
This issue should be fixed in swig-1.3.39-3.fc10. Sorry for troubles.

Comment 8 Josh Boyer 2009-08-03 18:51:08 UTC
(In reply to comment #7)
> This issue should be fixed in swig-1.3.39-3.fc10. Sorry for troubles.  

I tagged this in dist-f10-override for now

Comment 9 Fedora Update System 2009-08-05 00:34:13 UTC
swig-1.3.39-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Adam Tkac 2009-08-05 08:16:05 UTC
*** Bug 515577 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.