This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 506654 - Disk partitioning utility fails to detect disks correctly.
Disk partitioning utility fails to detect disks correctly.
Status: CLOSED DUPLICATE of bug 499733
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 03:29 EDT by Nils Hammar
Modified: 2009-06-19 05:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 05:22:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Error message from anaconda. (489.44 KB, text/plain)
2009-06-18 13:25 EDT, Nils Hammar
no flags Details
Picture of device names provided by OS. (89.81 KB, image/jpeg)
2009-06-18 13:27 EDT, Nils Hammar
no flags Details

  None (edit)
Description Nils Hammar 2009-06-18 03:29:05 EDT
Description of problem:
The installer fails to detect the disks /dev/sda, /dev/sdb etc correctly on a machine with the disks residing on third controller. The computer has a motherboard with both IDE and SATA controllers and the first two controllers are IDE while SATA are on the third.

There is something detected, but the naming is completely wrong and not related to sda etc. But the kernel does detect the disks correctly as /dev/sda etc.

The motherboard is an ASUS P4P800 Deluxe with a 3.0GHz Prescott CPU.

Version-Release number of selected component (if applicable):
Fedora 11 i386.

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nils Hammar 2009-06-18 13:25:59 EDT
Created attachment 348529 [details]
Error message from anaconda.

This is the error message that anaconda provided when it failed to write the configuration to disk.
Comment 2 Nils Hammar 2009-06-18 13:27:54 EDT
Created attachment 348530 [details]
Picture of device names provided by OS.

The device names provided seems to be unusable later on.
Comment 3 Nils Hammar 2009-06-18 13:29:13 EDT
The motherboard is an ASUS P4P800-E Deluxe. Previously it did have BIOS 1004, but there is no change after an upgrade to BIOS 1009.
Comment 4 Nils Hammar 2009-06-18 14:34:40 EDT
This seems to be similar to bug 496339; https://bugzilla.redhat.com/show_bug.cgi?id=496339
Comment 5 Nils Hammar 2009-06-18 16:00:43 EDT
After a lot of pain it seems like the only way to make things work during the installation is to accept the default partitioning and never enter the customization screen. I can't say that I like that at all - especially since I want a non-default partitioning. :(
Comment 6 Nils Hammar 2009-06-19 05:22:41 EDT
I finally found the real culprit in all this, and a workaround in bug 499733.

*** This bug has been marked as a duplicate of bug 499733 ***

Note You need to log in before you can comment on or make changes to this bug.