Bug 506721 - Package Review: nbtk - A toolkit for moblin NetBooks
Package Review: nbtk - A toolkit for moblin NetBooks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nikolay Vladimirov
Fedora Extras Quality Assurance
:
Depends On: 506712
Blocks: FedoraMoblin20 506804 506855 507223 507243 513452
  Show dependency treegraph
 
Reported: 2009-06-18 09:28 EDT by Peter Robinson
Modified: 2009-08-08 18:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 15:18:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
nikolay: fedora‑review+
tibbs: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2009-06-18 09:28:35 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Robinson 2009-06-18 09:31:23 EDT
SPEC: http://pbrobinson.fedorapeople.org/nbtk.spec
SRPM: http://pbrobinson.fedorapeople.org/nbtk-0.9.3-1.fc11.src.rpm

The Netbook Toolkit is a GUI toolkit, using Clutter and is optimised 
for the Moblin netbook experience. It consists of various classes 
useful for building UIs such as Buttons, Tooltips, Scrollbars and 
others. It also supports styling through CSS stylesheets.
Comment 2 Nikolay Vladimirov 2009-06-20 07:32:55 EDT
I'm starting the review.
Comment 3 Nikolay Vladimirov 2009-06-20 09:23:28 EDT
The package can not be built. It requires clutter 0.9.4 and the latest fedora version is 0.9.2 for f12

Otherwise everything seems fine. I'll do an in detail review when that's fixed.
Comment 4 Bastien Nocera 2009-06-20 10:33:57 EDT
clutter 0.9.4 is built:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1426252
Comment 5 Nikolay Vladimirov 2009-06-20 10:45:50 EDT
Ok, Thanks. 
I'll wait for the rawhide repo update tomorrow to do a mock build.
Comment 6 Peter Robinson 2009-06-22 13:03:37 EDT
The 0.9.3 release doesn't compile on rawhide. I've updated to the 0.11.1 release that's part of the moblin beta release and it compiles OK. I'm going to file a bug to get them to update the git tarball availability.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1429792

SRPM: http://pbrobinson.fedorapeople.org/nbtk-0.11.1-1.fc11.src.rpm
Comment 7 Nikolay Vladimirov 2009-06-24 16:42:18 EDT
The package seems ok and it's basic approved. 
It's OK on all points. 
I'm not very comfortable on making the initial commit from just some tarball of a git tag. I know that it blocks a lot of reviews but there's a lot of time until the freeze. 
So just post here when upstream has posted a tarball and update the changelog to reflect the new version (you forgot this for 0.11). And I'll give the fedora-review +
Comment 8 Nikolay Vladimirov 2009-06-24 18:45:45 EDT
Ok, scratch the previous I had a rethink so:

MUST:

    * rpmlint output: 0 errors, 0 warnings ( both srpm and binary rpm)
    * package name: OK
    * The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exeption: OK
    * Packaging Guidelines: OK
    * License: OK
    * The License field file matches the actual license: OK
    * License included in %doc: OK
    * The spec file must be written in American English: OK
    * The spec file for the package MUST be legible: OK
    * The sources used to build the package must match the upstream source: OK
    * The package MUST successfully compile and build into binary rpms on at least one primary architecture: OK ( on i586)
    * All build dependencies must be listed in BuildRequires: OK
    * The spec file MUST handle locales properly: N/A ( no locales)
    * Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun: OK
    * A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory: OK
    * A Fedora package must not list a file more than once in the spec file's %files listings: OK
    * Permissions on files must be set properly. Executables should be set with executable permissions, for example. Every %files section must include a %defattr(...) line: OK
    * Each package must have a %clean section, which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT): OK
    * Each package must consistently use macros: OK
    * The package must contain code, or permissable content: OK
    * Header files must be in a -devel package: OK
    * Packages containing pkgconfig(.pc) files must 'Requires: pkgconfig' (for directory ownership and usability): OK
    * If a package contains library files with a suffix (e.g. libfoo.so.1.1), then library files that end in .so (without suffix) must go in a -devel package: OK
    * In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name} = %{version}-%{release} : OK
    * Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built: OK
    * At the beginning of %install, each package MUST run rm -rf %{buildroot} (or $RPM_BUILD_ROOT): OK
    * All filenames in rpm packages must be valid UTF-8 : OK



SHOULD Items:
    * The reviewer should test that the package builds in mock: OK (for i586 rawhide)

Minor things before commit: 
   * Update the changelog before committing
   * Note the clutter version in build requres since it's still(0.8.8 in f11)
   BuildRequires: clutter-devel >= 0.9.4
   * add HACKING and README to %doc
Comment 9 Nikolay Vladimirov 2009-06-24 18:55:13 EDT
Forgot to mention:

From the packaging guidelines:

  Using Revision Control

In some cases you may want to pull sources from upstream's revision control system because there have been many changes since the last release and you think that a tarball that you generate from there will more accurately show how the package relates to upstream's development. Here's how you can use a comment to show where the source came from:

# The source for this package was pulled from upstream's vcs.  Use the
# following commands to generate the tarball:
#  svn export -r 250 http://www.example.com/svn/foo/trunk foo-20070221
#  tar -czvf foo-20070221.tar.gz foo-20070221
Source0: foo-20070221.tar.gz

So, Note that you're using a git tag and how can it be checkedout
Comment 10 Peter Robinson 2009-06-26 05:19:22 EDT
New Package CVS Request
=======================
Package Name: nbtk
Short Description: A toolkit for moblin NetBooks
Owners: pbrobinson
Branches: F-11 F-10
InitialCC:
Comment 11 Jason Tibbitts 2009-06-26 20:39:34 EDT
CVS done.
Comment 12 Peter Robinson 2009-06-27 04:29:33 EDT
Built in koji.
Comment 13 Peter Robinson 2009-06-28 15:18:49 EDT
Pushed to rawhide
Comment 14 Nikolay Vladimirov 2009-06-28 16:02:23 EDT
(In reply to comment #13)
> Pushed to rawhide  

Please make the changes I noted in my previous comments.
Comment 15 Peter Robinson 2009-06-28 16:59:01 EDT
(In reply to comment #14)
> (In reply to comment #13)
> > Pushed to rawhide  
> 
> Please make the changes I noted in my previous comments.  

The one about the git snapshots? I'm not using git snapshots. You can see all the releases here http://git.moblin.org/cgit.cgi/nbtk/refs/ The URL is correct. Also there is no HACKING file in the 0.11.1 tar ball and the README contains information for building it, which given its a binary package, isn't relevant to the RPM. There is also no plan to push any of the moblin stuff to F-11 or earlier as there are too many missing dependencies. I don't believe I've missed anything else.
Comment 16 Nikolay Vladimirov 2009-06-28 17:16:29 EDT
> The one about the git snapshots? I'm not using git snapshots. You can see all
> the releases here http://git.moblin.org/cgit.cgi/nbtk/refs/ The URL is correct.
Ok, sorry about that. 
> Also there is no HACKING file in the 0.11.1 tar ball and the README contains
> information for building it, which given its a binary package, isn't relevant
> to the RPM. 

Ok.

> There is also no plan to push any of the moblin stuff to F-11 or
> earlier as there are too many missing dependencies. I don't believe I've missed
> anything else.  

Even that you do not plan to push moblin to F-11 someone else can try to rebuild the package for his own purpose. It's better to have the version listed. It's a minor thing that can save someone's time.

Also the changelog in the .spec states that the last version of the package is 0.9.3 .
Comment 17 Peter Robinson 2009-06-28 17:31:11 EDT
> Even that you do not plan to push moblin to F-11 someone else can try to
> rebuild the package for his own purpose. It's better to have the version
> listed. It's a minor thing that can save someone's time.

I'm updated it although I really don't see much point as they're going to run into lots of other issues as most of the entire stack isn't supported on F11 and its not much use for much else.

> Also the changelog in the .spec states that the last version of the package is
> 0.9.3 .  

Oops. Updated.
Comment 18 Christoph Wickert 2009-08-08 18:52:24 EDT
Minor: %{_datadir}/gtk-doc/html/%{name} should be marked %doc

Note You need to log in before you can comment on or make changes to this bug.