Bug 50676 - owns /usr/share/locale/*/LC_MESSAGES
Summary: owns /usr/share/locale/*/LC_MESSAGES
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On: 50747
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-01 23:28 UTC by Enrico Scholz
Modified: 2016-11-24 15:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 19:18:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-08-01 23:28:48 UTC
The output of `rpm -ql freetype' contains

/usr/share/locale/cs/LC_MESSAGES
/usr/share/locale/de/LC_MESSAGES
/usr/share/locale/es/LC_MESSAGES
/usr/share/locale/fr/LC_MESSAGES
/usr/share/locale/nl/LC_MESSAGES

These directories should be owned by glibc-common only. Because most other
packages are following this rule, upgrade of freetype produces output like:

$ rpm -U freetype*
Warnung:    erase rmdir of /usr/share/locale/nl/LC_MESSAGES failed:
Directory not empty
Warnung:    erase rmdir of /usr/share/locale/fr/LC_MESSAGES failed:
Directory not empty
Warnung:    erase rmdir of /usr/share/locale/es/LC_MESSAGES failed:
Directory not empty
Warnung:    erase rmdir of /usr/share/locale/cs/LC_MESSAGES failed:
Directory not empty

Comment 1 Enrico Scholz 2001-08-02 20:02:55 UTC
Sorry, it not sure if glibc-common should own these dirs. Bug #50747 should
clarify this issue.

Comment 2 Glen Foster 2001-08-02 21:45:25 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 3 Mike A. Harris 2001-08-15 15:02:05 UTC
Changed freetype to use ${findlang}.  freetype-2.0.3-7


Note You need to log in before you can comment on or make changes to this bug.