Bug 50747 - Add policy for /usr/share/locale/* directories
Summary: Add policy for /usr/share/locale/* directories
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Mike McLean
URL:
Whiteboard:
: 52162 (view as bug list)
Depends On:
Blocks: 50676 50701 51381 52161
TreeView+ depends on / blocked
 
Reported: 2001-08-02 19:57 UTC by Enrico Scholz
Modified: 2015-03-05 01:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-28 04:47:52 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2001-08-02 19:57:59 UTC
Currently the most directories under /usr/share/locale are containing data
but are not owned by any package:

| $ cd /usr/share/locale
| $ rpm -qf af af/LC_MESSAGES/ af/LC_MESSAGES/sysstat.mo 
| file af is not owned by any package
| file af/LC_MESSAGES is not owned by any package
| sysstat-4.0.1-1

While upgrading packages a lot of ugly messages will be created:

| Warnung:    erase rmdir of /usr/share/locale/nl/LC_MESSAGES failed:
Directory not empty
| Warnung:    erase rmdir of /usr/share/locale/fr/LC_MESSAGES failed:
Directory not empty
| Warnung:    erase rmdir of /usr/share/locale/es/LC_MESSAGES failed:
Directory not empty
| Warnung:    erase rmdir of /usr/share/locale/cs/LC_MESSAGES failed:
Directory not empty

It would be nice to know which is the recommended strategy. Shall the
directories `af' and `af/LC_MESSAGES' owned by the `sysstat'-package, or
does there exists a package like `filesystem' which contains these dirs?

(Latter case seems to be inoperable because there exist thousands of
possible names)

Where have I to file my bugreports regarding such unowned dirs?

Comment 1 Glen Foster 2001-08-06 20:44:12 UTC
This needs to be documented somewhere (glibc?)... assigning to Bill.

Comment 2 Glen Foster 2001-08-06 22:28:43 UTC
This defect is considered SHOULD-FIX for Fairfax.

Comment 3 Bill Nottingham 2001-08-07 03:33:55 UTC
Jakub, since glibc owns most of these directories, I really don't see a much
better solution than it owning the union of all locales we ship in our packages;
comments?

Comment 4 Bill Nottingham 2001-08-21 12:58:01 UTC
*** Bug 52162 has been marked as a duplicate of this bug. ***

Comment 5 Tom "spot" Callaway 2005-06-24 07:08:49 UTC
This is still pending. FOUR YEARS LATER.

This is also an easy thing to fix.

Comment 6 Jakub Jelinek 2005-06-24 07:52:43 UTC
I disagree that this should be owned by glibc-common.
glibc-common owns just the 27 directories it ships libc.mo for, while there
are more than hundred other directories for locales of the day.
Maintaining it is going to be really hard.
Furthermore, e.g. coreutils populates also /usr/share/locale/*/LC_TIME
subdirectories in addition to LC_MESSAGES.

IMHO, either they should be owned by filesystem, in case somebody wants to
manually maintain the union, or each package that ships .mo files should own
its directories (the latter is a cleaner solution and cheaper for human work,
but more expensive for rpm/yum/etc. I guess).

Comment 7 Phil Knirsch 2006-06-28 04:47:52 UTC
The problem here is that filesystem could only own the "know"
/usr/share/locale/* directories (except those possibly owned by glibc, but would
need to manually keep that list in sync with glibc) and all possible subdirs in
those (which are LC_MESSAGES and LC_TIME currently).

Although that would be feasible i agree with Jakub here that packages that
install files there should own those directories and files with the same
arguments he brought up.

So fix is basically up to the respective packages.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.