This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 506798 - QEMU is not possible now booting from kernel image without specifying a bootable disk
QEMU is not possible now booting from kernel image without specifying a boota...
Status: CLOSED DUPLICATE of bug 506443
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 13:15 EDT by Miao ZhiCheng
Modified: 2009-06-18 13:24 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 13:24:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miao ZhiCheng 2009-06-18 13:15:52 EDT
Description of problem:
I use the following command to boot a kernel image before:
qemu -hda disk.img -net nic,vlan=0,model=rtl8139 -net tap,vlan=0,ifname=tap-kerneldev -kernel /data/home/mzhicheng/Documents/prog/linux/rootfs/kerneldev/boot/vmlinuz-2.6.30kerneldev -append ip=192.168.200.101:192.168.200.1:192.168.200.1:255.255.255.0:kerneldev root=/dev/nfs nfsroot=/data/home/mzhicheng/Documents/prog/linux/emacsprj/kerneldev/../../rootfs/kerneldev,udp,nolock ro

it worked before, disk.img is not a bootable disk image but with some partitions to test. After I upgrated to qemu-0.10.5-2.fc11.i586, it doesn't work any more and tell me "Booting from hard disk" and halt.

Version-Release number of selected component (if applicable):
qemu-0.10.5-2.fc11.i586
Comment 1 Mark McLoughlin 2009-06-18 13:24:13 EDT
Thanks for the report, it is a silly regression introduced by the qemu-0.10.5-2.fc11 update

A fix is currently queued up, please test:

https://admin.fedoraproject.org/updates/qemu-0.10.5-3.fc11

*** This bug has been marked as a duplicate of bug 506443 ***

Note You need to log in before you can comment on or make changes to this bug.