Bug 506807 - Can't install Fedora 11 x86_64, in free space near 100GB non partitioned and win2008 server standard installed in the same machine
Can't install Fedora 11 x86_64, in free space near 100GB non partitioned and ...
Status: CLOSED DUPLICATE of bug 495433
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:118554316a4d43d13...
:
: 507215 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 14:11 EDT by esdumbo2003
Modified: 2009-08-14 13:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 13:37:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (84.33 KB, text/plain)
2009-06-18 14:11 EDT, esdumbo2003
no flags Details
Attached traceback automatically from anaconda. (150.51 KB, text/plain)
2009-06-21 17:07 EDT, HJay
no flags Details
Anaconda stack trace log. (149.10 KB, text/plain)
2009-07-03 04:06 EDT, ricardo.gladwell
no flags Details

  None (edit)
Description esdumbo2003 2009-06-18 14:11:00 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/geometry.py", line 128, in intersect
    return Geometry(PedGeometry=self.__geometry.intersect(b.getPedGeometry()))
  File "/usr/lib/anaconda/storage/partitioning.py", line 501, in getBestFreeSpaceRegion
    free_geom = extended.geometry.intersect(_range)
  File "/usr/lib/anaconda/storage/partitioning.py", line 726, in allocatePartitions
    boot=_part.req_bootable)
  File "/usr/lib/anaconda/storage/partitioning.py", line 587, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/storage/partitioning.py", line 191, in doAutoPartition
    exclusiveDisks=anaconda.id.storage.clearPartDisks)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 712, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 965, in <module>
    anaconda.intf.run(anaconda)
CreateException: Error al abrir /dev/sdb: No se ha encontrado el medio
Comment 1 esdumbo2003 2009-06-18 14:11:11 EDT
Created attachment 348537 [details]
Attached traceback automatically from anaconda.
Comment 2 esdumbo2003 2009-06-18 14:18:35 EDT
I tried to install before in graphic mode, now I tried in text mode. The problem is when anaconda try to create the partition in free space. The free space is near 100 GB. 
When I tried to create manual partition, the installer show the same error when save the parameters for first partition

The machine is a Intel DG31PR with a Core2 Quad processor, and 500GB disk

Note
There isn't any problem to boot with live CD, but if I want to install from Live CD, happens the same problem

Sorry, but English isn't my native language
Comment 3 esdumbo2003 2009-06-18 14:23:56 EDT
Comment on attachment 348537 [details]
Attached traceback automatically from anaconda.

I tried to install before in graphic mode, now I tried in text mode. The
problem is when anaconda try to create the partition in free space. The free
space is near 100 GB. 
When I tried to create manual partition, the installer show the same error when
save the parameters for first partition

The machine is a Intel DG31PR with a Core2 Quad processor, and 500GB disk

Note
There isn't any problem to boot with live CD, but if I want to install from
Live CD, happens the same problem

Sorry, but English isn't my native language
Comment 4 HJay 2009-06-21 17:07:10 EDT
Created attachment 348820 [details]
Attached traceback automatically from anaconda.
Comment 5 HJay 2009-06-21 18:53:44 EDT
Comment on attachment 348820 [details]
Attached traceback automatically from anaconda.

The Fedora 10 installer experiences no difficulty with this arrangement (i.e. six-disk RAID 0 array with an ntfs Win XP Pro x64 partition, a Win 7 RC1 ntfs partition, and LVM for linux) -Very impressive.  In addition, I do get a report about "sde" being not responsive during the text based Fedora 11 install portion of "Finding Devices | Finding Storage Devices".  
  To get past the Fedora 11 hang-up, a fresh Fedora 10 install was done -wiping out the existing linux installation.  After that, the Fedora 11 install sort of works but errors out after installing packages and finalizing the installation.  -I'll attempt that again to see if the bug report is different.

Off topic: The graphical install of F11 fails.  With F10 it works without any problem on the same system with dual ATI 3870 PCIe graphics cards.    Upon reboot of the F11 install, I am able to get into the new install but xorg is broken.  Again, none of these problems occurred with F10.

Thank you.
Comment 6 HJay 2009-06-21 19:02:26 EDT
For clarification, the RAID is BIOS RAID on a Gigabyte GA-MA780FXT-UD5P motherboard.
Comment 7 HJay 2009-06-21 21:39:59 EDT
Comment on attachment 348820 [details]
Attached traceback automatically from anaconda.

I had no such trouble with Fedora 10.  This bug may be related to 506807 which I contributed to earlier today.

Thank you.
Comment 8 HJay 2009-06-21 21:49:15 EDT
I just generated another bug report (i.e. 507255) which might be related to this one.  The difference with the new bug is that it was generated After upgrading from F10 to F11 but before leaving the text-based installer.

I got around bug 506807 by reinstalling F10 and immediately rebooting off of the F11 x86_64 DVD (i.e. without initializing / personalizing the F10 installation).

Additional detail...
The updated GRUB loader looks fine and appears to work fine but the F11 install will not boot to a GUI.

Again, neither the LVM partition reuse nor the GUI issues occurred with Fedora 10.

Thank you.
Comment 9 Andy Lindeberg 2009-06-22 14:02:34 EDT
*** Bug 507215 has been marked as a duplicate of this bug. ***
Comment 10 ricardo.gladwell 2009-07-03 04:04:43 EDT
I'm getting the same issue on my 32 bit 686 system, with RAID installed. Please see attached stack trace. Does anyone have a work around for this?
Comment 11 ricardo.gladwell 2009-07-03 04:06:55 EDT
Created attachment 350388 [details]
Anaconda stack trace log.
Comment 12 David Lehman 2009-08-14 13:37:18 EDT

*** This bug has been marked as a duplicate of bug 495433 ***

Note You need to log in before you can comment on or make changes to this bug.