Bug 506829 - tetex-elsevier is outdated, does not provide the elsarticle document class
tetex-elsevier is outdated, does not provide the elsarticle document class
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tetex-elsevier (Show other bugs)
11
noarch Linux
low Severity medium
: ---
: ---
Assigned To: Mary Ellen Foster
Fedora Extras Quality Assurance
:
: 506826 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 15:45 EDT by Davide Cescato
Modified: 2009-07-11 13:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.1.20081007-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 13:22:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Cescato 2009-06-18 15:45:09 EDT
Description of problem:

Elsevier has introduced a new LaTeX document class named "elsarticle" that renders the previously used "elsart" document class obsolete. However, tetex-elsevier only provides the "elsart" document class, and not the "elsarticle" class.

The output of "rpmquery --filesbypkg tetex-elsevier" is as follows:
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024/CHANGES
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024/README
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024/instructions-harv.pdf
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024/instructions-num.pdf
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024/template-harv.tex
tetex-elsevier            /usr/share/doc/tetex-elsevier-0.1.20071024/template-num.tex
tetex-elsevier            /usr/share/texmf/bibtex/bst/elsevier
tetex-elsevier            /usr/share/texmf/bibtex/bst/elsevier/elsart-harv.bst
tetex-elsevier            /usr/share/texmf/bibtex/bst/elsevier/elsart-num-names.bst
tetex-elsevier            /usr/share/texmf/bibtex/bst/elsevier/elsart-num-sort.bst
tetex-elsevier            /usr/share/texmf/bibtex/bst/elsevier/elsart-num.bst
tetex-elsevier            /usr/share/texmf/tex/latex/elsevier
tetex-elsevier            /usr/share/texmf/tex/latex/elsevier/elsart.cls
tetex-elsevier            /usr/share/texmf/tex/latex/elsevier/elsart1p.cls
tetex-elsevier            /usr/share/texmf/tex/latex/elsevier/elsart3p.cls
tetex-elsevier            /usr/share/texmf/tex/latex/elsevier/elsart5p.cls

Version-Release number of selected component (if applicable):
tetex-elsevier-0.1.20071024-2.fc11.noarch

Expected result:
tetex-elsevier should provide the elsarticle document class; the elsart class should be kept in the package to allow old documents to compile.
Comment 1 Davide Cescato 2009-06-18 15:49:33 EDT
*** Bug 506826 has been marked as a duplicate of this bug. ***
Comment 2 Patrice Dumas 2009-06-18 17:23:33 EDT
Since none of the file of the new class conflicts with the old class file, I'd be in favor just to add the new styles without dropping the old (though maybe isolate the old classes documentation files in a specific subdirectory).
Comment 4 Fedora Update System 2009-06-22 05:22:28 EDT
tetex-elsevier-0.1.20081007-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tetex-elsevier-0.1.20081007-1.fc11
Comment 5 Fedora Update System 2009-06-22 06:37:03 EDT
tetex-elsevier-0.1.20081007-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tetex-elsevier-0.1.20081007-2.fc11
Comment 6 Fedora Update System 2009-06-22 06:37:46 EDT
tetex-elsevier-0.1.20081007-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/tetex-elsevier-0.1.20081007-2.fc10
Comment 7 Davide Cescato 2009-06-22 06:53:22 EDT
The bug fix is good, however the log entries somehow carry a date (20081024) different from the one in the build identifier (20081007).

* Mon Jun 22 2009 Mary Ellen Foster <mefoster at gmail.com> - 0.1.20081024-2
- Better location for the elsarticle files 

* Mon Jun 22 2009 Mary Ellen Foster <mefoster at gmail.com> - 0.1.20081024-1
- Add the elsarticle class as well
Comment 8 Fedora Update System 2009-06-24 15:34:24 EDT
tetex-elsevier-0.1.20081007-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tetex-elsevier'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-6939
Comment 9 Fedora Update System 2009-06-24 15:38:54 EDT
tetex-elsevier-0.1.20081007-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tetex-elsevier'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6868
Comment 10 Fedora Update System 2009-07-11 13:22:19 EDT
tetex-elsevier-0.1.20081007-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-07-11 13:37:15 EDT
tetex-elsevier-0.1.20081007-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.