Bug 50697 - /var/lib/rpm/__db.* are shipped rpm.rpm but created root.root
Summary: /var/lib/rpm/__db.* are shipped rpm.rpm but created root.root
Status: CLOSED DUPLICATE of bug 49663
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-02 10:51 UTC by Jonathan Kamens
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 10:51:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-08-02 10:51:16 UTC
The database cache files /var/lib/rpm/__db.* are shipped in the rpm package
with ownership rpm.rpm, but if they're created during rpm operations,
they're created with ownership root.root (since rpm is running as root). 
Either (a) rpm should chown/chgrp the files after creating them, or (b)
they should be shipped with ownership root.root so the ownership in the
package matches the ownership when they're created dynamically.

Comment 1 Jeff Johnson 2001-08-02 15:56:27 UTC

*** This bug has been marked as a duplicate of 49663 ***


Note You need to log in before you can comment on or make changes to this bug.