Bug 507010 - Jobs in /etc/cron.{hourly,daily,weekly,monthly} do not fire without anacron installed
Jobs in /etc/cron.{hourly,daily,weekly,monthly} do not fire without anacron i...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: crontabs (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 508432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 16:10 EDT by Ben Webb
Modified: 2009-06-30 03:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 16:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Webb 2009-06-19 16:10:09 EDT
Description of problem:
Since upgrading to F11, none of the periodic cronjobs (/etc/cron.daily etc.) fire any more. From the crontabs changelog, it looks like in 1.10-26 these directories were removed from /etc/crontab since "anacron will handle it". However, none of our systems have the anacron package installed (they are typically always-on server machines, and use the cronie package instead).

Version-Release number of selected component (if applicable):
crontabs-1.10-29.fc11.noarch

How reproducible:
Always.

Steps to Reproduce:
1. Install crontabs and cronie package, but not anacron.
2. Wait for an hourly or daily cronjob to become due.
  
Actual results:
cronjobs do not fire.

Expected results:
cronjobs do fire.
Comment 1 Tomas Mraz 2009-06-19 16:43:00 EDT
Please, just install anacron as that is the only supported way to run the daily, weekly and monthly jobs.

Of course the other possibility for you is to add the run-parts jobs manually into the /etc/crontab, but you're on your own in that case.

cronie will probably in future integrate with anacron completely.
Comment 2 Ben Webb 2009-06-19 17:19:43 EDT
(In reply to comment #1)
> Please, just install anacron as that is the only supported way to run the
> daily, weekly and monthly jobs.

This seems to have been missed from the F11 release notes. Periodic jobs ran just fine in F10 without requiring anacron.

I am not a huge fan of anacron (since my machines are on 24/7, I have no need of it) but if I am going to be required to use it anyway in order for my cronjobs to actually work (rather than being silently ignored) the crontabs package should depend on anacron, not just on cronie. Isn't this what RPM dependencies are for?
Comment 3 Marcela Mašláňová 2009-06-23 08:40:26 EDT
cronie requires anacron and anacron requires crontabs. 

crontabs is needed by other packages so I didn't want to create useless requirements.

I plan including cron and anacron functionality in one package so the problematic requires disappear hopefully in next Fedora.
Comment 4 Ben Webb 2009-06-23 10:52:21 EDT
(In reply to comment #3)
> cronie requires anacron and anacron requires crontabs.

This seems like a reasonable solution to me, but it does not appear to be the case in the current stable updated version of F11:

$ rpm -q cronie
cronie-1.3-1.fc11.x86_64
$ rpm -q --requires cronie|grep anacron
$

RPM also did not complain when I removed the anacron package, of course. (If I had removed the anacron package with --nodeps, obviously I would be to blame for the problem and so this bug report simply wouldn't exist.)

Is the dependency you refer to added in a later version of the cronie package? If so, what is the version/release? I can test this fix out.
Comment 5 Marcela Mašláňová 2009-06-23 11:08:58 EDT
anacron-2.3-75.fc11 & cronie-1.3-2.fc11 (in testing). Both of them should be soon in stable updates.
Comment 6 Tomas Mraz 2009-06-30 03:18:32 EDT
*** Bug 508432 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.