Bug 507092 - flash plugin unavailable after autostarting firefox
flash plugin unavailable after autostarting firefox
Status: CLOSED DUPLICATE of bug 489641
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 15:34 EDT by Stefan Seefeld
Modified: 2009-06-25 17:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 17:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Seefeld 2009-06-20 15:34:02 EDT
Description of problem:

When I start Firefox manually, I can use the flash plugin fine. However, when firefox gets started during (auto-)startup, it appears to be seeing a different environment, and can't run the flash plugin.


Version-Release number of selected component (if applicable):

At present I'm running Firefox 3.5 beta 4, but I have been observing this issue since Fedora 9 with whatever firefox was part of that.

How reproducible:

Start firefox, then log out. Log in again, causing firefox to get autostarted. Try to use the flash plugin (youtube, say).

I'm running Fedora 11 on x86_64.
Comment 1 Jason Tibbitts 2009-06-25 12:53:40 EDT
I'm seeing this as well.  For me it's not just flash; on a fresh login (updated F11, KDE) with firefox autostarting, about:plugins shows no available plugins.  After exiting firefox and starting it again (either by command line, Alt-F2, or the menus) about:plugins shows flash, icedtea, the totem plugins and npwrapper.
Comment 2 Jason Tibbitts 2009-06-25 13:03:49 EDT
I should add, x86_64 here too.  This is a fresh install, not updated from anything.
Comment 3 Jason Tibbitts 2009-06-25 13:06:19 EDT
Sorry to spam, but I noticed that this is possibly a dup of bug 489641.
Comment 4 Stefan Seefeld 2009-06-25 13:15:07 EDT
I seem to remember once seeing an error message related to this, suggesting that firefox saw a prerequisite library, but couldn't load it as it was a 32-bit variant, while it itself is the 64-bit firefox. Again, this suggests may be the LD_LIBRARY_PATH doesn't include some lib64 path.
Comment 5 Matěj Cepl 2009-06-25 14:47:47 EDT
Do you have KDE? If yes, then this is a duplicate of bug 489641
Comment 6 Matěj Cepl 2009-06-25 14:48:57 EDT
Sorry, Jason, yes, you are right. Just need to know from reporter, whether he is on KDE (which he probably is because sesion management on Gnome is broken, that he cannot expect it to work at all ;-))
Comment 7 Stefan Seefeld 2009-06-25 15:05:44 EDT
Yes, confirmed. I'm running KDE.
Comment 8 Matěj Cepl 2009-06-25 17:06:55 EDT
(In reply to comment #1)
> I'm seeing this as well.  For me it's not just flash; on a fresh login (updated
> F11, KDE) with firefox autostarting, about:plugins shows no available plugins. 
> After exiting firefox and starting it again (either by command line, Alt-F2, or
> the menus) about:plugins shows flash, icedtea, the totem plugins and npwrapper.  

Yes, that's duplicate behavior of the bug I am closing this against. The problem is that we need firefox to be run from the shell script /usr/bin/firefox to get all plugins. However, session management in KDE sees running /usr/lib*/firefox*/firefox-bin binary and so it tries to restart it on resume. Unfortunately, that makes running firefox without the environment prepared by /usr/bin/firefox.

I see some rumours from upstream, that they working on it, so this should hopefully be fixed soon.

*** This bug has been marked as a duplicate of bug 489641 ***

Note You need to log in before you can comment on or make changes to this bug.