Bug 507109 - Empathy crashes when trying to call
Empathy crashes when trying to call
Status: CLOSED DUPLICATE of bug 507009
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 17:55 EDT by Christoph Maser
Modified: 2009-06-21 03:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 03:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 586497 None None None Never

  None (edit)
Description Christoph Maser 2009-06-20 17:55:12 EDT
Description of problem:
When i try to call a jabber-contact empathy crashes

Version-Release number of selected component (if applicable):
empathy-2.26.2-1.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
Take two empathy clients and two jabber acccounts. Try to establish a call between the two.
  
Actual results:
Program crashes (SIGSEGV)

Expected results:
Sucessful voice/video call

Additional info:
gdb backtrace:

Program received signal SIGSEGV, Segmentation fault.
get_all_properties_cb (proxy=<value optimized out>, out_Properties=<value optimized out>, error=<value optimized out>, 
    user_data=<value optimized out>, weak_object=<value optimized out>) at stream.c:839
839	      tf_stream_error (stream, 0, error->message);
(gdb) bt
#0  get_all_properties_cb (proxy=<value optimized out>, out_Properties=<value optimized out>, error=<value optimized out>, 
    user_data=<value optimized out>, weak_object=<value optimized out>) at stream.c:839
#1  0x0000003a89a90248 in _tp_cli_dbus_properties_invoke_callback_get_all (self=0xc142a0, error=0x0, args=0x8290a0, 
    generic_callback=0x7ffff74beda0 <get_all_properties_cb>, user_data=<value optimized out>, weak_object=0x4804)
    at _gen/tp-cli-generic-body.h:1421
#2  0x0000003a89a92df7 in tp_proxy_pending_call_idle_invoke (p=0xc61c60) at proxy-methods.c:153
#3  0x0000003a88637afe in g_main_dispatch (context=<value optimized out>) at gmain.c:1814
#4  IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
#5  0x0000003a8863b1d8 in g_main_context_iterate (context=0x672a30, block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>) at gmain.c:2445
#6  0x0000003a8863b635 in IA__g_main_loop_run (loop=0xa36fe0) at gmain.c:2653
#7  0x000000377f9279c7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#8  0x00000000004138fa in main (argc=1, argv=0x7fffffffe318) at empathy.c:612
(gdb) quit
Comment 1 Christoph Maser 2009-06-21 03:14:36 EDT
According to the gnome folks this is caused by a missing dependency:
http://bugzilla.gnome.org/show_bug.cgi?id=586497

*** This bug has been marked as a duplicate of bug 507009 ***

Note You need to log in before you can comment on or make changes to this bug.