Bug 507249 - WARNING: at mm/page_alloc.c:1160 get_page_from_freelist+0x34c/0x6dc()
WARNING: at mm/page_alloc.c:1160 get_page_from_freelist+0x34c/0x6dc()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 507753 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-21 20:00 EDT by Tom London
Modified: 2009-10-01 13:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 13:19:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-06-21 20:00:49 EDT
Description of problem:

------------[ cut here ]------------
WARNING: at mm/page_alloc.c:1160 get_page_from_freelist+0x34c/0x6dc()
Hardware name: 74585FU
Modules linked in: sunrpc(+) ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq freq_table dm_multipath kvm_intel kvm uinput arc4 snd_hda_codec_conexant ecb snd_hda_intel snd_hda_codec iwlagn snd_hwdep pcspkr btusb i2c_i801 snd_pcm iwlcore snd_timer usb_storage bluetooth snd iTCO_wdt mac80211 iTCO_vendor_support soundcore usblp snd_page_alloc e1000e thinkpad_acpi cfg80211 hwmon wmi rfkill i915 drm i2c_algo_bit video output i2c_core [last unloaded: microcode]
Pid: 1463, comm: rsyslogd Not tainted 2.6.31-0.17.rc0.git15.fc12.x86_64 #1
Call Trace:
 [<ffffffff81062c49>] warn_slowpath_common+0x8d/0xbb
 [<ffffffff81062c9e>] warn_slowpath_null+0x27/0x3d
 [<ffffffff810fcaff>] get_page_from_freelist+0x34c/0x6dc
 [<ffffffff810fd022>] __alloc_pages_nodemask+0x193/0x5f9
 [<ffffffff811624c5>] ? __find_get_block_slow+0x6a/0x120
 [<ffffffff811624c5>] ? __find_get_block_slow+0x6a/0x120
 [<ffffffff811624c5>] ? __find_get_block_slow+0x6a/0x120
 [<ffffffff811280cc>] alloc_pages_current+0xa8/0xc8
 [<ffffffff8112ee4b>] alloc_slab_page+0x2e/0x4f
 [<ffffffff8112eecc>] new_slab+0x60/0x1fb
 [<ffffffff8112f5bb>] __slab_alloc+0x227/0x3f0
 [<ffffffff811f7f93>] ? start_this_handle+0xbc/0x568
 [<ffffffff811f7f93>] ? start_this_handle+0xbc/0x568
 [<ffffffff8112fb48>] kmem_cache_alloc_notrace+0xbf/0x13a
 [<ffffffff811f7f93>] start_this_handle+0xbc/0x568
 [<ffffffff811f865b>] jbd2_journal_start+0xd4/0x144
 [<ffffffff811d6211>] ext4_journal_start_sb+0x67/0xa3
 [<ffffffff811bf83d>] ext4_journal_start+0x28/0x3e
 [<ffffffff811c0d70>] ext4_dirty_inode+0xd6/0x104
 [<ffffffff8115cf21>] __mark_inode_dirty+0x43/0x10e
 [<ffffffff8115102e>] file_update_time+0xc3/0x118
 [<ffffffff810f6e89>] __generic_file_aio_write_nolock+0x182/0x2d3
 [<ffffffff810f73a3>] generic_file_aio_write+0x7b/0xef
 [<ffffffff811bd02a>] ext4_file_write+0xaa/0x148
 [<ffffffff8113b7a5>] do_sync_write+0xfa/0x14b
 [<ffffffff8104f4e9>] ? __dequeue_entity+0x46/0x63
 [<ffffffff8107f267>] ? autoremove_wake_function+0x0/0x5f
 [<ffffffff8121c5e8>] ? security_file_permission+0x29/0x3f
 [<ffffffff8113be59>] vfs_write+0xbd/0x12e
 [<ffffffff8113d0c3>] ? fget_light+0x63/0xfd
 [<ffffffff8113bfbc>] sys_write+0x59/0x91
 [<ffffffff81012f42>] system_call_fastpath+0x16/0x1b
---[ end trace e1d87d703125d273 ]---


Version-Release number of selected component (if applicable):
kernel-2.6.31-0.17.rc0.git15.fc12.x86_64

How reproducible:
Looks like every boot.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2009-06-23 22:47:44 EDT
That code has been mostly rewritten since -git15.
Comment 2 Chuck Ebbert 2009-07-07 09:14:48 EDT
*** Bug 507753 has been marked as a duplicate of this bug. ***
Comment 3 Tom London 2009-08-19 09:58:45 EDT
Haven't seen one of these in ages.

Close?
Comment 4 Adam Williamson 2009-10-01 13:19:29 EDT
if it's not reproducible any more, yes.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.