Bug 507279 - Pidgin does not connect to Yahoo
Pidgin does not connect to Yahoo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
: 507590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 02:23 EDT by Gerard Fernandes
Modified: 2009-07-07 13:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-07 13:31:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2009-06-22 02:23:35 EDT
Description of problem:
Pidgin can't connect to Yahoo anymore - connects to google-talk.

Version-Release number of selected component (if applicable):
Pidgin 2.5.6-1.fc11 (libpurple 2.5.6)

How reproducible: always


Steps to Reproduce:
1. Ensure you've set up 2 accounts in Pidgin: one Yahoo account and one Google account
2. Start up Pidgin
3. Observe you're connected to Google Talk, but Pidgin seems to hang connecting to Yahoo
  
Actual results: No connectivity to Yahoo.


Expected results: Connection to Yahoo should work.


Additional info:
This used to work on a fresh install. A recent update has broken it.
Comment 1 Gerard Fernandes 2009-06-22 05:10:35 EDT
This looks like Yahoo breaking Pidgin by changing their authentication mechanism/protocol.

http://bigbrovar.wordpress.com/2009/06/21/how-to-fix-pidgin-and-yahoo-issues/

Maybe everyone should just stop using Yahoo :P
Comment 2 Larry O'Leary 2009-06-22 12:18:08 EDT
Not sure why this was logged as non-critical but as Pidgin is an IM client and Yahoo is an IM service, connection failure would seem pretty critical to me.

This issue has been resolved with the latest release of Pidgin.  Could we get the package rebuilt for Fedora 9, 10, and 11?
Comment 3 Warren Togami 2009-06-22 13:14:48 EDT
http://wtogami.livejournal.com/30882.html
Comment 4 Amir Hedayaty 2009-06-23 05:36:40 EDT
Can anyone update this? I know several people with the same problem (though it works on Fc10)
Comment 5 Robert Story 2009-06-23 10:30:15 EDT
i was having this problem on f10 too... the update at http://kojipkgs.fedoraproject.org/packages/pidgin/2.5.7/ works for me..
Comment 6 Warren Togami 2009-06-23 10:46:16 EDT
*** Bug 507590 has been marked as a duplicate of this bug. ***
Comment 7 Steven Schveighoffer 2009-06-24 13:40:05 EDT
related issue on pidgin's bug tracker:

http://developer.pidgin.im/ticket/9414

BTW, the above mentioned update on kojipkgs works for me too on fedora 11.
Comment 8 Larry O'Leary 2009-06-24 14:10:06 EDT
(In reply to comment #3)
> http://wtogami.livejournal.com/30882.html  

Seems like the x86_64 libpurple package at http://kojipkgs.fedoraproject.org/packages/pidgin/2.5.7/1.fc10/x86_64/ (and maybe others) has a dependency on libpurple    i386   2.5.6-1.fc10 which in turn has a dependency on many other i386 libs.  So, I am unable to test on x86_64.
Comment 9 Warren Togami 2009-06-24 14:43:40 EDT
rpm -qp --requires libpurple-2.5.7-1.fc10.x86_64.rpm  |grep libpurple
libpurple-client.so.0()(64bit)  
libpurple.so.0()(64bit)  

Nope.  Something is wrong on your system.
Comment 10 Gerard Fernandes 2009-06-27 17:37:37 EDT
Pidgin 2.5.7-1.fc11 (libpurple 2.5.7) works as expected.
Comment 11 Robert Story 2009-07-06 13:52:45 EDT
update: I can log in and chat ok, but it appears that once a buddy logs in, they are show as online/available, even after they log out. If you log out of a yahoo account and log back in, only currently available buddies will show up. i.e.

- log in to myAccount
- log in to myBuddy
- myAccount shows myBuddy online
- log off myBuddy
- myAccount still shows myBuddy online
- log off myAccount
- log in to myAccount
- myAccount correctly shows myBuddy offline
Comment 12 Robert Story 2009-07-06 13:58:07 EDT
never mind... just noticed that 2.5.8 is out, and it fixes this problem!

Note You need to log in before you can comment on or make changes to this bug.