Bug 507426 - Firstboot modules missing from redhat-release package
Firstboot modules missing from redhat-release package
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-release-server (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Andrew Thomas
Release Test Team
:
: 507778 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 14:04 EDT by Jay Turner
Modified: 2016-01-18 11:09 EST (History)
6 users (show)

See Also:
Fixed In Version: redhat-release-6-6.0.0.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 08:11:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed eula.py (4.07 KB, text/plain)
2009-06-24 11:19 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Jay Turner 2009-06-22 14:04:46 EDT
Description of problem:
The firstboot modules are missing from redhat-release-6-6.0.0.5.  Net result is that at firstboot, there are several references to "Fedora" and the "Fedora Project."  References which should be overridden by the firstboot modules included in redhat-release (or somewhere else . . . they are in release-release in RHEL5.)

Version-Release number of selected component (if applicable):
6-6.0.0.5

How reproducible:
Always

Steps to Reproduce:
1. Install a box and check out the EULA text in firstboot.
  
Actual results:
References to "Fedora" and "Fedora Project"

Expected results:
References to "Red Hat Enterprise Linux"
Comment 1 Dennis Gregorovic 2009-06-23 10:53:14 EDT
I've rebuilt firstboot with the fedora-specific eula.py dropped and also rebuilt redhat-release with the old RHEL eula.py added.

redhat-release-6-6.0.0.6
firstboot-1.106-2.el6
Comment 2 Jay Turner 2009-06-24 07:57:54 EDT
I don't think firstboot is too happy with the old-style eula.py file:

/usr/lib64/python2.6/site-packages/firstboot/loader.py:89: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  if isinstance(e, ImportError) and e.message.find("firstboot_module_window") != -1:
firstboot CRITICAL: Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/firstboot/loader.py", line 87, in loadModules
    loaded = imputil.imp.load_module(module, found[0], found[1], found[2])
  File "/usr/share/firstboot/modules/eula.py", line 6, in <module>
    import functions
ImportError: No module named functions

This is with
firstboot-1.106-2.el6.x86_64
redhat-release-6-6.0.0.6.x86_64
Comment 3 Bill Nottingham 2009-06-24 10:55:53 EDT
*** Bug 507778 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2009-06-24 11:19:57 EDT
Created attachment 349256 [details]
Fixed eula.py

Here's a fixed version. Tested with Fedora firstboot.
Comment 5 Dennis Gregorovic 2009-06-24 11:39:05 EDT
Thanks for the fix.  Built into redhat-release-6-6.0.0.7
Comment 6 Jay Turner 2009-06-24 15:36:31 EDT
Things are looking much better with 6-6.0.0.7.  Moving to Verified.
Comment 7 Jay Turner 2010-01-20 08:11:19 EST
redhat-release-6-6.0.0.15 included in RHEL6.0-20100116.0.

Note You need to log in before you can comment on or make changes to this bug.