Bug 507446 - Audio CD not mounted on Fedora 11.
Audio CD not mounted on Fedora 11.
Status: CLOSED DUPLICATE of bug 513495
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: audio/CD/icons (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 15:28 EDT by Erik P. Olsen
Modified: 2013-03-05 22:58 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-09 10:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error messages from inserting CD on F11 system. (2.10 KB, text/plain)
2009-06-22 15:28 EDT, Erik P. Olsen
no flags Details

  None (edit)
Description Erik P. Olsen 2009-06-22 15:28:30 EDT
Created attachment 348981 [details]
Error messages from inserting CD on F11 system.

Description of problem:
When an audio CD is inserted in the driver nothing happens.

Version-Release number of selected component (if applicable):
gnome-mount-0.8-5.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. Insert audio CD
2.
3.
  
Actual results:
Nada.

Expected results:
Icon on desktop and ability to play music from the CD.

Additional info:
See messages produced in the attachment.

The bug is reported against my test system but is also present on my 64-bit system which is being prepared for production

I do not have the problem with Fedora 10 on same hardware.
Comment 1 Erik P. Olsen 2009-07-04 17:57:17 EDT
I somehow managed to make x86 platform accept audio CDs. I am not sure what triggered it maybe a kernel update or perhaps changing an entry in "Preferred Applications" for media. However the problem persists on the x86_64 platform, I have therefore changed the reported platform accordingly.
Comment 2 Erik P. Olsen 2009-07-04 18:26:07 EDT
BTW there are no error messages logged from the x86_64 system so the attached error messages are only related to the x86 system.
Comment 3 Need Real Name 2009-07-16 23:00:27 EDT
Same problem as reported above.  FC 11 can't read the audio cd, can read data cd.  The problem did not exist in FC 9.  This system is i386, up to date with fc11.
Comment 4 Stephen Herr 2009-07-21 12:14:18 EDT
Same problem as reported above. I'm running x86_64 F11 with KDE although I do apparently have the gnome-mount rpm installed. System is up to date.
Comment 5 Zsombor Nemestóthy 2009-07-22 08:47:27 EDT
Same problem as reported above. Kernel: 2.6.29.5-191.fc11.i686.PAE.
I use KDE. System is up to date.
Comment 6 Erik P. Olsen 2009-07-23 04:03:30 EDT
I've changed the component to hal because I felt this is the failed component since the problem occurs both with gnome and kde.
Comment 7 Mikkel L. Ellertson 2009-07-26 17:03:22 EDT
*** Bug 513875 has been marked as a duplicate of this bug. ***
Comment 8 Mikkel L. Ellertson 2009-07-26 17:06:38 EDT
I can access the audio CD on my x86 system even though the icon does not show up, and I do not get the popup asking me what I want to do. I can play the audio CDs if I fire up the program manually - it sees the CD in the drive, and will play it.
Comment 9 Paul 2009-07-26 19:52:00 EDT
Same problem here. I have an F11 system updated 27jun09 and the CD-DVD drive recognizes audio CDs (though not the second CD only drive). On another F11 that I yum updated today, not only does the system not recognize the CD, the icon for the drive in the "My Computer" view vanishes until I remove the audio CD. This happens in both its CD-DVD and the second CD only drives. DVD functionality "seems" to work for QT movies on both machines.

I am using the same model CD-DVD drive in both F11 machines. The same CD played on both machines when they were on F9 (and my F9 machine still plays it)

I was unable to get the recently updated F11 machine to see the CD via any means, it seems to just "think the drive is not there".

I also notice that under my F9 system, I see the machine's floppy drive A under "My Computer" but it isn't there in either of the F11 machines. The floppy is working as I use it on HP Diag tools to write results and can read it on an old Win98se system that has a floppy. This may be a different issue, but I thought I would add since it does appear related to the extent that it is F11's detection of drives and what is in them.

Thanks,
Paul
Comment 10 Mikkel L. Ellertson 2009-07-26 20:34:50 EDT
Dumb idea - could it be something as simple as missing icons?
Comment 11 Paul 2009-07-26 22:05:11 EDT
Wouldn't the user get an error message if something were missing that caused process to stop? It very well could be that simple and I don't think it is all that dumb an idea, but my "I don't know what I am talking about" gut feeling is that the lack of icon(s) is the system's way of telling me "this drive no longer exists as far as I am concerned".

Certainly seems that way with the vanish and return of the CD/CD-DVD icons. Who knows about the floppy

I ran a quick test and discovered that, for the floppy, both F9 and F11 aren't recognizing floppy's written by the HP Diag Tools on their respective machines, I can only read them on my old Win98se. But HP Diag tools has no trouble finding and writing to them (for the record, the two F11 machines are X4000 and the F9 is XW8000). So, to me, this is looking more and more like a different problem (that being said, "???")
Comment 12 Zsombor Nemestóthy 2009-07-27 05:29:39 EDT
I don't think the bug 513875 is a duplicate of this bug, because it says "/var/log/messages does not show anything unusual when you insert
the CD". But I have many error messages from the kernel (Buffer I/O error on device sr0) when i insert an audio CD as you can see from the attachement 348981. So I don't think it's just a missing icon problem.
Comment 13 Zsombor Nemestóthy 2009-07-27 05:32:31 EDT
Sorry, I mistyped the attachment 348981 [details].
Comment 14 Aaron Konstam 2009-07-27 09:37:27 EDT
When I insert the audio CD I get sevverl characteristic error messagwes:

Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Jul 27 08:36:09 localhost kernel: Info fld=0x0, ILI
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Jul 27 08:36:09 localhost kernel: end_request: I/O error, dev sr0, sector 0
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 0
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 1
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 2
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 3
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Jul 27 08:36:09 localhost kernel: Info fld=0x0, ILI
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Jul 27 08:36:09 localhost kernel: end_request: I/O error, dev sr0, sector 0
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 0
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Jul 27 08:36:09 localhost kernel: Info fld=0x0, ILI
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Jul 27 08:36:09 localhost kernel: end_request: I/O error, dev sr0, sector 0
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 0
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 1
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 2
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 3
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Jul 27 08:36:09 localhost kernel: Info fld=0x0, ILI
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Jul 27 08:36:09 localhost kernel: end_request: I/O error, dev sr0, sector 0
Jul 27 08:36:09 localhost kernel: Buffer I/O error on device sr0, logical block 0
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE,SUGGEST_OK
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Jul 27 08:36:09 localhost kernel: Info fld=0x0, ILI
Jul 27 08:36:09 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Jul 27 08:36:09 localhost kernel: end_request: I/O error, dev sr0, sector 0
Comment 15 Tim Dewhirst 2009-07-31 12:37:58 EDT
I see the same as #14, platform is x86:

[tpd@bugless-5 ~]$ uname -a
Linux bugless-5 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT 2009 i686 i686 i386 GNU/Linux

Was working fine in FC9. I did a clean install to get to FC11.
Comment 16 Aram Agajanian 2009-08-01 00:21:26 EDT
Those who experienced this bug in late July should look at bug #513495.
Comment 17 John Williams 2009-08-03 05:27:13 EDT
When I insert a DVD, no icon appears on the desktop as it used to and the drive in 'My Computer' disappears. Kaffeine will play the DVD but it does not detect a DVD inserted in a second drive.
To eject the DVD I have to either restart the computer or do 'eject /media/DVD_VIDEO_RECORDER' in a terminal

Linux localhost.localdomain 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT 2009 i686 athlon i386 GNU/Linux
The system is up to date.
Comment 18 Alex Lancaster 2009-08-03 05:34:51 EDT
(In reply to comment #17)
> When I insert a DVD, no icon appears on the desktop as it used to and the drive
> in 'My Computer' disappears. Kaffeine will play the DVD but it does not detect
> a DVD inserted in a second drive.
> To eject the DVD I have to either restart the computer or do 'eject
> /media/DVD_VIDEO_RECORDER' in a terminal
> 
> Linux localhost.localdomain 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7
> 20:59:29 EDT 2009 i686 athlon i386 GNU/Linux
> The system is up to date.  

This sounds like a duplicate of bug #513495 and the underlying problem is with udev not hal.  This bug should probably be closed as a duplicate of that one.
Comment 19 Mark Johnson 2009-08-14 16:45:51 EDT
I'm running FC11 x64, 2.6.29.6-217.2.3.fc11.x86_64, and am having the same problem I've seen described in this thread.  If I downgrade to udev-141-3, the problem goes away.  I tried updating to the udev-141-6 linked above, but the problem returned.  I downgraded to udev-141-3 again, and the problem disappeared again.  If udev-141-6 resolves this issue for some, then I think it's likely an incomplete fix.  Thanks!
Comment 20 Tim Pepper 2009-08-31 20:19:25 EDT
I guess this signals that audio cd's are truly dead.  This has been going on for a year and a google search makes it look like other distros are in similar shape.

FWIW the downgrade worked for me:

Removed:
  libudev0.i586 0:141-4.fc11             libvolume_id.i586 0:141-4.fc11        
  rhythmbox.i586 0:0.12.3-1.fc11         udev.i586 0:141-4.fc11                

Installed:
  libudev0.i586 0:141-3.fc11             libvolume_id.i586 0:141-3.fc11        
  rhythmbox.i586 0:0.12.1-3.fc11         udev.i586 0:141-3.fc11
Comment 21 Andre Costa 2009-09-07 18:27:54 EDT
Argh... score another one for F11 :-( As if F11 didn't have enough problems sound-wise, now audio CDs don't play. I had seen this a couple of days ago, but I thought it was a hardware problem considering those scary messages on /var/log/messages, but I just realized WinXP still handles audio CDs just fine on the same computer.
Comment 22 Jonathan Steffan 2009-09-08 16:22:41 EDT
I will confirm the downgrade to 141-3 allows the use of audio CDs again.
Comment 23 Andre Costa 2009-09-08 17:42:30 EDT
Shouldn't the "component" tag of this bug be changed to "udev" then? Chances are it is not being seen by the right people...
Comment 24 Andre Costa 2009-09-08 17:48:54 EDT
Ops, as others already mentioned, there it is: bug #513495. Sorry for the noise...
Comment 25 Scott Glaser 2009-09-09 10:10:43 EDT
This appears to be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=513495

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 513495 ***

Note You need to log in before you can comment on or make changes to this bug.