Bug 513495 - CD audio stops working after update to new release of udev
CD audio stops working after update to new release of udev
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: DeviceKit-disks (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 458036 507446 526229 (view as bug list)
Depends On:
Blocks: 516998 533643
  Show dependency treegraph
 
Reported: 2009-07-23 17:51 EDT by Aram Agajanian
Modified: 2013-03-05 22:58 EST (History)
43 users (show)

See Also:
Fixed In Version: 004-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 533643 (view as bug list)
Environment:
Last Closed: 2009-10-27 02:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Errors after inserting a CD audio disk (1.28 KB, text/plain)
2009-07-23 17:51 EDT, Aram Agajanian
no flags Details
playing audio CD's (78 bytes, text/plain)
2009-08-31 07:00 EDT, qualimax
no flags Details
specfile patch (1.76 KB, patch)
2009-10-09 11:06 EDT, Harald Hoyer
no flags Details | Diff
patch to fix audio CDs (1.68 KB, patch)
2009-10-09 11:07 EDT, Harald Hoyer
no flags Details | Diff
Unable to mount Audio Disc - repeated popup error (13.08 KB, image/png)
2009-10-21 09:15 EDT, Nik Lam
no flags Details

  None (edit)
Description Aram Agajanian 2009-07-23 17:51:26 EDT
Created attachment 354933 [details]
Errors after inserting a CD audio disk

Description of problem:
Today, two of our PCs running Fedora 11 had the latest updates applied.  In both cases, CD Audio stopped working.  I found that by backing out udev, libudev0, and libvolume_id to version 141-1, CD Audio started working again.

Version-Release number of selected component (if applicable):
141-4

How reproducible:
Happens every time.

Steps to Reproduce:
1.  Insert audio CD into drive.
2.
3.
  
Actual results:
The icon for the drive should change to an icon titled Audio Disc.

Expected results:
The icon for the drive disappears.


Additional info:
There are some kernel messages.  (See attached file.)  They are similar to bug #
458036.
Comment 1 Harald Hoyer 2009-07-24 03:07:15 EDT
To find out which change broke audio can you try 141-3?

Download from:
https://koji.fedoraproject.org/koji/buildinfo?buildID=99462
Comment 2 Aram Agajanian 2009-07-24 11:12:19 EDT
141-3 works OK.  It seems to recognize a CD Audio disk the same way that 141-1 does.

By the way, I just noticed that the errors in the attachment are present in all three releases.  The only difference is the number in the __ratelimit: nn callbacks suppressed line.
Comment 3 Harald Hoyer 2009-07-24 11:21:36 EDT
if you are familiar with rpm building, you could take the udev src.rpm, install it and comment out the patches one by one and see which one breaks your system.

I would guess Patch4
Comment 4 Aram Agajanian 2009-07-24 14:40:01 EDT
Your guess is correct.  I rebuilt the 141-4 RPMs with Patch4 commented out, installed them, and rebooted.  Then, the CD Audio disk was recognized.
Comment 5 Tim Dewhirst 2009-08-01 05:11:52 EDT
Do the above comments indicate the problem has been solved and if so when is the fix likely to ripple through to updates? Is there an interim solution/workaround to the problem?
Comment 6 Alex Lancaster 2009-08-03 04:39:12 EDT
I suspect this is the cause of many of the folks on bug #507446.  Since this has been known for a while (at least a week) can we please have a new build with patch4 backed out at least in updates-testing?  This is hitting a lot of people.
Comment 7 Alex Lancaster 2009-08-03 05:25:32 EDT
I can also confirm that rolling back to 141-3 cause CD audio discs to be recognised in rhythmbox and an icon appears on the desktop.
Comment 8 Harald Hoyer 2009-08-04 05:39:34 EDT
Can you please test, if this fixes your problems?

http://koji.fedoraproject.org/koji/buildinfo?buildID=125573
Comment 9 Harald Hoyer 2009-08-04 10:58:15 EDT
Also available here:
http://kojipkgs.fedoraproject.org/packages/udev/141/6.fc11/
Comment 10 Aram Agajanian 2009-08-04 11:36:19 EDT
My CD Audio disk is not recognized when using 141-6.  Going back to 141-4 with Patch4 commented out works.

I also noticed that Rhythmbox is no longer able to play my CD with udev version 141-4 with Patch4 commented out.  Totem works and so does hovering the mouse button over the track icon.  I don't know why this worked before but doesn't work now.
Comment 11 Aram Agajanian 2009-08-15 19:31:26 EDT
I can get Rhythmbox to play CDs with 141-4 minus patch 4 when I revert to rhythmbox version 0.12.1-2.  The latest release of rhythmbox, 0.12.3-1.fc11, doesn't play CDs with this udev.
Comment 12 Zsombor Nemestóthy 2009-08-17 08:42:50 EDT
I tried the udev-141-6.fc11.i586.rpm but it didn't solve the problem for me. The kernel messages remained the same.
Comment 13 Alex Hudson (Fedora Address) 2009-08-18 07:21:31 EDT
I have this problem as well. The patch 4 thing seems to be bogus to me, although maybe that's because it has been renumbered at some point!

The problem for me appears to be the loss of ID_CDROM_MEDIA_STATE due to udev.git-d3c8231e738dd286591c1becc2f327ed55ed89d1.patch :

[from a broken udev 6 with all the patches applied]

/lib/udev/cdrom_id -d /dev/sr0
main: probing: '/dev/sr0'
cd_inquiry: INQUIRY: [TSSTcorp][CDDVDW SH-S223F ][SB02]
cd_profiles: GET CONFIGURATION: number of profiles 368
cd_profiles: profile 0x15
cd_profiles: profile 0x16
cd_profiles: profile 0x17
cd_profiles: profile 0x2b
cd_profiles: profile 0x1b
cd_profiles: profile 0x1a
cd_profiles: profile 0x14
cd_profiles: profile 0x13
cd_profiles: profile 0x12
cd_profiles: profile 0x11
cd_profiles: profile 0x10
cd_profiles: profile 0x0a
cd_profiles: current profile 0x08
cd_media_toc: READ TOC: len: 100
cd_media_toc: track=1 info=0x0(audio) start_block=0
cd_media_toc: track=2 info=0x0(audio) start_block=13527
cd_media_toc: track=3 info=0x0(audio) start_block=31492
cd_media_toc: track=4 info=0x0(audio) start_block=44002
cd_media_toc: track=5 info=0x0(audio) start_block=59102
cd_media_toc: track=6 info=0x0(audio) start_block=81645
cd_media_toc: track=7 info=0x0(audio) start_block=97297
cd_media_toc: track=8 info=0x0(audio) start_block=110447
cd_media_toc: track=9 info=0x0(audio) start_block=120607
cd_media_toc: track=10 info=0x0(audio) start_block=133270
cd_media_toc: track=11 info=0x0(audio) start_block=152857
cd_media_toc: last track 1 starts at block 0
cd_media_info: disk type 00
ID_CDROM=1
ID_CDROM_CD_R=1
ID_CDROM_CD_RW=1
ID_CDROM_DVD=1
ID_CDROM_DVD_R=1
ID_CDROM_DVD_RW=1
ID_CDROM_DVD_RAM=1
ID_CDROM_DVD_PLUS_R=1
ID_CDROM_DVD_PLUS_RW=1
ID_CDROM_DVD_PLUS_R_DL=1
ID_CDROM_MRW=1
ID_CDROM_MRW_W=1
ID_CDROM_MEDIA=1
ID_CDROM_MEDIA_CD=1
ID_CDROM_MEDIA_SESSION_COUNT=1
ID_CDROM_MEDIA_TRACK_COUNT=11
ID_CDROM_MEDIA_TRACK_COUNT_AUDIO=11

With a working udev (patch mentioned above removed), I get exactly the same except I also get ID_CDROM_MEDIA_STATE=complete.

I'm not sure why that state is relied upon to let me access the device, but having had a brief look at the patch and the explanation it looks wrong to me. The additional test is for ID_CDROM_MEDIA_CD=0, but the examples given in the patch both have that set to 1. 

So, potentially, there are two bugs here (for me) - first, is STATE=complete really needed, or can the udev rules be changed to allow that to be missed out?

Second, is that patch actually doing what it says on the tin? For me, the test ought to be "if the device is writable, then look for the media state"...
Comment 14 qualimax 2009-08-31 07:00:05 EDT
Created attachment 359250 [details]
playing audio CD's

FC11: The only and easiest way of playing audio CD's in my case is using xine.
Comment 15 Jonathan Steffan 2009-09-08 16:13:56 EDT
Updated all components from https://koji.fedoraproject.org/koji/buildinfo?buildID=99462 and did not fix the issue for me. 2.6.30.5-43.fc11.x86_64
Comment 16 Scott Glaser 2009-09-09 10:10:43 EDT
*** Bug 507446 has been marked as a duplicate of this bug. ***
Comment 17 Dirk Schlüter 2009-09-10 16:21:14 EDT
I've the same problem. Not able to play any audio cd. 

/var/log/messages:

Sep 10 22:05:30 crow kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Sep 10 22:05:30 crow kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Sep 10 22:05:30 crow kernel: Info fld=0x0, ILI
Sep 10 22:05:30 crow kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Sep 10 22:05:30 crow kernel: end_request: I/O error, dev sr0, sector 0
Sep 10 22:05:30 crow kernel: Buffer I/O error on device sr0, logical block 0
Sep 10 22:05:30 crow kernel: Buffer I/O error on device sr0, logical block 1
Sep 10 22:05:30 crow kernel: Buffer I/O error on device sr0, logical block 2
Sep 10 22:05:30 crow kernel: Buffer I/O error on device sr0, logical block 3
Sep 10 22:05:30 crow kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Sep 10 22:05:30 crow kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Sep 10 22:05:30 crow kernel: Info fld=0x0, ILI
Sep 10 22:05:30 crow kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Sep 10 22:05:30 crow kernel: end_request: I/O error, dev sr0, sector 0
Sep 10 22:05:30 crow kernel: Buffer I/O error on device sr0, logical block 0
Sep 10 22:05:35 crow kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Sep 10 22:05:35 crow kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Sep 10 22:05:35 crow kernel: Info fld=0x0, ILI
Sep 10 22:05:35 crow kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Sep 10 22:05:35 crow kernel: end_request: I/O error, dev sr0, sector 0
Sep 10 22:05:35 crow kernel: Buffer I/O error on device sr0, logical block 0
Sep 10 22:05:35 crow kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Sep 10 22:05:35 crow kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Sep 10 22:05:35 crow kernel: Info fld=0x0, ILI
Sep 10 22:05:35 crow kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Sep 10 22:05:35 crow kernel: end_request: I/O error, dev sr0, sector 0
Sep 10 22:05:35 crow kernel: Buffer I/O error on device sr0, logical block 0
Comment 18 Nathan G. Grennan 2009-09-18 20:42:42 EDT
I found it is patch6 of udev-141-7, also known as udev.git-d3c8231e738dd286591c1becc2f327ed55ed89d1.patch. If I disable this patch, compile the package, and install it, then audio cds work again.
Comment 19 Nathan G. Grennan 2009-09-18 20:50:09 EDT
Note, that even with udev-141-3 that shipped with Fedora 11 and works, you at least can get dmesg errors from audio cds.
Comment 20 Alex Lancaster 2009-09-21 18:16:57 EDT
(In reply to comment #18)
> I found it is patch6 of udev-141-7, also known as
> udev.git-d3c8231e738dd286591c1becc2f327ed55ed89d1.patch. If I disable this
> patch, compile the package, and install it, then audio cds work again.  

Do you happen know what the intent of that patch was and has the fact that it broke audio CDs been reported upstream?
Comment 21 James_A 2009-09-22 00:31:10 EDT
Two months gone and still no fix?

Between udev, gvfs (see bug #500341) and nautilus (see bug #523749) F11 has not been able to mount and play Audio CDs for most of its life.

gvfs >= 1.2.3-7 && nautilus = 2.26.3-3 (currently in testing) && udev <= 141-3 is the only combination that works for me.
Comment 22 Steven Drinnan 2009-09-22 01:32:16 EDT
Any progress?
Comment 23 Alex Hudson (Fedora Address) 2009-09-22 03:06:29 EDT
If it is the -89d1 patch, I already analysed it in #13: the loss of the state output causes the audio to not work in my case.

I still don't think the patch makes sense either: at the very least, the comments within the patch do not reconcile with what the code does.
Comment 24 Andre Costa 2009-09-22 09:15:40 EDT
(In reply to comment #21)
> Two months gone and still no fix?
> 
> Between udev, gvfs (see bug #500341) and nautilus (see bug #523749) F11 has not
> been able to mount and play Audio CDs for most of its life.
> 
> gvfs >= 1.2.3-7 && nautilus = 2.26.3-3 (currently in testing) && udev <= 141-3
> is the only combination that works for me.  

Agreed. Additionally to the ones you mentioned there's also no sound on headphones (bug #500418), rhythmbox going mute randomly etc.

It's almost as if F11 was meant to be seen but not heard :-( I guess we'll just have to hope F12 will be better as far as sound goes.
Comment 25 Alex Lancaster 2009-09-22 14:10:04 EDT
Harald: ping?   We haven't heard from you, the maintainer, since 2009-08-04 and this is a very serious bug that is affecting a lot of people (note the number of people Cc'ed).  

If we don't hear from you soon, I will ask on #fedora-devel about getting in a co-maintainer or provenpackager to rebuild udev without the troublesome patch and push a new version to at least updates-testing, or I will do it myself.
Comment 26 Harald Hoyer 2009-09-23 14:02:32 EDT
pong, I should have more time now to fix that problem.
Comment 27 Andre Costa 2009-09-23 17:52:50 EDT
Nice to hear that, thks =)
Comment 28 Harald Hoyer 2009-09-25 13:33:28 EDT
Does this patch for /lib/udev/rules.d/95-devkit-disks.rules help?

http://cgit.freedesktop.org/DeviceKit/DeviceKit-disks/commit/?id=97d71294bdb15eda4ff6624b80601cd847953e46

@@ -16,7 +16,7 @@ KERNEL=="hd*[!0-9]", ATTR{removable}=="1", SUBSYSTEMS=="ide", ATTRS{media}=="dis
KERNEL=="hd*[0-9]", ATTRS{removable}=="1", GOTO="probe_parttable_end"
# don't scan for partition tables on empty discs
-KERNEL=="sr*", ENV{ID_CDROM_MEDIA_TRACK_COUNT}!="?*", GOTO="probe_parttable_end"
+KERNEL=="sr*", ENV{ID_CDROM_MEDIA}!="?*", GOTO="probe_parttable_end"
# scan for partition tables both on whole-disk and partitions
#
Comment 29 Aram Agajanian 2009-09-25 18:05:31 EDT
I tested loading an Audio CD with the patched file and both udev-141-4 and udev-141-7.  In both cases, the drive icon disappears just as it did without the patch.

I wasn't able to use the patch command with the text below the URL in Comment #28.  So, I carefully updated line 16 of /lib/udev/rules.d/95-devkit-disks.rules with a text editor.
Comment 30 Mike C 2009-10-09 03:21:48 EDT
One additional point - I have just installed a new f11 system and updated it - I inserted a blank CD (in order to burn an iso) and found I am getting very similar kernel messages in the log:

Oct  8 18:50:14 home1 kernel: cdrom: This disc doesn't have any tracks I recognize!
Oct  8 18:50:14 home1 kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct  8 18:50:14 home1 kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct  8 18:50:14 home1 kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct  8 18:50:14 home1 kernel: end_request: I/O error, dev sr0, sector 0
Oct  8 18:50:14 home1 kernel: Buffer I/O error on device sr0, logical block 0
Oct  8 18:50:14 home1 kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct  8 18:50:14 home1 kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct  8 18:50:14 home1 kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct  8 18:50:14 home1 kernel: end_request: I/O error, dev sr0, sector 0
Oct  8 18:50:14 home1 kernel: Buffer I/O error on device sr0, logical block 0

My logwatch output flagged this up:
--------------------- Kernel Begin ------------------------ 

 WARNING:  Kernel Errors Present
    Buffer I/O error on device sr0, l ...:  2 Time(s)
    end_request: I/O error, dev sr0, sector ...:  2 Time(s)
 
 ---------------------- Kernel End ------------------------- 

So I guess that this is ongoing.

I did not see others reporting whether there was also a problem inserting a blank CD or DVD but it is likely the same problem as with audio CD?
Comment 31 Paul 2009-10-09 09:57:11 EDT
From a simple user point of view, I can open a view of /media and see the icons for the two drives I have on my machine. Insert the audio disk into either and I get to watch the respective drive's icon vanish. Remove the CD and the icon pops back on. Kinda a "now you see me, now you don't" game.

I also note that it doesn't pick up the floppy drive, which my F9 system does.

Last updated 04oct09, 2.6.30.8-64.fc11.i686.PAE, don't have the relevant other packages version info handy.

I am a bit surprised (mild understatement) that I still can't play an audio CD after how many months F11 has been out. It doesn't stop me from doing what I need to do on the machine, but it doesn't make sense that its taking this long to resolve.
Comment 32 rg_linux1 2009-10-09 10:20:47 EDT
(In reply to comment #31)
> From a simple user point of view, I can open a view of /media and see the icons
> for the two drives I have on my machine. Insert the audio disk into either and
> I get to watch the respective drive's icon vanish. Remove the CD and the icon
> pops back on. Kinda a "now you see me, now you don't" game.
> 
> I also note that it doesn't pick up the floppy drive, which my F9 system does.
> 
> Last updated 04oct09, 2.6.30.8-64.fc11.i686.PAE, don't have the relevant other
> packages version info handy.
> 
> I am a bit surprised (mild understatement) that I still can't play an audio CD
> after how many months F11 has been out. It doesn't stop me from doing what I
> need to do on the machine, but it doesn't make sense that its taking this long
> to resolve.  

I more than agree. Having access to peripherals is essential when using any PC. Downgrading software may be an option but by moving say from F9 to F11 or F10 to F11, the basic expectation is that basic functionality would have been checked prior releasing F11.

rg_linux1
Comment 33 Harald Hoyer 2009-10-09 11:06:32 EDT
Created attachment 364257 [details]
specfile patch
Comment 34 Harald Hoyer 2009-10-09 11:07:33 EDT
Created attachment 364258 [details]
patch to fix audio CDs

Ok, here is the fix for DeviceKit-disks to let audio CDs reappear on the desktop
Comment 35 Aram Agajanian 2009-10-09 12:03:59 EDT
This patch is working well here, so far.
Comment 36 Dennis 2009-10-09 15:54:39 EDT
Thanks for the work Harold.
Lots of people will be (silently) grateful for this.

Care to mention the general nature of the bug / what was fixed?
Comment 37 Paul 2009-10-10 00:15:01 EDT
I took a look at the attachment ... but what I want to know is when will it be committed so it gets picked up in a "yum update"

I agree with Dennis's post that I would like to know more about what the heck this bug was.

But I need to push it a bit further. This bug was opened by (date included) Aram Agajanian (agajania@cs.newpaltz.edu)  2009-07-23 17:51:26 EDT. It is now 09oct09. From what I can tell, very shortly after my post and rg_linux1@yahoo.ca comment, it was assigned and fixed rather quickly ... say one day to be generous.

Why did it take so long for such an apparently quick fix?

Something is just plain wrong here, it should have been resolved a long time ago.

That being said, thanks for the fix, though I only care about it when it is released via yum (I am not savvy enough to play around with patches and can therefore only care about the general release).

Thanks,
Paul
Comment 38 Alex Lancaster 2009-10-10 00:52:43 EDT
(In reply to comment #37)
> I took a look at the attachment ... but what I want to know is when will it be
> committed so it gets picked up in a "yum update"

It will probably be pushed to updates-testing initially, to make sure it works and doesn't cause even more breakage.  That's easily installed by using (assuming the fix is in the DeviceKit-disk package):

yum --enablerepo=updates-testing install DeviceKit-disks

Regarding the delay, I believe it was that the maintainer, Harald Hoyer, only had a chance to look at it again in the last week or so.  Although, I agree that the bug has remained open for so long for basically functionality is not good. 

Part of the problem is that these packages such as udev/hal and the various *-Kits are fairly core (sic) plumbing/infrastructure packages and are generally (still) maintained by Red Hat employees (but not always!) who are fairly busy people and can probably only work on Fedora for some subset of their company time.  I would volunteer to co-maintain but I wouldn't feel comfortable modifying these packages not having the relevant expertise in how udev etc. works under the hood.  

Ideally there would be more community members with the relevant expertise available to work on these kind of core packages, but as they are (mostly) dealt with in a speedy manner by the RH folks, there isn't as much incentive from the community end of things.  Just my $0.02.
Comment 39 Harald Hoyer 2009-10-10 03:05:12 EDT
Yes, I was busy and lazy, and I am sorry that.. :-(
Comment 40 Mike C 2009-10-10 05:55:23 EDT
Well it is good to see the fix - thank you Harald. Looking forward to testing this from Bodhi or updates-testing...
Comment 41 Paul 2009-10-10 10:38:24 EDT
Harald:

Thank you for the reply, I appreciate.

The important thing is that you have fixed it (big thank you for that) and I look forward to its making its way through testing and into the general release.

Paul
Comment 42 Aram Agajanian 2009-10-10 13:48:25 EDT
After posting Comment #35, I did encounter a problem yesterday.  When I tried to open the CD Audio entry in the Places menu, there was a small pop-up which had an error message regarding /dev/sr1.  Ejecting and reinserting the disk into the drive seemed to reset things so that the CD Audio disk was recognized.  I didn't have time to test further, however.

Today, I am unable to reproduce the problem.  However, I am testing with a different computer with one DVD drive.  The computer that I was using yesterday has two DVD drives.  I'll test the PC with two drives again until Monday.
Comment 43 Aram Agajanian 2009-10-13 19:46:21 EDT
I tested loading CD audio disks a bit yesterday and today.  I did encounter problems a couple of times but I am not able to reproduce them now.  Overall, the patch seems to be working well.
Comment 44 Jerry James 2009-10-14 13:03:45 EDT
The patch only sort of fixed things for me.  Now when I insert an audio disk, GNOME pops up its dialog asking me to choose an application.  However, when I choose grip, grip says "No Disc".  I looked in dmesg, and I still see this:

sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 2:0:0:0: [sr0] Sense Key : Illegal Request [current] 
sr 2:0:0:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
Buffer I/O error on device sr0, logical block 4
Buffer I/O error on device sr0, logical block 5
Buffer I/O error on device sr0, logical block 6
Buffer I/O error on device sr0, logical block 7
sr 2:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 2:0:0:0: [sr0] Sense Key : Illegal Request [current] 
sr 2:0:0:0: [sr0] Add. Sense: Illegal mode for this track
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0

... followed by lots of repetitions of the next-to-last 4 lines.

On the other hand, sound-juicer now works.  Any ideas why grip doesn't see the CD?
Comment 45 Jerry James 2009-10-14 13:39:36 EDT
An strace of grip shows the last 2 lines of this block repeatedly in the output:

open("/dev/sr0", O_RDONLY|O_NONBLOCK)   = 15
ioctl(15, CDROM_DRIVE_STATUS, 0x7fffffff) = 4
ioctl(15, CDROMSUBCHNL, 0x7fff714f0210) = 0

The return statuses are okay.  Using gdb, I see these values in the cdrom_subchnl struct filled in by the second ioctl:

cdsc_format = 2
cdsc_audiostatus = 10
cdsc_adr = 0
cdsc_ctrl = 0
cdsc_trk = 1
cdsc_ind = 1
cdsc_absaddr = msf = { minute = 0, second = 2, frame = 1 }
cdsc_reladdr = msf = { minute = 0, second = 0, frame = 1 }
};

The value of cdsc_audiostatus is supposed to be between 17 and 21 when a CDROM is present in the drive.  I have this happening on two different models of drives, one in my home computer and one in my work computer.
Comment 46 peter 2009-10-14 14:29:50 EDT
When I insert an audiodisc kscd pops up but dosn't start to play. The playlist is empty, files can not be selected. If I type kscd into Konsole:
[perdelyi@localhost ~]$ kscd
CDROMREADTOCHDR: Kein Medium gefunden
Query failed: Cannot read table of contents.
This CD was not found.
[perdelyi@localhost ~]$ CDROMREADTOCHDR: Kein Medium gefunden
Also other applications are not able play audiocds. Xine, Kaffeine, Mplayer...
Dolpine doesn't open the content of the cd.
Possibly false symlinks at /etc/cdrom?
DVDs work fine, there is no trouble.

I'm using:
Linux version 2.6.30.8-64.fc11.x86_64 (mockbuild@x86-5.fedora.phx.redhat.com) (gcc version 4.4.1 20090725 (Red Hat 4.4.1-2) (GCC) ) #1 SMP Fri Sep 25 04:43:32 EDT 2009
4.3.1 (KDE 4.3.1)
GeForce 7300 GS/PCI/SSE2
2.1.2 NVIDIA 185.18.36
DeviceKit-disks-004-4.fc11.x86_64 is already installed.
Comment 47 peter 2009-10-15 12:12:13 EDT
Today the new kde packages 4.3.2 were coming so I did update my system but the result is the same. Audiocds can not be played.
Comment 48 Andre Costa 2009-10-15 21:23:02 EDT
Same here. Just updated to udev-141-7 and inserting an audio CD results in such messages on /var/log/messages:

Oct 15 22:18:54 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 15 22:18:54 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 15 22:18:54 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 15 22:18:54 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 0
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 1
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 2
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 3
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 4
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 5
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 6
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 7
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 8
Oct 15 22:18:54 localhost kernel: Buffer I/O error on device sr0, logical block 9
Oct 15 22:18:54 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 15 22:18:54 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 15 22:18:54 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 15 22:18:54 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 15 22:18:56 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 15 22:18:56 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 15 22:18:56 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 15 22:18:56 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 15 22:18:56 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 15 22:18:56 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 15 22:18:56 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 15 22:18:56 localhost kernel: end_request: I/O error, dev sr0, sector 0
Comment 49 Harald Hoyer 2009-10-16 03:53:52 EDT
Hold on guys.. There was no bugfix released, yet. Wait for the DeviceKit update or create the package yourself with my attachements or download the prebuilt rpms:

http://harald.fedorapeople.org/downloads/DeviceKit-disks/

i586:
http://harald.fedorapeople.org/downloads/DeviceKit-disks/i586/DeviceKit-disks-004-4.1.hh.1.fc11.i586.rpm

x86_64:
http://harald.fedorapeople.org/downloads/DeviceKit-disks/x86_64/DeviceKit-disks-004-4.1.hh.1.fc11.x86_64.rpm
Comment 50 Alex Lancaster 2009-10-16 17:45:28 EDT
(In reply to comment #49)
> Hold on guys.. There was no bugfix released, yet. Wait for the DeviceKit update
> or create the package yourself with my attachements or download the prebuilt
> rpms:

Hi Harald,

Since the maintainer of DeviceKit-disks has not (yet) chimed on this update since you switched it 5 days ago, but this is clearly a major long-standing bug in a production release, could you possibly roll the update yourself and push it to at least updates-testing if the maintainer does not respond in a timely fashion.  This is a good reason that this package should probably have some co-maintainers with similar expertise to yourself.

If not, I could do so, as I am a provenpackager, but I would want to have the go-ahead from somebody with more knowledge such as yourself.  Also pushing to updates-testing would at least get more feedback before we let it loose on stable F-11.
Comment 51 Paul 2009-10-16 23:29:53 EDT
Harald:

I realize I am showing a weak hand and therefore don't really have a right to make a suggestion (as in I am not comfortable enough with my own skills to download pre-release material), but I have to agree with Alex's comment that this bug needs to get resolved and therefore needs more testing exposure sooner rather than later. Someone needs to get it into updates-testing now so it can be verified whether the couple of potential problems mentioned are real or not.

Given what I have read in the posts after you announced a fix certainly show that it is better than what is currently in the F11 release package ... that in and of itself says its worth being aggressive on getting it broader testing.

Thanks,
Paul
Comment 52 Dirk Götz 2009-10-17 02:08:39 EDT
Hello,

I downloaded and installed Haralds prebuild package, now Audio CD Icon appears, Rhythmnbox is playing the Audio CD, Sound Juicer is recognizing, also Brasero does. Totem is seeing the mounted CD, but playing it is greyed out, I am not sure if this is normal, because I dont use it, but I remember it always appeared as default player. I would also vote for pushing it to update-testing as soon as possible.

Thanks for the fix,
 Dirk
Comment 53 Harald Hoyer 2009-10-19 03:22:01 EDT
I am not a provenpackager :-) so I can't build it. Talked to David on IRC, the day I posted the patches, and he said, he wants to get another fix also in the next DeviceKit-disks update, so I think he will prepare an update in the near future.
But a build into updates-testing by a provenpackager will not hurt anybody...
Comment 54 Randell Jesup 2009-10-19 11:24:29 EDT
Here's a question: why in the world is this very-visible user-level bug marked "low" priority?  I'd imagine bugs with "low" don't tend to show up on the maintainers radar, or the radar of whomever is managing the project (if anyone is....)
Comment 55 Paul W. Frields 2009-10-19 18:14:23 EDT
I don't believe the priority marking on the bug necessarily reflects the developers' priorities.  The log shows me developers are on the case and working on the problem, and I think I saw a rebuilt DeviceKit-disks in the release engineering hopper for tagging.
Comment 56 Alex Lancaster 2009-10-19 18:25:42 EDT
My scratch build worked:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1755623

and I downloaded the resultant package, installed it and rebooted (this seemed to be necessary to get DeviceKit reloaded) and now CDs show up on the desktop and in rhythmbox and can be played.

I therefore just committed Harald's patch and will send this to updates-testing ASAP as per comment #53.  If the official maintainer sends an additional new update in the meantime it will obsolete this update, so no harm done.

(In reply to comment #55)
> I don't believe the priority marking on the bug necessarily reflects the
> developers' priorities.  

Indeed, I think that "low" is the default priority and in my experience not really used by most Fedora developers.

> The log shows me developers are on the case and
> working on the problem, and I think I saw a rebuilt DeviceKit-disks in the
> release engineering hopper for tagging.  

I think that's probably for F-12, this bug is affecting F-11 and that hasn't been updated (until I did just now).
Comment 57 Fedora Update System 2009-10-19 18:28:36 EDT
DeviceKit-disks-004-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/DeviceKit-disks-004-5.fc11
Comment 58 Fedora Update System 2009-10-20 20:58:01 EDT
DeviceKit-disks-004-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update DeviceKit-disks'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10713
Comment 59 Andre Costa 2009-10-21 08:44:15 EDT
I just installed DeviceKit-disks-004-5 from updates-testing. Audio CDs are properly handled again, nice job. Still, these messages appear on system logs when I insert an audio CD:

ct 21 10:26:42 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:26:42 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:26:42 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:26:42 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 10:26:42 localhost kernel: __ratelimit: 25 callbacks suppressed
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 0
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 1
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 2
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 3
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 4
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 5
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 6
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 7
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 8
Oct 21 10:26:42 localhost kernel: Buffer I/O error on device sr0, logical block 9
Oct 21 10:26:42 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:26:42 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:26:42 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:26:42 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 10:26:44 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:26:44 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:26:44 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:26:44 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 10:26:44 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:26:44 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:26:44 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:26:44 localhost kernel: end_request: I/O error, dev sr0, sector 0

Also, whe I tried to rip some tracks from an audio cd, these appeared on the logs:

Oct 21 10:31:17 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:31:17 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:31:17 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:31:17 localhost kernel: end_request: I/O error, dev sr0, sector 144
Oct 21 10:31:17 localhost kernel: __ratelimit: 25 callbacks suppressed
Oct 21 10:31:17 localhost kernel: Buffer I/O error on device sr0, logical block 18
Oct 21 10:31:17 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:31:17 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:31:17 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:31:17 localhost kernel: end_request: I/O error, dev sr0, sector 144
Oct 21 10:31:17 localhost kernel: Buffer I/O error on device sr0, logical block 18
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:31:18 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 10:31:18 localhost kernel: Buffer I/O error on device sr0, logical block 0
Oct 21 10:31:18 localhost kernel: Buffer I/O error on device sr0, logical block 1
Oct 21 10:31:18 localhost kernel: Buffer I/O error on device sr0, logical block 2
Oct 21 10:31:18 localhost kernel: Buffer I/O error on device sr0, logical block 3
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:31:18 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 10:31:18 localhost kernel: Buffer I/O error on device sr0, logical block 0
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 10:31:18 localhost kernel: sr 6:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 10:31:18 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 10:31:18 localhost kernel: Buffer I/O error on device sr0, logical block 0

Despite those, CD icon appeared on the desktop, and audio playing (rhythmbox) and ripping (sound juicer) worked.
Comment 60 Nik Lam 2009-10-21 09:11:39 EDT
No luck with DeviceKit-disks-004-5.fc11 here I'm afraid.

I get repetitions of the following in /var/log/messages as the drive keeps trying to spin the audio CD up. I also get a gnome pop-up error which I will attach.

Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 23:59:22 localhost kernel: Info fld=0x0
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 23:59:22 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 23:59:22 localhost kernel: __ratelimit: 4 callbacks suppressed
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 0
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 1
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 2
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 3
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 4
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 5
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 6
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 7
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 23:59:22 localhost kernel: Info fld=0x0
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 23:59:22 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 0
Oct 21 23:59:22 localhost kernel: Buffer I/O error on device sr0, logical block 1
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 23:59:22 localhost kernel: Info fld=0x0
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 23:59:22 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Sense Key : Illegal Request [current] 
Oct 21 23:59:22 localhost kernel: Info fld=0x0
Oct 21 23:59:22 localhost kernel: sr 1:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 21 23:59:22 localhost kernel: end_request: I/O error, dev sr0, sector 0
Oct 21 23:59:22 localhost kernel: ata2.00: exception Emask 0x12 SAct 0x0 SErr 0x400 action 0x6 frozen
Oct 21 23:59:22 localhost kernel: ata2.00: irq_stat 0x08000000, interface fatal error
Oct 21 23:59:22 localhost kernel: ata2: SError: { Proto }
Oct 21 23:59:22 localhost kernel: ata2.00: cmd a0/00:00:00:02:00/00:00:00:00:00/a0 tag 0 pio 16388 in
Oct 21 23:59:22 localhost kernel:         cdb 43 02 05 00 00 00 00 00  02 00 00 00 00 00 00 00
Oct 21 23:59:22 localhost kernel:         res 50/00:03:00:04:00/00:00:00:00:00/a0 Emask 0x12 (ATA bus error)
Oct 21 23:59:22 localhost kernel: ata2.00: status: { DRDY }
Oct 21 23:59:22 localhost kernel: ata2: hard resetting link
Oct 21 23:59:23 localhost kernel: ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
Oct 21 23:59:23 localhost kernel: ata2.00: configured for UDMA/33
Oct 21 23:59:23 localhost kernel: ata2: EH complete
Comment 61 Nik Lam 2009-10-21 09:15:18 EDT
Created attachment 365504 [details]
Unable to mount Audio Disc - repeated popup error

This error repeats itself as the drive continuously spins up then slows down. I had to manually eject the audio CD to prevent my screen from filling up with the errors.
Comment 62 Zsombor Nemestóthy 2009-10-21 09:47:36 EDT
I installed DeviceKit-disks-004-5.fc11 from updates-testing, but the problem still persist. No changes in kernel messages, and cd ripping (sound juicer) does not work (error message: Could not read the CD).
Comment 63 Andre Costa 2009-10-21 11:10:44 EDT
(In reply to comment #62)
> I installed DeviceKit-disks-004-5.fc11 from updates-testing, but the problem
> still persist. No changes in kernel messages, and cd ripping (sound juicer)
> does not work (error message: Could not read the CD).  

Hi Zsombor,

just to make sure: did you reboot after upgrading DeviceKit-disks? You need to reboot for the upgrade to be effective.
Comment 64 Steven Drinnan 2009-10-22 03:57:00 EDT
For me all working - after restart
Comment 65 Zsombor Nemestóthy 2009-10-22 05:37:57 EDT
(In reply to comment #63)
> (In reply to comment #62)
> > I installed DeviceKit-disks-004-5.fc11 from updates-testing, but the problem
> > still persist. No changes in kernel messages, and cd ripping (sound juicer)
> > does not work (error message: Could not read the CD).  
> 
> Hi Zsombor,
> 
> just to make sure: did you reboot after upgrading DeviceKit-disks? You need to
> reboot for the upgrade to be effective.  

Hi!

Yes. I installed with "yum --enablerepo=updates-testing update DeviceKit-disks" then rebooted. My system is up to date, using kde.
Tested further: As I put in the cd the got the following messages:

Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 22 10:54:24 zsombi kernel: end_request: I/O error, dev sr0, sector 0
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 0
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 1
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 2
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 3
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 4
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 5
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 6
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 7
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 22 10:54:24 zsombi kernel: end_request: I/O error, dev sr0, sector 0
Oct 22 10:54:24 zsombi kernel: Buffer I/O error on device sr0, logical block 0
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 22 10:54:24 zsombi kernel: end_request: I/O error, dev sr0, sector 0
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 22 10:54:24 zsombi kernel: end_request: I/O error, dev sr0, sector 0
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
Oct 22 10:54:24 zsombi kernel: sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
Oct 22 10:54:24 zsombi kernel: end_request: I/O error, dev sr0, sector 0

I can play the audio cd with KsCd, Gnome mplayer, Kaffeine, Rhythmbox and Vlc without problem. So it's obviously better than was.
As I tested with a few audio CD, I found an interesing thing: Sound Juicer can rip some but can't the others. It depends on the CD but i can not find out any logic in it.
If it fails on a cd, it says: 
"Could not read the CD. Sound Juicer could not read the track listing on this CD. Reason: Cannot access CD: The specified location is not mounted."
And it will fail always with that CD. If it works with a cd it will always work.

So apart from the kernel messages and the Sound Juicer: it works. Maybe Sound Juicer error related to another bug? I don't know but in F10 I ripped many CD without error.
Comment 66 Andre Costa 2009-10-22 07:14:44 EDT
Yes, I get those kernel error messages, too. Even though it's working, something still seems to be wrong, hope someone digs deeper into it.

Juts a wild guess: maybe some of your cds are copy-protected? (that stupid protection scheme that makes audio cds unreadable on cd-roms). Unless, of course, you were able to rip those very same cds on F10...
Comment 67 Jerry James 2009-10-22 10:55:11 EDT
See comment 44 and comment 45.  I am interested to know if anyone else is seeing the CDROMSUBCHNL ioctl return an audiostatus of 10.  That seems to be the source of the problems I am observing, such as grip not working.
Comment 68 Nicola Soranzo 2009-10-26 05:13:28 EDT
*** Bug 526229 has been marked as a duplicate of this bug. ***
Comment 69 Nicola Soranzo 2009-10-26 05:31:03 EDT
*** Bug 458036 has been marked as a duplicate of this bug. ***
Comment 70 peter 2009-10-26 13:56:45 EDT
Sorry for the long delay. I have installed DeviceKit-disks-004-5.fc11 yesterday but the problem still persist. kscd can't launch any cd (as I posted before) and amarok displays following message: can not be read.
Comment 71 Fedora Update System 2009-10-27 02:59:27 EDT
DeviceKit-disks-004-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 72 Alex Lancaster 2009-10-27 06:18:02 EDT
(In reply to comment #70)
> Sorry for the long delay. I have installed DeviceKit-disks-004-5.fc11 yesterday
> but the problem still persist. kscd can't launch any cd (as I posted before)
> and amarok displays following message: can not be read.  

Did you reboot your system?
Comment 73 Alex Lancaster 2009-10-27 06:26:44 EDT
Also, since this fixed the problem for most people, for those remaining problems such as with grip and/or with the error messages in /var/log/messages, new bug(s) should probably be opened and this bug should remain closed.

This bug is already getting too long as it is.

I get the error messages in the log as well, I'll try to followup on comment #67 to see if I get the same ioctl return status.  Can somebody open a new report about that once it is determined which component is responsible?
Comment 74 peter 2009-10-27 13:19:41 EDT
@Alex Lancaster: Yes I did reboot my system. No change.
Comment 75 peter 2009-10-27 15:41:15 EDT
Correction. At the beginning of my note I had two dvd writer. I detected that one of them was out of order. I have not used it for a long time. I removed it. At first fc11 and DeviceKit-disks-004-5.fc11 didn't work but I made a link like this:
ln -s /dev/cdrom1 /dev/cdrom.
This link solves my problem. kscd works absolutely perfect.
Comment 76 Alex Lancaster 2009-11-07 22:20:15 EST
(In reply to comment #73)
> Also, since this fixed the problem for most people, for those remaining
> problems such as with grip and/or with the error messages in /var/log/messages,
> new bug(s) should probably be opened and this bug should remain closed.
> 
> This bug is already getting too long as it is.
> 
> I get the error messages in the log as well, I'll try to followup on comment
> #67 to see if I get the same ioctl return status.  Can somebody open a new
> report about that once it is determined which component is responsible?  

As this is still affecting me, I opened up a new bug #533643 .

Note You need to log in before you can comment on or make changes to this bug.