Bug 50746 - bounce command doesn't work in elm update 2.5.5-0.62 and 2.5.5-1
bounce command doesn't work in elm update 2.5.5-0.62 and 2.5.5-1
Status: CLOSED DUPLICATE of bug 49686
Product: Red Hat Linux
Classification: Retired
Component: elm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-08-02 15:43 EDT by Troy Barbee
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-02 15:45:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
patch to src/reply.c to fix this bug (1.43 KB, patch)
2001-08-02 15:45 EDT, Troy Barbee
no flags Details | Diff

  None (edit)
Description Troy Barbee 2001-08-02 15:43:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17 i686)

Description of problem:
After installing the 2.5.5-0.62 update under 6.2 or the 2.5.5-1 update
under 7.[01], the bounce command in elm appears to work (the "Mail resent"
message appears), but the mail is not sent.

How reproducible:

Steps to Reproduce:
1. Enter elm, choose a message
2. choose "b" to "bounce" the message
3. Enter an email address to send the message to
4. Confirm re-sending by hitting "y"	

Actual Results:  "Mail resent" is displayed at the bottom of the screen,
but no mail message is actually sent.

Expected Results:  The mail message should have been sent to the designated

Additional info:

The elm-2.5.5-tempnam.patch file in the SRPM appears to be defective. The
patch modifies the routine remail() in the file src/reply.c to make temp
file handling more secure, but fails to use the new filename variable
(called tempfilename) throughout the routine.  Since the original filename
variable is NULL, the sendmail command invoked by system_call(buffer,0)
can't find the file to send, so no message is sent.

A patch to src/reply.c to fix this problem is attached.

This problem also occurs in RH Linux 7.0 and 7.1, elm-2.5.5-1
Comment 1 Troy Barbee 2001-08-02 15:45:24 EDT
Created attachment 25974 [details]
patch to src/reply.c to fix this bug
Comment 2 Trond Eivind Glomsrxd 2001-08-02 16:44:40 EDT

*** This bug has been marked as a duplicate of 49686 ***

Note You need to log in before you can comment on or make changes to this bug.