Bug 49686 - New package breaks bouncing messages.
Summary: New package breaks bouncing messages.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: elm   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 50746 52473 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-23 09:57 UTC by Paul Raj Khangure
Modified: 2007-04-18 16:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 09:57:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Raj Khangure 2001-07-23 09:57:10 UTC
Description of Problem:

The new elm package elm-2.5.5-0.62 breaks the bouncing of messages via the
b command.

How Reproducible:

By attempting to bounce a message.

Steps to Reproduce:
1.  Open elm. 
2.  Bounce a message to a valid email address ( b , enter address , y )
3.  Note brief error before screen rewrites incorrectly.

Actual Results:

Screen rewrites incorrectly, over writing error message. 
Error message is:

Resending mail...sh: syntax error near unexpected token `(n'
sh: -c: line 1: `(/usr/sbin/sendmail -oi -oem -om "user@domainname.net"
<(null
);/bin/rm -f (null))&'

user@domainname.net is a valid email address.

The message is not bounced.

Expected Results:

The email should be bounced, and the screen redraw correctly.

Additional Information:
	
To get the actuall error message, I had to pipe the output to a file, so it
wouldn't be written over. I did:

elm > elmtrace 2>&1

Then hit b to bounce, entered the address, y to bounce, q to quit, n to not
move to received.

System is RedHat 6.2, new elm package, sendmail-8.9.3-20.
Has been reproduced on another 6.2 box running the same packages.

Worked before the update.

Comment 1 Trond Eivind Glomsrxd 2001-07-25 22:12:15 UTC
Should be fixed in elm-2.5.5-5



Comment 2 Gilbert E. Detillieux 2001-07-31 22:27:13 UTC
Can this fixed release be made available as updates for supported Red Hat Linux
versions (6.2, 7.1 at least)?

Given that the issued update packages are broken, the right thing to do would be
to reissue a corrected update, IMHO.

Comment 3 Trond Eivind Glomsrxd 2001-08-02 20:44:34 UTC
*** Bug 50746 has been marked as a duplicate of this bug. ***

Comment 4 Trond Eivind Glomsrxd 2001-08-24 02:22:04 UTC
*** Bug 52473 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.