Bug 507489 - Changed device URI not reflected in properties dialog
Changed device URI not reflected in properties dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
: 508086 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 20:15 EDT by Christoph Wickert
Modified: 2009-07-22 18:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.8-6.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 18:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2009-06-22 20:15:35 EDT
Description of problem:
The device URI of an installed printer cannot be changed.

Version-Release number of selected component (if applicable):
system-config-printer-1.1.7-4.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start s-c-p with at least one installed printer
2. Select it -> Properties -> Device URI -> Change...
3. Enter root password (causes SELinux denial, but this is not the problem since I'm in permissive mode)
4. Change the URI and hit Apply
  
Actual results:
s-c-p asks for root pw a second time (sucks) but nothing happens

Expected results:
Dialog should close and URI should get updated.
Comment 1 Christoph Wickert 2009-06-22 20:26:45 EDT
I just realized this is a crasher: As you hit the Apply button on the console appears:

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6536, in on_btnNPApply_clicked
    self.mainapp.cups.addPrinter(name, device=uri)
  File "/usr/share/system-config-printer/authconn.py", line 183, in <lambda>
    return lambda *args, **kwds: self._authloop (fname, fn, *args, **kwds)
  File "/usr/share/system-config-printer/authconn.py", line 198, in _authloop
    result = fn.__call__ (*args, **kwds)
  File "/usr/share/system-config-printer/cupspk.py", line 494, in addPrinter
    *args, **kwds)
  File "/usr/share/system-config-printer/cupspk.py", line 230, in _call_with_pk_and_fallback
    debugprint ('PolicyKit call to %s did not work: %s' %
NameError: global name 'debugprint' is not defined
Comment 2 Christoph Wickert 2009-06-22 20:35:47 EDT
Ok, forget about comment # 2. I updated to system-config-printer-1.1.8-1.fc11  from updates testing and the python traceback is gone. The Device URI dialog gets closed now, but the URI is not getting updated.

If I manually enter the new URI in the Properties dialog and hit apply an error message appears: "There was an error during the CUPS operation: 'client-error-not-possible'"
Comment 3 Tim Waugh 2009-06-23 05:30:26 EDT
Thanks for the report, and especially thanks for trying the test update.

After the dialog closes, the printer properties dialog is still showing the old device URI.  If you cancel that dialog and double-click on the printer again you should see the new URI; i.e. the printer properties dialog is not getting updated after the URI is changed.

I'm not seeing the other problem you mention (client-error-not-possible) -- would you mind opening a separate bug report for that?  Seems to need more investigation.
Comment 4 Tim Waugh 2009-06-23 07:29:31 EDT
Looks like this display issue was fixed by a change I made upstream yesterday.
Comment 5 Tim Waugh 2009-06-25 11:51:59 EDT
*** Bug 508086 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2009-06-30 17:23:24 EDT
system-config-printer-1.1.8-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6777
Comment 7 Fedora Update System 2009-07-11 13:10:14 EDT
system-config-printer-1.1.8-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-07-20 05:23:57 EDT
system-config-printer-1.1.8-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/system-config-printer-1.1.8-6.fc11
Comment 9 Fedora Update System 2009-07-22 18:06:14 EDT
system-config-printer-1.1.8-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.