Bug 50750 - plaympeg crashes with any (?) mpeg file
Summary: plaympeg crashes with any (?) mpeg file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: SDL   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 47941 51215 51536 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-02 20:39 UTC by Alexandre Oliva
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 09:33:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2001-08-02 20:39:06 UTC
I've got a collection of mpeg files that I could play with plaympeg on Red
Hat Linux 7.1, that will cause plaympeg to crash on roswell, right after it
opens the X window:
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

I tried with both local and remote displays, with the same results.

The stack trace is always similar.  These are from two sample mpeg files:

#0  0x40112083 in _Hermes_X86_CPU () from /usr/lib/libSDL-1.2.so.0
#1  0x08076760 in ?? () at eval.c:41
#2  0x400f9652 in SDL_CreateYUVOverlay () from /usr/lib/libSDL-1.2.so.0
#3  0x4003b781 in MPEGvideo::SetDisplay () at eval.c:41
Cannot access memory at address 0x64

#0  0x40112083 in _Hermes_X86_CPU () from /usr/lib/libSDL-1.2.so.0
#1  0x08069bc0 in ?? () at eval.c:41
#2  0x400f9652 in SDL_CreateYUVOverlay () from /usr/lib/libSDL-1.2.so.0
#3  0x4003b781 in MPEGvideo::SetDisplay () at eval.c:41

Running Red Hat Linux 7.1's plaympeg, with the corresponding version of
SDL, works around the problem.

Comment 1 Bill Nottingham 2001-08-06 22:52:59 UTC
*** Bug 47941 has been marked as a duplicate of this bug. ***

Comment 2 Bill Crawford 2001-08-08 11:12:56 UTC
I can reproduce this with the Raw Hide packages, but they work(ed) fine at home:

[root@fraser root]# rpm -q smpeg SDL
smpeg-0.4.4-2
SDL-1.2.1-4

If it's likely to be relevent, the work machine (where it doesn't work) is a
PII-400 with two ATI cards, the home one a K6-III 400 with a Matrox G400.


Comment 3 Bill Nottingham 2001-08-09 03:51:59 UTC
*** Bug 51215 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2001-08-12 05:13:53 UTC
*** Bug 51536 has been marked as a duplicate of this bug. ***

Comment 5 lethalwp 2001-08-13 13:15:15 UTC
Same problem, crashes on plaympeg (parachute deployed), using latest SDL rpm's of libSDL.org corrects it


Comment 6 lethalwp 2001-08-30 09:26:46 UTC
Tried the SDL-1.2.2-2 of rawhide, same problems it crashes
RH poeple: please change it to the normal SDL-1.2.2-1 where it works fine.
(www.libsdl.org)

Comment 7 Bernhard Rosenkraenzer 2001-08-30 09:33:07 UTC
There is no related difference whatsoever between those files... Which 
compiler did you use to compile 1.2.2-1?


Comment 8 Bill Nottingham 2001-08-31 21:47:58 UTC
Fixed in 1.2.2-3, it appears.


Note You need to log in before you can comment on or make changes to this bug.