Bug 50755 - Unable to see pci devices
Unable to see pci devices
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 16:59 EDT by Arthur Tan
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 12:27:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Tan 2001-08-02 16:59:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)

Description of problem:
Upgrade from 2.4.2-2 kernel to 2.4.3-12 kernel. Running on a IBM netfinity 
7000 quad processor host with 1024 MB of memory. I have 2 Qlogic 2200 and 
an Intel ethernet pro100 nic card in the pci slots. After upgrading 
successfully rebooting the host modules for those cards would not load, 
saying that there are no devices available. I have an adaptec scsi host 
adapter and that loads fine with the aic7xxx module. 

How reproducible:
Always

Steps to Reproduce:
1.Load kernel 2.4.3-12
2.Create new ramdisk and edit lilo.conf to load new kernel
3.Reboot the host
	

Actual Results:  All pci devices are no longer accessible.

Expected Results:  They should still be accessible.

Additional info:

Output from lspci:

00:00.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:00.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:00.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:00.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
00:01.0 PCI bridge: IBM IBM27-82351 (rev 07)
00:0a.0 VGA compatible controller: S3 Inc. Trio 64V2/DX or /GX (rev 16)
00:10.0 Host bridge: Intel Corporation 450NX - 82451NX Memory & I/O 
Controller (rev 03)
00:12.0 Host bridge: Intel Corporation 450NX - 82454NX/84460GX PCI 
Expander Bridge (rev 02)
00:13.0 Host bridge: Intel Corporation 450NX - 82454NX/84460GX PCI 
Expander Bridge (rev 02)
00:14.0 Host bridge: Intel Corporation 450NX - 82454NX/84460GX PCI 
Expander Bridge (rev 02)
01:02.0 Bridge: IBM: Unknown device 00dc (rev 02)
01:04.0 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-
7895 (rev 04)
01:04.1 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-
7895 (rev 04)
Comment 1 Arjan van de Ven 2001-08-02 17:07:04 EDT
I assume you reran lilo (no kidding, some people forget that)
Comment 2 Arthur Tan 2001-08-03 12:01:15 EDT
yup ! I created a new ramdisk and ran lilo after making all the necessary 
changes in lilo.conf.
Comment 3 Arjan van de Ven 2001-08-03 12:22:28 EDT
Ok I've to admit this puzzles me. I don't think the PCI code changed
THAT much between 2.4.2-2 and 2.4.3-12....
Comment 4 Arthur Tan 2001-08-03 14:30:44 EDT
I have other smp host that was upgraded to the 2.4.3-12smp kernel with the same 
set of pci devices and they are running fine. The host are Dell PowerEdge 2400.
Comment 5 Michael K. Johnson 2001-08-23 13:06:51 EDT
Also see Bug #50856
Comment 6 Michael K. Johnson 2001-08-23 14:20:12 EDT
We believe this will be fixed in the next rawhide kernel, 2.4.7-2.8 or
later.  If so, the bug was caused by a fix for another machine with the
450NX chipset...

Note You need to log in before you can comment on or make changes to this bug.