Bug 50856 - Secondary PCI bus not seen on Compaq Proliant 6400
Secondary PCI bus not seen on Compaq Proliant 6400
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-03 18:54 EDT by Andrew Bond
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 13:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output from machine booted with stock 2.4.6 kernel (4.36 KB, text/plain)
2001-08-13 11:48 EDT, Andrew Bond
no flags Details
lspci -v output from machine booted with 2.4.6-3.1smp kernel (4.12 KB, text/plain)
2001-08-13 12:07 EDT, Andrew Bond
no flags Details
lilo.conf (not grub as stated earlier) used to boot linux_ent entry. Initrd file used was the one installed by Enterprise rpm. (599 bytes, text/plain)
2001-08-16 10:41 EDT, Andrew Bond
no flags Details

  None (edit)
Description Andrew Bond 2001-08-03 18:54:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
PCI network card is not seen in secondary PCI bus.  When moved to the
Primary PCI bus it appears.  7.1 on this same Proliant 6400 did not have
this problem.  lspci does not seem to show cards or PCI Hot Plug device
from the secondary PCI bus.  The 6400 is based on a Intel 450NX chipset.

How reproducible:
Always

Steps to Reproduce:
1.Put a PCI card in a secondary PCI bus slot
2.Boot machine
3.OS does not see the card and lspci does not show it
	

Additional info: Machine is located in Compaq lab at Red Hat
Comment 1 Glen Foster 2001-08-06 18:47:23 EDT
This defect is considered MUST-FIX for Fairfax
Comment 2 Arjan van de Ven 2001-08-07 08:42:30 EDT
The fact that it's the hotplug part of the system is interesting.
Is this by chance the enterprise kernel ?
Comment 3 Andrew Bond 2001-08-13 11:48:39 EDT
Created attachment 27533 [details]
lspci -v output from machine booted with stock 2.4.6 kernel
Comment 4 Andrew Bond 2001-08-13 11:55:15 EDT
The install created a -smp kernel entry.  During the install I originally had
the NIC in the secondary PCI bus, and the install did not see it.  That is when
I first noticed the problem.  I moved the NIC to the primary PCI bus to make is
visible.  

All the slots in the Proliant 6400 are Hot Plug.  

I created a kernel from a stock 2.4.6 kernel tree and booted it.  The secondary
PCI bus shows up with that kernel, but does not with the install built
2.4.6-3.1-smp kernel.  I am attaching lspci output from the stock 2.4.6 kernel
and the 2.4.6-3.1-smp kernel.  The stock 2.4.6 kernel shows two PCI-Hot plug
devices, while the 2.4.6-3.1-smp kernel shows just one.
Comment 5 Arjan van de Ven 2001-08-13 11:57:30 EDT
Could you try installing the enterprise kernel ?
That one has hotplug PCI enabled
Comment 6 Andrew Bond 2001-08-13 12:07:28 EDT
Created attachment 27534 [details]
lspci -v output from machine booted with 2.4.6-3.1smp kernel
Comment 7 Andrew Bond 2001-08-16 10:14:47 EDT
Installed Enterprise kernel rpm from CD 1.  It failed to boot with:

freeing unused memory
Kernel Panic  no init found try passing init= to kernel


Ealier boot messages:
pivot_root:pivot_root (/sysroot, /sysroot/initrd) failed:2
error 19 mounting ext2

I created an entry in grub.boot that used the new kernel image and initrd that 
were installed by the rpm.  Maybe I didn't set something up correctly.  Any 
ideas?
Comment 8 Arjan van de Ven 2001-08-16 10:19:15 EDT
Looks like you are using the wrong initrd. The -enterprise kernel installs it's
own initrd, which is different from the smp one.
Comment 9 Andrew Bond 2001-08-16 10:41:45 EDT
Created attachment 28115 [details]
lilo.conf (not grub as stated earlier) used to boot linux_ent entry.  Initrd file used was the one installed by Enterprise rpm.
Comment 10 Andrew Bond 2001-08-22 12:46:02 EDT
-  Tried installing Roswell2 on the machine.  Still didn't see the secondary PCI
bus.
-  Tried booting with the enterprise kernel from Roswell2.  Still didn't see
secondary PCI bus.

The issue is evident at install time because the kernel booted during the
install process does not see the NIC and cciss controller in the secondary bus
and therefore does not allow NIC configuration and does not load the cciss driver.

Went back and started an install from a 7.1 CD and the install saw the NIC and
asked for configuration info, and the cciss driver was loaded during install
kernel boot.  So the kernel on the 7.1CD is seeing the secondary PCI bus correctly.
Comment 11 Michael K. Johnson 2001-08-23 12:07:21 EDT
Have now verified that this behavior was introduced between
2.4.2-2 and 2.4.3-12; 2.4.2-2 shows the full lspci output and
2.4.3-12 has the truncated lspci output that shows nothing on
the secondary bus.
Comment 12 Michael K. Johnson 2001-08-23 12:16:21 EDT
2.4.3-6 kernel works
Comment 13 Michael K. Johnson 2001-08-23 13:02:45 EDT
Also see Bug #50755
Comment 14 Michael K. Johnson 2001-08-23 14:17:48 EDT
Fixed in 2.4.7-2.8 and later

Note You need to log in before you can comment on or make changes to this bug.