Bug 507608 - openoffice.org-ogltrans prints a warning on update
openoffice.org-ogltrans prints a warning on update
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openoffice.org (Show other bugs)
6.0
All Linux
low Severity medium
: beta
: ---
Assigned To: Caolan McNamara
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 09:19 EDT by Alexander Todorov
Modified: 2009-07-02 09:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 503003
Environment:
Last Closed: 2009-07-02 09:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-06-23 09:19:18 EDT
+++ This bug was initially created as a clone of Bug #503003 +++

Description of problem:
When "yum update"ing to the latest openoffice.org-ogltrans, I see the following warning:
grep: /usr/lib64/openoffice.org/extensions/ogltrans.oxt/description.xml: No such file or directory      
  Updating       : 1:openoffice.org-ogltrans-3.1.0-11.3.fc11.x86_64                               29/72 

rpm -q --scripts openoffice.org-ogltrans yields this:
preinstall scriptlet (using /bin/sh):
# deregister old extension if it is still there
unopkg remove --shared `grep identifier /usr/lib64/openoffice.org/extensions/ogltrans.oxt/description.xml | cut -d '"' -f 2` > /dev/null 2>&1 || :

That file doesn't exist, so the grep is printing an error to stderr. Perhaps there should be an output redirection inside the backquotes?

Version-Release number of selected component (if applicable):
openoffice.org-ogltrans-3.1.0-11.3.fc11.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Update to the latest version
  
Actual results:
Warning message

Expected results:
No warning message

--- Additional comment from caolanm@redhat.com on 2009-05-28 06:02:04 EDT ---

indeed

--- Additional comment from fedora-triage-list@redhat.com on 2009-06-09 12:42:41 EDT ---


This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

--- Additional comment from dtardon@redhat.com on 2009-06-15 03:29:44 EDT ---

*** Bug 505981 has been marked as a duplicate of this bug. ***

--- Additional comment from updates@fedoraproject.org on 2009-06-23 03:38:29 EDT ---

openoffice.org-3.1.0-11.4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.0-11.4.fc11
Comment 2 Caolan McNamara 2009-06-23 09:50:22 EDT
Now, that's just a massive pain in my ass, how are we even handling RHEL-6 bugs. Especially as my understanding was that we were importing a some stage during the F-12 cycle, and that's a F-11 OOo, not the latest F-12 one.
Comment 3 Caolan McNamara 2009-07-02 09:29:41 EDT
The consensus seems to be that the way to handle these is to consider rawhide the development branch for RHEL-6 for the moment, i.e. fixed in F-12 branch is fixed, so...

Note You need to log in before you can comment on or make changes to this bug.