Bug 50771 - neat writes the BOOTPROTO setting in all caps, which breaks ifdown on a DHCP interface.
neat writes the BOOTPROTO setting in all caps, which breaks ifdown on a DHCP ...
Status: CLOSED DUPLICATE of bug 50902
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-02 19:16 EDT by Panic
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-03 11:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-08-02 19:16:48 EDT
Description of Problem:

neat writes this configuration in ifcfg-eth0 for a DHCP interface:

BOOTPROTO=DHCP

which ifup handles okay, but ifdown bypasses the interface dropping
sequence for DHCP interfaces and ends up leaving dhcpcd running. 
Essentially, the trap looks like this:

if ["$BOOTPROTO" = bootp -o "$BOOTPROTO" = dhcp ]; then
     [ -n "`pidof -x dhcpcd`" ] && {
          dhcpcd -k ${DEVICE}
          retcode=$?
...

you get the idea.  Point is, when neat sets that BOOTPROTO=DHCP, it evades
this trap and the interface is dropped rather messily, leaving dhcpcd still
running.  

There is also one other error associated with this:

Error: an inet prefix is expected rather than "/".

I'm not sure where that is coming from, but it seems related, and it goes
away when you manually fix the ifcfg-eth0 file.


How Reproducible:

Always

Steps to Reproduce:
1. Configure a DHCP interface with neat. 
2. Note the ifcfg-eth0 file has BOOTPROTO=DHCP
3. try to ifdown eth0, and notice the ipcalc errors and that dhcpcd is
still running after the interface is brought down.

Actual Results:

ifdown spews errors and doesn't kill dhcpcd like it should

Expected Results:

clean interface shutdown, with dhcpcd terminated.

Additional Information:
Comment 1 Bill Nottingham 2001-08-02 22:58:51 EDT
it shouldn't even work on ifup, AFAIK.
Comment 2 Trond Eivind Glomsrxd 2001-08-03 11:01:05 EDT
Will fix.
Comment 3 Trond Eivind Glomsrxd 2001-08-05 15:50:58 EDT

*** This bug has been marked as a duplicate of 50902 ***

Note You need to log in before you can comment on or make changes to this bug.