Bug 50902 - neat saves the config information in capital letters and ifup is looking for small letters
Summary: neat saves the config information in capital letters and ifup is looking for ...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: roswell
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
: 50771 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-04 17:24 UTC by sahag
Modified: 2015-03-05 01:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 11:56:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sahag 2001-08-04 17:24:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
I am using dhcp ethernet connection. When I configure my eth0 adapter in
"neat" as DHCP client it adds the following line to configuration file
/etc/sysconfig/network-scripts/ifcfg-eth0
BOOTPROTO=DHCP

on the other hand the program /sbin/ifup which enables networking at boot
time has the following lines #24-26

if [ "${BOOTPROTO}" = "bootp" -o "${BOOTPROTO}" = "dhcp" ]; then          
                                                                     
DYNCONFIG=true                                                            
                                                              fi

as you can see ifup is doing if BOOTPROTO="dhcp" with small letters while
neat is writing it with capital letters. 

After i changed in /etc/sysconfig/network-scripts/ifcfg-eth0 
DHCP -> dhcp my ethernet connection started to work.


How reproducible:
Always

Steps to Reproduce:
1.try to configure dhcp client connection woth redhat-network-config "neat"

	

Actual Results:  the network was not working

Expected Results:  the network should work

Additional info:

after i replaces DHCP to dhcp everything works perfectly

Comment 1 Trond Eivind Glomsrxd 2001-08-05 19:50:53 UTC
*** Bug 50771 has been marked as a duplicate of this bug. ***

Comment 2 Glen Foster 2001-08-06 22:52:12 UTC
We (Red Hat) really need to fix this defect before next release.

Comment 3 Phil Knirsch 2001-08-07 11:56:21 UTC
Fixed in CVS.


Note You need to log in before you can comment on or make changes to this bug.