Bug 507809 - S-c-tools cleanup: About dialog bugs
S-c-tools cleanup: About dialog bugs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-audit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
: Triaged
: 493820 (view as bug list)
Depends On:
Blocks: 493593
  Show dependency treegraph
 
Reported: 2009-06-24 07:34 EDT by Roman Rakus
Modified: 2014-01-12 19:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-07 09:34:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Appearance of the utility with all tabs in main window (40.61 KB, image/png)
2009-07-29 06:01 EDT, Radek Novacek
no flags Details
Proposed patch that fixes license in the about dialog (2.32 KB, patch)
2009-07-29 07:12 EDT, Radek Novacek
no flags Details | Diff

  None (edit)
Description Roman Rakus 2009-06-24 07:34:21 EDT
Description of problem:
There are few minor bugs with about dialog

How reproducible: 

Steps to Reproduce:
1. Help - About
2. 
3. 

Actual results:
About dialog is centered on screen.
There is bad license text

Expected results:
About dialog centered on parent window (main window)
Right GPL v.2 text.

Additional info:
This bug report is part of "System Configuration Tools Cleanup Project". Don't
hesitate to ask project maintainers for any kind of help.
Comment 1 Radek Novacek 2009-07-29 06:01:13 EDT
Created attachment 355514 [details]
Appearance of the utility with all tabs in main window

I tried to design proposed layout with all tabs in main window but it looks too crowded. Can somebody please check this layout and tell me his opinion before I will try to create fully operational patch? Thanks
Comment 2 Radek Novacek 2009-07-29 06:18:19 EDT
Comment on attachment 355514 [details]
Appearance of the utility with all tabs in main window

I'm sorry, this belongs to bug #507807.
Comment 3 Radek Novacek 2009-07-29 07:12:47 EDT
Created attachment 355527 [details]
Proposed patch that fixes license in the about dialog
Comment 4 Miloslav Trmač 2009-07-29 08:17:47 EDT
Thanks for the patch, I have applied the set_transient_for() addition.

The license text part would change the license from GPLv2 to GPLv2+.  What makes the previous license text "wrong"?
Comment 6 Roman Rakus 2009-08-11 10:00:59 EDT
*** Bug 493820 has been marked as a duplicate of this bug. ***
Comment 7 Bug Zapper 2009-11-16 05:23:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.