Bug 508157 - setroubleshoot: SELinux is preventing hald (hald_t) "getattr" tmpfs_t.
setroubleshoot: SELinux is preventing hald (hald_t) "getattr" tmpfs_t.
Status: CLOSED DUPLICATE of bug 508150
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:724a45cc141...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 16:26 EDT by Antonio A. Olivares
Modified: 2009-06-26 08:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 08:57:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonio A. Olivares 2009-06-25 16:26:53 EDT
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing hald (hald_t) "getattr" tmpfs_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by hald. It is not expected that this access is
required by hald and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:hald_t:SystemLow
Target Context                system_u:object_r:tmpfs_t:SystemLow
Target Objects                /dev/root [ blk_file ]
Source                        hald
Source Path                   /usr/sbin/hald
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           hal-0.5.12-26.20090226git.fc12.3
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.19-4.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.24.rc0.git18.fc12.i586 #1 SMP Mon Jun 22
                              16:26:17 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Thu 25 Jun 2009 03:16:43 PM CDT
Last Seen                     Thu 25 Jun 2009 03:16:43 PM CDT
Local ID                      22505590-c68b-4832-a483-691b1c736eb1
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1245961003.580:149): avc:  denied  { getattr } for  pid=1098 comm="hald" path="/dev/root" dev=tmpfs ino=1252 scontext=system_u:system_r:hald_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=blk_file

node=(removed) type=SYSCALL msg=audit(1245961003.580:149): arch=40000003 syscall=195 success=yes exit=0 a0=bfc88ccc a1=bfc88c4c a2=5ddff4 a3=bfc88c4c items=0 ppid=1 pid=1098 auid=4294967295 uid=68 gid=68 euid=68 suid=68 fsuid=68 egid=68 sgid=68 fsgid=68 tty=(none) ses=4294967295 comm="hald" exe="/usr/sbin/hald" subj=system_u:system_r:hald_t:s0 key=(null)


audit2allow suggests:

#============= hald_t ==============
allow hald_t tmpfs_t:blk_file getattr;
Comment 1 Daniel Walsh 2009-06-26 08:57:31 EDT

*** This bug has been marked as a duplicate of bug 508150 ***

Note You need to log in before you can comment on or make changes to this bug.