Bug 508168 - clock-applet can't get weather because DNS query not passed to proxy
clock-applet can't get weather because DNS query not passed to proxy
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 17:05 EDT by Stefan Jensen
Modified: 2010-06-14 09:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 09:10:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 579434 None None None Never

  None (edit)
Description Stefan Jensen 2009-06-25 17:05:11 EDT
Description of problem:

clock-applet can not get the weather infos, when a proxy is set via "gnome-network-properties"

Version-Release number of selected component (if applicable):

gnome-panel-2.26.2-1.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:

1. launch "clock-applet" and enter a Location
2. enter common proxy-settings via gnome-network-properties
3. log out and in
  
Actual results:

The weather infos in clock-applet are not displayed.

Expected results:

Regular display and updates of weather information, even when connected through a proxy.
Comment 1 Garry 2009-07-01 00:45:23 EDT
This is a bug in the 32 bit release as well, that is, since upgrading from FC10 to FC11 the weather applet does not update.

Version-Release number of selected component (if applicable):

gnome-applets-2.26.2-1.fc11.i586

I am running cntlmd as a local proxy, and if I run it in the foreground I can not see any access when I try to update the weather. Proxy settings were not changed during or after the upgrade, and I am using the cntlmd proxy for Firefox OK. 

It might be a Gnome proxy issue rather than weather applet, but I am not sure how to test it.

--Garry.
Comment 2 Garry 2009-07-09 18:49:27 EDT
I have a workaround for this.

I did a tcpdump while trying to update the weather applet, and noticed that it triggered a DNS lookup for www.bom.gov.au, the Bureau of Meteorology in Australia, but it never got a DNS result as our internal DNS servers only serve addresses for my organisation. So I added www.bom.gov.au to the /etc/hosts file, and I could now see the local weather forecast.

However, the applet does another lookup to weather.noaa.gov, I think it is to get the icons for the weather, so I added that to /etc/hosts too, and also the domain name for the radar map, and everything works. In total, I added the following to /etc/hosts:

134.178.63.140 www.bom.gov.au
134.178.63.141 www.bom.gov.au
140.90.128.70 weather.noaa.gov
203.63.53.112 mirror.bom.gov.au

Off course, if you are not in Australia you will have to work out your own local entries to add using tcpdump, and I had to jump on to an Internet connected computer to find out the IP addresses for the domains.

The weather icon in the clock works too now.

So the issue was not with the proxy code, but the fact that when using a proxy it still tried to do a DNS lookup instead of just passing the domain name to the proxy and letting the proxy connect. This was exacerbated by the fact that our organisation does not allow desktops to do DNS lookups to Internet hosts. 

--Garry
Comment 3 William Lovaton 2009-07-21 09:06:06 EDT
I'm having this problem too!.

I'm using the only proxy available at my work place to browse the Internet.  This very same configuration used to work fine in Fedora 10 and now that I installed Fedora 11, the weather information is not available anymore.
Comment 4 William Lovaton 2009-07-24 08:50:48 EDT
It seems that libgweather-2.26.2.1-1.fc11.i586 applied from yesterday's update fixed the problem for me.  Now I can see the weather information as soon as I log into my Gnome session.

Can someone else confirm this? I think we can close this bug report.
Comment 5 Stefan Jensen 2009-07-25 11:31:01 EDT
Can't confirm on X86_64. Still no weather info, through proxy, no dns-lookup or proxy hit are in the logs.
Comment 6 Christopher Beland 2010-01-25 11:51:29 EST
Just a note that Bug 541556 in Fedora 12 (which does not involve proxies) has the same symptoms, which may complicate diagnosis.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2010-04-27 11:15:26 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Dan Winship 2010-06-14 09:10:49 EDT
This was fixed in F12. (via libsoup 2.28)

Note You need to log in before you can comment on or make changes to this bug.