Bug 508189 - "/sbin/grub-install /dev/cciss/c0d0" results in unbootable system
"/sbin/grub-install /dev/cciss/c0d0" results in unbootable system
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 19:19 EDT by Ben Webb
Modified: 2010-06-28 09:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:18:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Webb 2009-06-25 19:19:17 EDT
Description of problem:
If I run
/sbin/grub-install /dev/cciss/c0d0
to install GRUB, it complains

expr: non-numeric argument

and if I then reboot, the system hangs, displaying only "GRUB".


Version-Release number of selected component (if applicable):
grub-0.97-50.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. /sbin/grub-install /dev/cciss/c0d0
  
Actual results:
I get the following output:
# /sbin/grub-install /dev/cciss/c0d0
expr: non-numeric argument
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

# this device map was generated by anaconda
(hd0)     /dev/cciss/c0d0

If I reboot, the system prints simply "GRUB" and hangs.


Expected results:
Bootable system.

Additional info:
The OS is installed on an HP Smart Array Controller, device /dev/cciss/c0d0 and the following partitions:
/dev/cciss/c0d0p1      3020140    301340   2565384  11% /
/dev/cciss/c0d0p3     12096756    721628  10760644   7% /usr
/dev/cciss/c0d0p2     12096756    531176  10951096   5% /var

The problem is in the script's attempt to break up the device name into a disk and partition, for use by GRUB. (If I run instead /sbin/grub-install '(hd0)' everything works fine.) The regular expression to populate $tmp_part does not match (line 120 in my copy) so $tmp_part ends up as "/dev/cciss/c0d0" rather than "". Obviously that is an invalid partition number, and so later on the script tries to install GRUB on (hd0,) rather than (hd0).

I can fix the problem by adding
         if echo $tmp_part | grep "^/dev" >/dev/null; then
           tmp_part=""
         fi
immediately after the regular expression that populates $tmp_part, but this doesn't seem like the cleanest solution to me.
Comment 1 Raina Otoni 2009-09-09 10:09:24 EDT
I also reproduced this bug.
Same bug in RHEL is closed errata.
 https://bugzilla.redhat.com/show_bug.cgi?id=402151
This patch should apply Fedora's grub package.

Fedora 11
grub version: grub-0.97-51.fc11.i586
RAID Controller: SmartArray E200

/dev/mapper/VolGroup00-LogVol00 215G  6.2G  198G   4% /
/dev/cciss/c0d0p1     190M   28M  153M  16% /boot
Comment 3 Bug Zapper 2010-04-27 11:15:49 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2010-06-28 09:18:01 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.