Bug 50822 - vfat filesystems are not nfs-exportable
Summary: vfat filesystems are not nfs-exportable
Status: CLOSED DUPLICATE of bug 50820
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-03 17:20 UTC by Marty Shannon
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 15:44:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marty Shannon 2001-08-03 17:20:11 UTC
Description of Problem:
summary covers it

How Reproducible:
100%

Steps to Reproduce:
1. make a vfat filesystem
2. add it to /etc/exports
3. exportfs -a
4. attempt to mount it from another machine

Actual Results:
client gets EPERM;
server logs permission denied

Expected Results:
it should be able to be mounted

Additional Information:
It is claimed that user-space nfsd can export vfat filesystems; if so, then
knfsd should be able to as well.

Comment 1 Bob Matthews 2001-08-06 15:44:26 UTC
Oops, wrong component.

Comment 2 Glen Foster 2001-08-06 21:03:09 UTC
This is a side-effect of bug 50820

*** This bug has been marked as a duplicate of 50820 ***


Note You need to log in before you can comment on or make changes to this bug.