This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 508302 - gnome-rdp tries to use tightvncviewer when setup to make a vnc protocol connection
gnome-rdp tries to use tightvncviewer when setup to make a vnc protocol conne...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-rdp (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: John Anderson
Fedora Extras Quality Assurance
:
: 510889 512704 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 09:29 EDT by Michael Kearey
Modified: 2009-07-24 15:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.2.3-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 15:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Kearey 2009-06-26 09:29:59 EDT
Description of problem:
gnome-rdp application in set to use tightvncviewer to launch a VNC protocol connection. tightvnc is not in the Fedora repo's, _tigervnc_ is. Tiger VNC has vncviewer

Version-Release number of selected component (if applicable):
gnome-rdp-0.2.3-3.fc11

How reproducible:
100%

Steps to Reproduce:
1. yum install gnome-rdp -y
2. run gnome-rdp
3. Create a session, set it to use VNC protocol
4. Start the session by double clicking it
  
Actual results:
Session does not start, and a popup appears :

xtightvncviewer seems not to be installed.

In addition, console messages :

$ gnome-rdp 
ApplicationName='vncpasswd', CommandLine='/tmp/tmp5689b522.tmp', CurrentDirectory='/'
 -viewonly  -passwd /tmp/tmp5689b522.tmp localhost
ApplicationName='xtightvncviewer', CommandLine=' -viewonly  -passwd /tmp/tmp5689b522.tmp localhost', CurrentDirectory='/'



Expected results:
Should create a vncviewer process

Additional info:
Quick look at the source shows the use of tightvncviewer in src/Main.cs file:


   320                 Console.WriteLine(par);
    321                                 prc = new ProcessCaller(
    322                                         "xtightvncviewer", 
    323                                         par, 
    324                                         "/", 
    325                                         false,
    326                                         config.Password, 
    327                                         this.wndMain);
    328                                 prc.StartProcess();
    329                         }



I think a small change , replacing tightvncviewer with 'vncvier'  will fix the problem.
Comment 1 Fedora Update System 2009-07-02 22:04:10 EDT
mumbles-0.4-11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/mumbles-0.4-11.fc11
Comment 2 John Anderson 2009-07-02 22:19:00 EDT
Sorry about the mistaken update tag.

I tried changing the xtightvncviewer as suggested, however this launches the vncviewer but does not hand off the password correctly. I'll look into this deeper and see if I can get it going using tiger.
Comment 3 Fedora Update System 2009-07-02 23:00:36 EDT
gnome-rdp-0.2.3-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/gnome-rdp-0.2.3-4.fc11
Comment 4 John Anderson 2009-07-02 23:02:48 EDT
I had to make the modification and include both tigervnc and tigervnc-server (for vncpasswd). It appears to be functional now.
Comment 5 Fedora Update System 2009-07-11 12:59:40 EDT
gnome-rdp-0.2.3-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-rdp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7429
Comment 6 John Anderson 2009-07-12 08:47:21 EDT
*** Bug 510889 has been marked as a duplicate of this bug. ***
Comment 7 John Anderson 2009-07-23 20:17:26 EDT
*** Bug 512704 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2009-07-24 15:38:45 EDT
gnome-rdp-0.2.3-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.