Bug 508397 - Display goes black temporarily every few hours
Display goes black temporarily every few hours
Status: CLOSED DUPLICATE of bug 501601
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 17:15 EDT by Leif Gruenwoldt
Modified: 2009-07-23 10:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 23:49:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg taken a couple minutes after a screen blackout (118.94 KB, text/plain)
2009-07-08 16:52 EDT, Leif Gruenwoldt
no flags Details
xorg log taken minutes after a screen blackout (326.94 KB, text/plain)
2009-07-08 16:52 EDT, Leif Gruenwoldt
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 349019 None None None Never

  None (edit)
Description Leif Gruenwoldt 2009-06-26 17:15:57 EDT
Description of problem:

In the middle of using my desktop my two displays will go black. Then one or two seconds later the displays will come back on and I can continue on working as normal.


Version-Release number of selected component (if applicable):

$ rpm -q xorg-x11-drv-ati
xorg-x11-drv-ati-6.12.2-14.fc11.i586

How reproducible:

Happens at least once a day at my 9-5 job.


Steps to Reproduce:
1. login to gnome desktop
2. use computer
3. wait!
  
Actual results:

Screen goes black for a second every few hours.


Expected results:

Not to go black.


Additional info:

1. In /var/log/messages

Jun 25 15:53:28 jug kernel: [drm] Resetting GPU
Jun 25 15:53:31 jug kernel: [drm] Loading RV630 CP Microcode
Jun 25 15:53:31 jug kernel: [drm] Loading RV630 PFP Microcode
Jun 25 15:53:31 jug kernel: [drm] Resetting GPU

2. /etc/X11/xorg.conf is empty

3. $ lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc M76 [Radeon Mobility HD 2600 Series]
01:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device [Radeon HD 2600 Series]
Comment 1 Leif Gruenwoldt 2009-06-30 11:02:54 EDT
Those "kernel: [drm] Resetting GPU" messages are seem to be triggered by system suspend/resumes not my screen "blackout" problems. I will try to gather info that might be useful.
Comment 2 Matěj Cepl 2009-06-30 18:12:18 EDT
Similar, but probably different bug is bug 508513.
Comment 3 Matěj Cepl 2009-06-30 18:13:53 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Gianluca Sforna 2009-07-07 17:23:53 EDT
This looks like a duplicate of bug 501601
Comment 5 Leif Gruenwoldt 2009-07-08 16:52:25 EDT
Created attachment 350991 [details]
dmesg taken a couple minutes after a screen blackout
Comment 6 Leif Gruenwoldt 2009-07-08 16:52:53 EDT
Created attachment 350992 [details]
xorg log taken minutes after a screen blackout
Comment 7 Leif Gruenwoldt 2009-07-08 16:53:08 EDT
And my xorg.conf is empty.
Comment 8 Adam Huffman 2009-07-10 06:15:57 EDT
I've seen this on my desktop with an HD4850 card.

When it happened this morning, some vertical lines appeared on the main monitor once the display had resumed, which didn't go away until I rebooted.
Comment 9 Leif Gruenwoldt 2009-07-22 23:49:37 EDT

*** This bug has been marked as a duplicate of bug 501601 ***
Comment 10 Leif Gruenwoldt 2009-07-22 23:52:39 EDT
Just to be clear now that I've seen bug #501601, pressing a key or moving the mouse does indeed bring the screen back right away.
Comment 11 Gianluca Sforna 2009-07-23 02:58:49 EDT
So it's not a duplicate isn't it?
Comment 12 Leif Gruenwoldt 2009-07-23 10:00:17 EDT
(In reply to comment #11)
> So it's not a duplicate isn't it?  

It's a duplicate in the sense that Adam Jackson (bug #501601#c42) had decided to use that one bug for both cases where the screen does and doesn't come back on with mouse/key input.
Comment 13 Leif Gruenwoldt 2009-07-23 10:02:00 EDT
(In reply to comment #12)
> Adam Jackson

s/Jackson/Williamson

Note You need to log in before you can comment on or make changes to this bug.