Bug 508513 (brown-xorg) - Desktop is loosing brightness and colors when screen-saver activates
Summary: Desktop is loosing brightness and colors when screen-saver activates
Status: CLOSED RAWHIDE
Alias: brown-xorg
Product: Fedora
Classification: Fedora
Component: gnome-screensaver
Version: rawhide
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 508450 509185 (view as bug list)
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-06-28 07:19 UTC by Steve
Modified: 2018-04-11 11:55 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-08-18 19:49:36 UTC


Attachments (Terms of Use)
Log-in-screen after losing collors and brightness (2.43 MB, image/jpeg)
2009-06-28 07:19 UTC, Steve
no flags Details
Desktop after losing collors and brightness (2.53 MB, image/jpeg)
2009-06-28 07:21 UTC, Steve
no flags Details

Description Steve 2009-06-28 07:19:41 UTC
Created attachment 349689 [details]
Log-in-screen after losing collors and brightness

Description of problem:
Desktop is loosing brightness and colors when screen-saver activates. There is no information in the log-files about this issue.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.6.99-6.20090618.fc12.i586
xorg-x11-xinit-1.0.9-11.fc12.i586
xorg-x11-drv-ati-6.12.2-19.fc12.i586

How reproducible:
Always when screen-saver activates.

Steps to Reproduce:
1.Startup system and log-in
2.Lock the screen to loosing colors and brightness
3.Restart X to return to normal colors and brightness
  
Actual results:


Expected results:


Additional info:
Another picture follows..

Comment 1 Steve 2009-06-28 07:21:17 UTC
Created attachment 349690 [details]
Desktop after losing collors and brightness

Comment 2 Yanko Kaneti 2009-06-28 09:24:08 UTC
Tested previous xorg-x11-server releases. This regression happened between 1.6.1.901-4 and 1.6.99-2  everything else (barring evdev) the same.
radeon here as well, latest rawhide.

to reproduce 
gnome-screensaver-command -a

I'll move it to xorg-x11-server

Comment 3 Yanko Kaneti 2009-06-28 14:28:44 UTC
Specifically its caused by the fading. The same effect is achieved by running test-fade from the gnome-screensaver sources.

Comment 4 Adam Jackson 2009-06-29 21:31:11 UTC
I'm going to go out on a limb and say that 'xgamma -gamma 1.0' fixes this, in which case it's a gnome-screensaver bug, not an X bug.

Comment 5 Yanko Kaneti 2009-06-29 22:04:45 UTC
Yes it does, this to fix after the screwup. Thanks
$ xgamma -gamma 1.0
-> Red  0.100, Green  0.100, Blue  0.100
<- Red  1.000, Green  1.000, Blue  1.000

Comment 6 Steve 2009-06-30 06:27:27 UTC
Yes, this is the workaround.

gnome-screensaver-2.27.0-1.fc12.i586

Comment 7 Matěj Cepl 2009-06-30 22:08:20 UTC
*** Bug 508450 has been marked as a duplicate of this bug. ***

Comment 8 Matěj Cepl 2009-06-30 22:13:19 UTC
Similar, but probably different bug is bug 508397.

Comment 9 Yanko Kaneti 2009-07-01 20:22:37 UTC
*** Bug 509185 has been marked as a duplicate of this bug. ***

Comment 10 Steve 2009-07-03 06:30:04 UTC
The problem is not fixed in gnome-screensaver-2.27.0-2.fc12.i586.

Comment 11 Aioanei Rares 2009-07-21 06:47:08 UTC
It's not a driver issue, I guess, since I have Nvidia card and I encounter the same behaviour.

Comment 12 Adam Jackson 2009-08-18 19:49:36 UTC
Should be fixed in 2.27.0-9.  Please test and reopen if not.


Note You need to log in before you can comment on or make changes to this bug.