Bug 508513 - (brown-xorg) Desktop is loosing brightness and colors when screen-saver activates
Desktop is loosing brightness and colors when screen-saver activates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 508450 509185 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-06-28 03:19 EDT by Steve
Modified: 2015-01-14 18:23 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 15:49:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log-in-screen after losing collors and brightness (2.43 MB, image/jpeg)
2009-06-28 03:19 EDT, Steve
no flags Details
Desktop after losing collors and brightness (2.53 MB, image/jpeg)
2009-06-28 03:21 EDT, Steve
no flags Details

  None (edit)
Description Steve 2009-06-28 03:19:41 EDT
Created attachment 349689 [details]
Log-in-screen after losing collors and brightness

Description of problem:
Desktop is loosing brightness and colors when screen-saver activates. There is no information in the log-files about this issue.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.6.99-6.20090618.fc12.i586
xorg-x11-xinit-1.0.9-11.fc12.i586
xorg-x11-drv-ati-6.12.2-19.fc12.i586

How reproducible:
Always when screen-saver activates.

Steps to Reproduce:
1.Startup system and log-in
2.Lock the screen to loosing colors and brightness
3.Restart X to return to normal colors and brightness
  
Actual results:


Expected results:


Additional info:
Another picture follows..
Comment 1 Steve 2009-06-28 03:21:17 EDT
Created attachment 349690 [details]
Desktop after losing collors and brightness
Comment 2 Yanko Kaneti 2009-06-28 05:24:08 EDT
Tested previous xorg-x11-server releases. This regression happened between 1.6.1.901-4 and 1.6.99-2  everything else (barring evdev) the same.
radeon here as well, latest rawhide.

to reproduce 
gnome-screensaver-command -a

I'll move it to xorg-x11-server
Comment 3 Yanko Kaneti 2009-06-28 10:28:44 EDT
Specifically its caused by the fading. The same effect is achieved by running test-fade from the gnome-screensaver sources.
Comment 4 Adam Jackson 2009-06-29 17:31:11 EDT
I'm going to go out on a limb and say that 'xgamma -gamma 1.0' fixes this, in which case it's a gnome-screensaver bug, not an X bug.
Comment 5 Yanko Kaneti 2009-06-29 18:04:45 EDT
Yes it does, this to fix after the screwup. Thanks
$ xgamma -gamma 1.0
-> Red  0.100, Green  0.100, Blue  0.100
<- Red  1.000, Green  1.000, Blue  1.000
Comment 6 Steve 2009-06-30 02:27:27 EDT
Yes, this is the workaround.

gnome-screensaver-2.27.0-1.fc12.i586
Comment 7 Matěj Cepl 2009-06-30 18:08:20 EDT
*** Bug 508450 has been marked as a duplicate of this bug. ***
Comment 8 Matěj Cepl 2009-06-30 18:13:19 EDT
Similar, but probably different bug is bug 508397.
Comment 9 Yanko Kaneti 2009-07-01 16:22:37 EDT
*** Bug 509185 has been marked as a duplicate of this bug. ***
Comment 10 Steve 2009-07-03 02:30:04 EDT
The problem is not fixed in gnome-screensaver-2.27.0-2.fc12.i586.
Comment 11 Aioanei Rares 2009-07-21 02:47:08 EDT
It's not a driver issue, I guess, since I have Nvidia card and I encounter the same behaviour.
Comment 12 Adam Jackson 2009-08-18 15:49:36 EDT
Should be fixed in 2.27.0-9.  Please test and reopen if not.

Note You need to log in before you can comment on or make changes to this bug.